Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Clean 2.6 Install > Dashboard URLs = Something Wrong

Trying without success to update my main live forum to 2.6
(Was initially displaying 500 errors so worth a shot. Files and DB backed up prior to update attempt)

Set up a dev forum subdirectory for a clean install.

  • Renamed and edited htaccess to reflect correct subdirectory
  • Forum Installed. Taken to */forumnew/settings/gettingstarted - OK
  • */forumnew/dashboard/settings/home - "Something has gone wrong" error
  • */forumnew/dashboard/settings/branding - "Something has gone wrong" error
  • */forumnew/dashboard/message - Tested and working
  • Set debug to 'true' in config.php
  • Looked through the community posts, can't find anything similar

Still none the wiser.

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    What was the error report when you set debug to true?

  • Where would I see the debug message?

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Typically, when you set debug to true, you should see a detailed error report in place of the 'Something has gone wrong' message in your browser.

  • Just checked the URL and it’s the same “Something is wrong” message.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited June 20

    Then debug isn't set correctly, I would say, or you have a cache issue stopping you seeing the change.

  • Ok as soon as I’m back on my computer (on my phone right now) I’ll clear the cache and update this post.

    Thanks for the assist so far.

  • Cleared the cache folder apart from the htaccess file - still showing the same error message.

    Double checked debug is set to true: https://i.imgur.com/bMmha6P.png (assuming that's the correct setting

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Just to confirm, you are editing config. php

  • Correct. config.php

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Sorry, I'm officially baffled, so it feels like time to mention @R_J

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Some things working and some other not could be a hint for not fulfilling the requirements. Could you please dive into the readme and make sure that your setup satisfies the requirements?

    If yes, what platform and what versions of php and mysql are you using?

  • Hi @R_J

    Server OS: CentOS 7.5 KVM
    WHM: 70.0.51
    Apache: 2.4.33
    PHP: 7.0
    MySQL: 10.1.34-MariaDB

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    And do you have the php extension mbstring enabled?

    For test environments, you can edit the /index.php and search for ini_set('display_errors', 0); and change it to ini_set('display_errors', 1);, but remeber to change it to zero again as soon as possible

  • I checked EasyApache in my WHM and PDO and CURL were already installed for PHP7.0 and I just had my host support install mbstring.

    I'm not testing this on a live forum right now as I'm aiming to migrate all the previous posts and users over via a MySQL import (hopefully)

    I've changed "ini_set" and there are no errors showing.

    And it's definitely the correct index.php I've edited.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The screenshot above shows that you have added 'Garden']['Debug'] = true; to the config-defaults.php.

    1. Please make sure that you have $Configuration['Garden']['Debug'] = true; as your last line in "/conf/config.php"
    2. Clear all files in the /cache folder
    3. Visit your forum with the privacy mode of your browser
  • If you are on cPanel, the default .htaccess file did not work for me at all. Can you post your .htaccess file between these characters:
    ~~~ <your .htaccess file> ~~~

  • @R_J I had renamed config-defaults.php to config.php and manually entered the various DB connecting settings.

    Cache folder = unable to completely clear the cache via FTP or CPanel File Manager as I cannot delete the 'Smarty' and 'theme' folders and some files within 'theme' due to permission being denied for some reason (screenshot attached)

    @donovanb the .htaccess is the default one that comes with 2.6 apart from me changing the first line to # Modified and 'Rewritebase /forumnew'

    I couldn't get the whole .htaccess file to display properly in the comment so I've added it here:

    https://pastebin.com/xhMa9MvQ

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The config.php will automatically be created during the installation process. The config-defaults file should never be touched nor copied.
    And the db information must be entered during the setup process which starts when you first visit the page. You only have to copy all files and rename the htaccess, keep the db information at hand and follow the (few) instructions during the web based installation process

  • @camstudio cPanel adds it's own .htaccess file to get PHP7 to work (for it's multi-php feature)... did you delete that?
    If you open up shell and go to the directory of your forum and type:
    php -v
    You can be sure of what php version you are running in that directory. (without the .htaccess entry by WHM, your mult-php entry may be lying to you).

    Anyway, here is my working .htaccess with WHM v68.0.36 and Vanilla 2.6.. note the cPanel PHP part.

    Hope this helps:

    # Modified
    # If you modify this file then change the above line to: # Modified
    
    <IfModule mime_module>
      AddType application/x-httpd-ea-php70 .php .php7 .phtml
    </IfModule>
    
    DirectoryIndex index.php
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
        # Certain hosts may require the following line.
        # If vanilla is in a subfolder then you need to specify it after the /.
        # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
        # RewriteBase /
    
        DirectoryIndex disabled
    
        RewriteRule (^|/)\.git - [L,R=403]
        RewriteRule ^cache/ - [L,R=403]
        RewriteRule ^cgi-bin/ - [L,R=403]
        RewriteRule ^uploads/import/ - [L,R=403]
        RewriteRule ^vendor/ - [L,R=403]
    
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    
    <IfModule mod_headers.c>
       <FilesMatch "(?<!embed)\.(css|js|woff|ttf|eot|svg|png|gif|jpeg|jpg|ico|swf)$">
          Header set Cache-Control "max-age=315360000"
          Header set Expires "31 December 2037 23:59:59 GMT"
       </FilesMatch>
    </IfModule>
    
  • @donovanb @R_J

    Apologies for the delay ...

    Decided to wipe that installation and start again using the info from this thread.

    • Confirmed PHP7 via SSH and PHPInfo (screenshots attached)
    • Installed a new v2.6 to a subdirectory (used donovanb's htaccess as I got a 404 for the dashboard/setup URL)
    • Edited the rewritebase line to the correct subdirectory (although seemed to work OK without it)!
    • Cleared cache (screenshot attached)
    • Set debug to true in config.php (screenshots attached)

    Installed fine. Dashboard settings URL still broken - no error details shown in browser (same as before).

    Now unable to completely clear cache via CPanel File Manager or FTP - I now get Permission Denied messages (attached)

    Any thoughts?

  • You may have correct some permissions on your file structure.

  • I double checked the conf, cache and uploads folders and they're set to 777 (writable)

    Logged in as root via Terminal and managed to delete the folders and all files in cache.

    Logged back into the forum via incognito browser, same error with Dashboard Settings Home > no error output

  • can you post the output of ls -la in your terminal when at the root of your forum?

  • @camstudio

    not sure which version you are trying to upgrade from, but I recently resolved a similar issue, almost identical.

    1. export my old db using Navicat (skip since you already have your db)
    2. create a new mysql database on new server (skip)
    3. Import the db onto new server using navicat again (skip)
    4. created another mysql database
    5. upload 2.6 files, and copy .htaccess file from your OLD directory, into the new one (without doing this, on my server at least, i'd constantly get that error)
    6. visit the forum directory and install 2.6
    7. drop GDN_Permission and GDN_Role using phpmyadmin, from old db (not sure of the version you're upgrading from, so you can possibly skip 7 and 8)
    8. grab GDN_Permission and GDN_Role from the fresh 2.6 install, and import them into
      old db
    9. change config.php in 2.6 to point towards old db
    10. run /utility/update and /utility/structure
    11. completed.

    Personally, I did not have to adjust any directory permissions, and they were all pre-set. After following these steps, I managed to get a fully functioning 2.6, upgraded from 2.0.18.1. Hope I can help (although i'm not expert like these other guys)

  • @StaticCory - thanks for taking the time to post that. I'm doing this from a fresh install but if I can't get any further, I'll test your method and let you know =)

  • donovanbdonovanb
    edited July 5

    Thx... sorry, one of things I was trying to determine by you posting that output was if you were using suPHP or suexec in your cPanel environment... which I could likely tell by if your user and group are of the same account. You have them blotched out.. so I'll assume you are.

    Seems to me its something to do with your rewrite ability in certain situations.. which could be perms or config. Some questions:

    • Once you delete the cache, do they cache files come back after plunking around on your forum?
    • Are the user:group the same throughout your directory tree?.. or do you have a different owner from group?
    • You could maybe try running this cPanel script as root, which auto-sets some perms per account:
      /usr/local/cpanel/scripts/enablefileprotect

    Docs for above:
    https://documentation.cpanel.net/display/EA4/The+EasyApache+4+FileProtect+Option

    (It appears that action of turning it off and on messes with the global perms.. so if you have other important accounts on your cpanel install, you may want to consult cPanel support directly)

    For what it's worth, I use 755 / 644, suexec.

    You are using a bit newer version of WHM than I.. so maybe the .htaccess file I posted is not perfect??

    Without knowing details, that's all I can think of.

    Donovan

  • Try to recreate the problem and be aware of the time
    From your Cpanel or FTP client navigate to
    /home/yourusername/public_html
    There you will find a file called "error_log" without an extension
    Download the file and open it with your favorite text editor
    You should be able see the error message there at the exact timestamp
    From there you will see the exact reason what is missing and needs to be added.

Sign In or Register to comment.