Unable to see existing threads after update

Hi
Unless you register and/or log in you now no longer see the discussion threads that exist on my well established forum... What did I do wrong?
http://vwlt.co.uk/forum/
Thanks

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Check if you have $Configuration['Garden']['PrivateCommunity'] = true; in your /conf/config

    It is also possible that you have revoke the view permissions from guest role


  • Added that line which was missing but no change

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    No, you shouldn't set "Private" = true, because that would exclude guests from your forum, therefore you should have checked that :lol:

    If you want to add something to your config, add $Configuration['Garden']['PrivateCommunity'] = false;.

    Have you checked the permissions of the guest roles? You can also set individual permissions per category so that shoul be checked, too


  • @R_J said:
    Have you checked the permissions of the guest roles? You can also set individual permissions per category so that shoul be checked, too

    I don't know how to do this?

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    You have to go to "your_forum.com/dashboard/role" and click the dit symbol of the guest role.

    End the end of the screen you will find the "View" permissions for the categories:

    You see that there is a default category and three of my categories (I have silly names in my test forum: GROUP, UND, MODERATORENBEREICH) have individual permissions and you have to check this settings, too.


  • I don't have that - I have this:

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Please run yourforum.com/utility/structure


  • Done. Here's my Roles screen:

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    This should have nothing to do with your problem, but you need to set the default roles. Edit each role and pick the correct one


  • Hi
    I'm still stuck with this and would like to pay someone to fix this. How do I do that?
    Thanks

  • I'm having the exact same problem.

    Heres what I have found so far.

    . After updating from 2.5 (php5.6) to 2.6.4 (php7.0), every time I logout a "No Categories/Discutions were found." message appear.

    . After running myforum.com/utility/structure I get this every time (not sure what to do with it).


    alter table GDN_UserAuthenticationNonce
    -- [Existing: Timestamp timestamp not null default CURRENT_TIMESTAMP, New: Timestamp timestamp not null]
    change Timestamp Timestamp timestamp not null;

    alter table GDN_UserAuthenticationToken
    -- [Existing: Timestamp timestamp not null default CURRENT_TIMESTAMP, New: Timestamp timestamp not null]
    change Timestamp Timestamp timestamp not null;

    alter table GDN_AccessToken
    -- [Existing: DateInserted timestamp not null default CURRENT_TIMESTAMP, New: DateInserted timestamp not null default current_timestamp]
    change DateInserted DateInserted timestamp not null default current_timestamp,
    -- [Existing: DateExpires timestamp not null default CURRENT_TIMESTAMP, New: DateExpires timestamp not null default current_timestamp]
    change DateExpires DateExpires timestamp not null default current_timestamp;

    update GDN_User User
    set Permissions = ''
    where Permissions <> '';

    insert GDN_UserMeta
    (UserID, Name, Value)
    values ('0', 'stubcontent.record.locale', 'en');


    . I recovered my old 2.5 version to find that it was the same problem with php 7.0 (I did check that my server has all the required stuff).

    . Tried to go back to php 5.6 and everything is working again.

    I did try a fresh install and the above problem persists.

    When I try to a change users roles I get this:

    Thanks

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @maldonadoxico that PHP version hint looks promising! I'm trying to help @timaldiss and he is also using PHP 7.0 and there are really srange behaviors that I cannot explain.
    I (as a user with the admin role) cannot see any categories in the dashboard, although I cannot see any problems in the database concerning GDN_Role, GDN_Permission, GDN_Category and GDN_UserRole
    Can you go from PHP7.0 to 7.1 or above?
    (And don't mind about that utility/structure left overs, they will always appear)

    @aajake13 @our420room
    Which PHP version do you use? Is it 7.0? If yes, do you have the possibility to upgrade to a newer PHP version? If yes, please do, retry and give feedback. Your problem might be connected to this one:


  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @maldonadoxico @aajake13 @our420room
    @timaldiss just reported back that a PHP version upgrade to 7.1 solved his problem


  • Hi, I can confirm that it works with PHP 7.1 and 7.2 for me to.
    Thanks for the help.

Sign In or Register to comment.