php7.3

Hello,
My provider offers me to go to php7.3.
Can Vanilla support this evolution of php?
Best regards

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    I bet Vanilla will support it. But as far as I know it hasn't been officially tested right now. PHP 7.3 is only two weeks old, so it would be a little bit hasty.

    You can do one of two things:
    1. Stick with 7.2 for now and there's nothing wrong with that. In most cases I'd recommend that.
    2. Read about the changes in 7.3, upgrade your servers PHP version and give feedback as soon as you experience problems which are based on the new PHP version. That's a possibility to support the developers and "give something back".


  • @R_J a dit :
    I bet Vanilla will support it. But as far as I know it hasn't been officially tested right now. PHP 7.3 is only two weeks old, so it would be a little bit hasty.

    You can do one of two things:
    1. Stick with 7.2 for now and there's nothing wrong with that. In most cases I'd recommend that.
    2. Read about the changes in 7.3, upgrade your servers PHP version and give feedback as soon as you experience problems which are based on the new PHP version. That's a possibility to support the developers and "give something back".

    Thank you very much for your quick reply,
    I will not take the risk of putting php7.3.
    I will ask my provider to leave with 7.2.
    No risky
    Best regards

  • LincLinc Director of Development Detroit Vanilla Staff

    Vanilla 7.3 should work fine, but we haven't even started the Travis (automated testing) builds for it yet, so I'd hold off on running it in production for a month unless you're very confident about diagnosing issues. I'm sure we'll get it officially supported in January.

Sign In or Register to comment.