Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Unknown column Active in field list



  • Options

    Finally, it's solved... I don't have a words. 4 days I can't sleep properly. At last.

    I've created a new column.

      ADD COLUMN `Active` TINYINT(4) AFTER `ThumbPath`;

    And the error message dissapear!

    Thank you All, folks. I appreciate your help.

  • Options
    steamsteam - #1 foro planes amigo
    edited March 2019

    I had same issue after update from vanilla 2.6 to 2.8.1 and error disappear after Alter table.

    Thank you very match!

  • Options
    charrondevcharrondev Developer Lead (PHP, JS) Montreal Vanilla Staff

    Did you guys run a utility/update during the upgrade process? There a few steps required to successfully complete the upgrade.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    As far as I know in that step no column should be removed, which is okay since it might be used by a plugin even if not needed any more by Vanilla

  • Options
    charrondevcharrondev Developer Lead (PHP, JS) Montreal Vanilla Staff
  • Options
    R_JR_J Ex-Fanboy Munich Admin

    So weird: I seem to misunderstand everyone who is speaking about that column and the problems connected with it 🙄

  • Options

    @noszone - Could you explain exactly what you did to fix the problem? For example, what file did you alter? Where did you put that "ALTER TABLE" code?

    I'm having the same problem.


  • Options

    Thanks @noszone - that alter fixed my issue as well

    @leftbrain - it's a SQL command, if you have phpmyadmin installed you can run it from there in the SQL tab of your database.

  • Options
    edited September 2019

    I encountered the same issue after upgrading from 2.6->3.0->3.1->3.2.

    It would happen when I edited a post. I'd try to save, get the error, would have to cancel and then would see that the save actually worked.

    I looked at applications/dashboard/settings/structure.php and it appears that the tables are defined here (?). Anyway, when I look at the definition for the Media table it looks like this:




      ->column('Name', 'varchar(255)')

      ->column('Path', 'varchar(255)')

      ->column('Type', 'varchar(128)')

      ->column('Size', 'int(11)')

      ->column('Active', 'tinyint', 1)

      ->column('InsertUserID', 'int(11)', false, 'index')

      ->column('DateInserted', 'datetime')

      ->column('ForeignID', 'int(11)', true, 'index.Foreign')

      ->column('ForeignTable', 'varchar(24)', true, 'index.Foreign')

      ->column('ImageWidth', 'usmallint', null)

      ->column('ImageHeight', 'usmallint', null)

      ->column('ThumbWidth', 'usmallint', null)

      ->column('ThumbHeight', 'usmallint', null)

      ->column('ThumbPath', 'varchar(255)', null)

      ->set(false, false);

    When I looked at the structure in phpmysqladmin 'Active' was not there.

    I added it between 'Size' and 'InsertUserID', defaulted it to 1 and can edit posts now with impunity.

    I KNOW I ran utility/update. So either it's lying to me when it says "Success", something got missed in the upgrade scripts, or there is something else going on that I don't understand. Given the day I've had, the smart money is on that last option 😄.

    In lieu of running the SQL command, you can just click on the Structure tab for the Media table in phpmysqladmin and add it there.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    You should try running /utility/structure just in case something else was missed

  • Options

    Sure enough!!

    update `GDN_User` `User`
    set `Permissions` = ''
    where `Permissions` <> '';
    alter table `GDN_Article`
    character set utf8mb4 collate utf8mb4_unicode_ci,
    convert to character set utf8mb4 collate utf8mb4_unicode_ci;
    alter table `GDN_ArticleComment`
    character set utf8mb4 collate utf8mb4_unicode_ci,
    convert to character set utf8mb4 collate utf8mb4_unicode_ci;
    alter table `GDN_ArticleMedia`
    character set utf8mb4 collate utf8mb4_unicode_ci,
    convert to character set utf8mb4 collate utf8mb4_unicode_ci;
    insert `GDN_UserMeta` 
    (`UserID`, `Name`, `Value`) 
    values ('0', 'stubcontent.record.locale', 'en');

    Thanks so much. Starting to feel like I need to just blindly thank you once a week 😃.

    Quick question:

    Could I have gone straight from 2.6 to 3.2 (as long as I followed all the 2.6 & 2.8 to 3.0 upgrade specific instructions)? In other words, is the 3.2 upgrade inclusive of everything in 3.0 and 3.1 or is it a delta from 3.0 or 3.1?

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    If you follow all steps, you can update from any 2.x to the current 3.2. But there have been users reporting problems with roles and maybe all users need to reset their passwords. No showstoppers, annoyances perhaps, but nothing that hasn't been solved already.

  • Options

    OK, so this is weird. When I ran utility/structure and it identified those items above, I clicked on the button to run the Structure and Data scripts. It said it ran them successfully. However, if I run utility/structure again those same items appear.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Some of those messages will never disappear. In the dashboard's structure file there is an command to set the cached Permissions in the user table to an empty string. But in order to reach the dashboard, at least the admins permissions are cached in the Permission column of the User table for the admin. So it is impossible to get rid of that command. The others might be not as easy to explain, but there are reasons why they always return like Zombies, too.

    Run utility/structure two or three times, even four times if you like to, and everything should be fine. What comes up afterwards can be ignored.

  • Options

    I figured it had to be some sort of caching thing; when I looked at the database with phpmysqlyadmin everything the queries were doing were already in place.

    Again, thanks so much and thank you for the tip on utility/structure.

  • Options

    Followup -

    I created a test environment and restored my pre-3.2 (so Vanilla 2.6) site and database to it. I then went through the upgrade carefully following all the upgrade-specific steps. This time I went directly from 2.6 to 3.2.

    Ran utility/upgrade (success)

    Ran utility/structure and applied scripts several times (two SQL statements; nothing of note).

    Same problem: Missing Active column in the Media table. You get the error message when you update a post.

  • Options

    Hi! So, I am having this problem and I don't understand what to do even after diligently reading all the relevant posts.

    Just for background: I installed Vanilla Forums a while back because my hosting provider had an automatic update program. This has been a while back now, and after repeatedly trying to upgrade whenever the message on the dashboard said I should, and failing, through the auto update service, I called customer service and found out that the auto update service had been disabled.

    This was very frustrating for me, I didn't want to have to wrangle forum software just to have a little forum, and so, I tried to upgrade several times without success, off and on, over about two years. I finally was able to upgrade my forum by making an entirely new forum, importing the database, and reloading all the pictures.

    I still don't understand how the upgrade process is supposed to work, all the instructions simply say to follow the instructions and there's absolutely no direction on how to get to the instructions to follow them. It's very, very frustrating, and I would never have set my forum up on my own server if I'd had any idea this was going to be so much work, but would have put it on a service instead. But, that ship has sailed.

    Knowing all of that as background, can someone please tell me in very simple directions like you might be talking to a five year old, how to fix the error that is being discussed in this forum?

    I'm sorry to be a big stupidhead, this really wasn't ever supposed to be this difficult but I'm doing my level best to learn as I go.

    Thank you so much in advance for any help anyone can give!

Sign In or Register to comment.