Unknown column Active in field list

When I set the permissions in YAGA, I start receiving a message with exception 256 Unknown column Active in field list. This is happens when I trying to edit a discussion or comment. What a table I have to create this column?

Writing from mobile, ssrory my brevierty. I set permission to allow users to edit their own posts.

«13

Comments

  • It allows to save, but the small window with error appears. I did utility update and structure, trying to debug. But only this message appears.

  • When trying to save any existing post it gives message - { "Code": 256, "Exception": "Unknown column 'Active' in 'field list'", "Class": "Gdn_ErrorException" }. Please help folks.

  • The bad thing is that in not showing the full sql query. Only this text, even I've tryed out to debug it.

  • Even if I used a Debug panel created by Linc, is not showing exactly this request. How to trace the sql query? I need to trace a sql when I trying to save (I open existing post, click edit on it) an existing post or comment.

    When I click save, this error message appears. BUT, the post or comment is saving however, showing all modiifications, the time of modification. BUT it's not closing the editor automatically (due of error message appearing), I have to click on the other category and then coming back to that post.

    Also I've tried out disabling YAGA, but this message still present. So the best way to trace that sql query, but don't know how to do it. I think this is a dynamical sql query. If somebody show me where in php file I've to look (like discussion-save.php) then might be I can do something.

  • noszonenoszone New
    edited February 26

    I 've tried everything, you can check my conf.php:

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    $Configuration['Garden']['Errors']['LogEnabled'] = true;

    $Configuration['Garden']['Errors']['LogFile'] = 'log/DebugLog';

    And it's shows only other issues, not related to Sql queries.

    Also in index.php I put displya errors = 1.

  • try to disable all plugins to find which one causes the bug

    noszone
  • noszonenoszone New
    edited February 26

    Tried, but no success. Also I cleared the cache after disabling all plugins. Maybe @Linc could help me? Could you please have a look, very terrible issue.

  • Was mistake, full conf.php for debug is like this:

    $Configuration['Garden']['Debug'] = true;

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    $Configuration['Garden']['Errors']['LogEnabled'] = true;

    $Configuration['Garden']['Errors']['LogFile'] = 'log/DebugLog';

    Plus dysplay errors in index.php=1.

  • Try to disable YAGA to be sure it's a yaga's problem.

    Where do you download yaga? You can try my fork here https://github.com/pioc92/Application-Yaga

    I try to update it when i found an incompatibility with current vanilla's release

    noszone
  • Before I've tried that, and tried once more with cache clearing. Just now also tried to switch to Keystone template. The same. Due I'm using old default Baseline template.

    Thank you for the link! Someday I will go to update a YAGA from your fork.

  • Thank you, who knows where I could find the complete list of vanila tables? I will check tomorrow an advice of Kaspar.

  • I've start looking in Google the pages not related to vanilla. And I think I find what I have to check. First it's not a vanilla issue. Its' a mysql issue. But the problem that in the files inside a query somewhere unprintable symbols.

    So, the column exists, just it's a mistake in a query SQL. This could be happen if file edited with different encoding or bad code redactor. So will check it tomorrow.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    These are the files which create all tables in Vanilla:

    https://github.com/vanilla/vanilla/blob/master/applications/dashboard/settings/structure.php

    https://github.com/vanilla/vanilla/blob/master/applications/vanilla/settings/structure.php

    https://github.com/vanilla/vanilla/blob/master/applications/conversations/settings/structure.php


    For yaga it is

    /applications/yaga/settings/structure.php


    But there is only one column called "Active" and that has nothing to do with editing comments.


    Do you have the possibility to enable the mysql query log?


    noszone
  • Thank you, I've asked this from my hosted. Will reply when they done.

  • Hoster can't enable the mysql logging on the shared hosting. Any other way to get the logs of mysql queries?

  • noszonenoszone New
    edited February 27

    Even if I rewrited most of the vanilla folders from 2.8 zip archive, it continue giving this message. I start to think that issue is in mysql server. But to catch the full sql query need to find the way to logging.

    Does anybody knows where the function of event fire event(AfterFormButtons). My idea is to find a place where I can put some code for logging. So now looking for the piece of code where events starting after pressing a Save button or Post comment button.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    By the way: I'm not sure that this belongs to MySQL. If the post has been saved like you sayed, the database side is clean.

    And if I do a full text search on my test installation, I cannot find the text "field list" anywhere. Could be that you have altered something somewhere?

    The first thing I would try would be to open the edit comment in a new window. Go to /post/editdiscussion/12345

    See if there are JavaScript errors in the console or network errors. To me it looks like the editor cannot handle the result sent back by the edit ajax action. Try to find that POST snippet in your network traffic and see if it contains a key called "Active" and the content of it.


    noszone
«13
Sign In or Register to comment.