Please upgrade here. These earlier versions are no longer being updated and have security issues.

Following / all button

I currently have a problem with Vanilla.

I can not switch to ALL on the button that can be seen in the picture because there is always an error.

Tagged:

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    As a first step, have you tried it with a different theme?

  • @whu606 Yes, I have already tried. Unfortunately did not bring anything

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    Do your other dropdowns work? Eg discussion options, mebox, etc?

  • SerrIISerrII New
    edited April 30

    @charrondev Yes, everything else works as far as I know

  • Here is the error message @whu606 @charrondev


  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff
    edited April 30

    Are there any errors in your javascript console before clicking the following link?

  • Where can I find the console?

  • @charrondev I have not installed the forum on a Linux server but on a webspace without a console if that matters

  • I think I know the mistake. If I press "ALL" the wrong link will be executed. This one ... / categories. But actually he would have to run with me ... / index.php? P = / categories

  • SerrIISerrII New
    edited May 3
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Looks as if you have to enable pretty urls in your forum. Open your /conf/config.php and add this line at the end: $Configuration['Garden']['RewriteUrls'] = true;


  • As soon as I add that, the forum does not work anymore. So then no page works anymore @R_J

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    "does not work anymore" isn't helpful. There are at least two possible reasons in this constellation for "not working", both would look different.

    1. If you see a blank screen, you have made an error while adding that line to the config. Make sure you copy the complete line, from "$" to ";" and paste it as the last line into the config
    2. If you still see the home page but you cannot open e.g. an existing discussion, you should show us your ".htaccess" file


  • @R_J The file contains only "Deny from all"

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    You have a .htaccess file in the root folder of your forum with only one line: "Deny from all"?

    If so, copy the .htaccess.dist to .htaccess


Sign In or Register to comment.