File uploads wrong url after move.

Hi, i just completed my development successfully and started to migrate to the webserver, i deleted everything inside cache folder like documentation said.

After the full move vanilla seamed to be working just fine, except file uploads that happened before the move, they all use the development local url. How do i change that to the new url?

I have been looking in the docs, both help section and developer docs and can't find anything related to this.

If anyone have any knowledge about how to fix that, that would be awesome.

I also noticed that there is no good way of managing uploads, maybe that's coming soon?

There is also no good way of bulk deleting users nor content.

Comments

  • ShadowdareShadowdare Moderator
    edited October 3

    Were the file uploads attached to posts via Advanced Editor? Are they image embeds or attached at the end of the posts?

    The links are probably stored with the full absolute URL of your old address in the database. Try searching through the database for that URL in text and replace the occurrences with your new address in the same format (with the slashes in the right places, etc).

    Add Pages to Vanilla with the Basic Pages app

    mattish91
  • Yea, that's the issue. Solved my problem instantly under "*_discussion" table.

    Luckily this were only a test post with no real intention other than testing, but this should be solved by using some php in the future to avoid this instead of including the entire URL from when the file got uploaded.

    Shadowdare
Sign In or Register to comment.