My forum is down 2.1?

I have been running a small forum for a small fishing group. Been running fine for years and I recently had a problem that required to "park" my domain. Now that problem with the website has been fixed my Forum no longer loads. Is there a way to tell from looking in my Vanilla-2 folder and tell what version I am running. I think it is back at 2.1.x.

Yes, I know I should have upgraded. Be gentle, I am in no way a server, html expert and I think I may be too old to learn!

Error I get is a blank page and if I run utility/update I get this error.


Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.


Dan

«13

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    There must be some kind of server log file where there is more information. Without that we will not be able to support on a error 500


  • Yes, thanks. I did contact the host support about that yesterday and I am waiting for a reply. I was thinking if I knew which version of Vanilla I have I could maybe reinstall it over the top and maybe that would fix it. But I will see what the hosting company tells me about the name and location of the log.


    Thank you!

    Dan

  • Ok,

    Got the error log. Appears to be .htaccess file. Here is what they found:

    [Thu Apr 02 12:44:28.050437 2020] [core:error] [pid 18827] [client

    77.75.79.36:38606] AH00124: Request exceeded the limit of 10 internal

    redirects due to probable configuration error. Use

    'LimitInternalRecursion' to increase the limit if necessary. Use

    'LogLevel debug' to get a backtrace.


    I have no idea what that means. Is there a generic .htaccess file I can try? I don't understand what changed to cause this to happen after all this time.


    TIA

    Dan

  • You can disable the .htaccess file by temporarily removing the dot.

    If that cures the 500 error, post the contents of the .htaccess file here so we can maybe figure out what's wrong.

  • I get the blank screen as before when using the web URL and get a URL not found error when doing utility/update. No longer get the internal server error.

    I have a number of .htaccess files I have experimenting with but I think this is the original one with the addition of the rewrite location..

    # Original

    # If you modify this file then change the above line to: # Modified

    <IfModule mod_rewrite.c>

      RewriteEngine On

      # Certain hosts may require the following line.

      # If vanilla is in a subfolder then you need to specify it after the /. 

      # (ex. You pur Vanilla in /forum so change the next line to: RewriteBase /www.berksbassmasters.com/Vanilla-2)

      RewriteBase /www.berksbassmasters.com/Vanilla-2

      RewriteCond %{REQUEST_FILENAME} !-d

      RewriteCond %{REQUEST_FILENAME} !-f

      RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

    </IfModule>

  • ianw5555ianw5555 New
    edited April 3

    This line is wrong:

    RewriteBase /www.berksbassmasters.com/Vanilla-2

    It should be

    RewriteBase /Vannilla-2

    R_J
  • Ok thanks,

    Edited and made no difference. Do you know if I can download the update file of the same version (how do I tell which version I have) and they do an upgrade over the top?

    TIA

    Dan

  • Yes that was what was causing the 500 error, you clearly have other issues as well.

    Have another look in your error_log and try putting it into debug mode to see what errors you are getting.

  • I checked with host. I do have the logging file activated but they are not familiar with a debug mode. It does not appear that any errors are appearing there now that the .htaccess file has been corrected. I just get a blank page/screen when going to my forum url, I still get the 500 error when I do a utility/update. I do notice when I get the blank page the title in the window tab indicated "bonk" but the screen is blank, no error. Does Vanilla depend on anything else in the home directory other than the .htaccess file? Isn't everything located in the Vanilla-2 folder? I have backups of the Vanilla-2 folder but not sure of the version of them but ALL of them produce the same blank page or 500 error with utility/update.

  • ianw5555ianw5555 New
    edited April 4

    The error_log file is usually in the same (root) directory as the .htaccess file.

    To debug you have to put this line in your /conf/config.php file

    $Configuration['Debug'] = TRUE;
    

    then refresh your browser to see the error message.

  • It was not activate. Had to deactivate some other error login to get this one working. Hosting made the changes. So now I have something that makes more sense. Looks like it is not finding garden.

    Thanks for all your help with this.


    [04-Apr-2020 12:31:23 America/Los_Angeles] PHP Fatal error: Uncaught Error: Class 'Gdn_Url' not found in /home/devinephoto/berksbassmasters.com/vanilla-2/library/core/functions.general.php:335

    Stack trace:

    #0 /home/devinephoto/berksbassmasters.com/vanilla-2/applications/dashboard/views/error.master.php(10): Asset('/applications/d...')

    #1 /home/devinephoto/berksbassmasters.com/vanilla-2/library/core/functions.error.php(172): include('/home/devinepho...')

    #2 [internal function]: Gdn_ExceptionHandler(Object(Error))

    #3 {main}

     thrown in /home/devinephoto/berksbassmasters.com/vanilla-2/library/core/functions.general.php on line 335

    [04-Apr-2020 12:43:11 America/Los_Angeles] PHP Fatal error: Uncaught Error: Class 'Gdn_Url' not found in /home/devinephoto/berksbassmasters.com/vanilla-2/library/core/functions.general.php:335

    Stack trace:

    #0 /home/devinephoto/berksbassmasters.com/vanilla-2/applications/dashboard/views/error.master.php(10): Asset('/applications/d...')

    #1 /home/devinephoto/berksbassmasters.com/vanilla-2/library/core/functions.error.php(172): include('/home/devinepho...')

    #2 [internal function]: Gdn_ExceptionHandler(Object(Error))

    #3 {main}

  • Could this be a theme problem?

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    If your forum isn't running right now, why don't you try upgrading it to 3.3? Fixing an old insecure version doesn't sound reasonable...


  • Can I upgrade to 3.3 from a version I am not sure of?

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator


  • Ok, thanks RJ and ianw555. I was hoping to get this version working before I do the upgrade. I have not been too successful with prior upgrades but got it figured out after a period of experimenting. I will put the 3.3 upgrade on my list of things to do later this week.

    Thanks again

    Dan

  • Ok, I checked the installation instruction on the link last week and went back to print it out today and I can't find the information I had seen before on the link supplied above. Can you give me the link to the docs that tell me what files I need to delete on the server before i try to install 3.3 directly from 2.1. Can't seem to find it again.

    TIA

    Dan

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    https://success.vanillaforums.com/kb/articles/158-upgrading


  • Tnx! Here goes!

  • Ok,

    I did the upgrade and the forum is up. Ran without needing utility/update. Am able to sign in as admin and see the posts. I do get this error when going to the dashboard.

    Fatal Error in Gdn_Pluggable.__call();

    The "SettingsController" object does not have a "xsetHighlightRoute" method.

    The error occurred on or near: /home/devinephoto/berksbassmasters.com/vanilla-2/library/core/class.pluggable.php

    190:         // Make sure that $ActualMethodName exists before continuing:
    191:         if (!method_exists($this, $actualMethodName)) {
    192:             // Make sure that a plugin is not handling the call
    193:             if (!Gdn::pluginManager()->hasNewMethod($className, $referenceMethodName)) {
    194:                 throw new \BadMethodCallException(
    195:                     "The \"$className\" object does not have a \"$actualMethodName\" method.",
    196:                     501
    197:                 );
    198:             }
    

    Backtrace:

    [/home/devinephoto/berksbassmasters.com/vanilla-2/plugins/VanillaStats/class.vanillastats.plugin.php:116] Gdn_Pluggable->__call();
    [/home/devinephoto/berksbassmasters.com/vanilla-2/library/core/class.dispatcher.php:872] VanillaStatsPlugin->settingsController_home_create();
    [/home/devinephoto/berksbassmasters.com/vanilla-2/library/core/class.dispatcher.php:289] Gdn_Dispatcher->dispatchController();
    [/home/devinephoto/berksbassmasters.com/vanilla-2/index.php:29] Gdn_Dispatcher->dispatch();
    


Sign In or Register to comment.