HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 2021.009 no categories found



  • Thanks.

  • Thanks, yes there was a forum on the site that was supposed to be "Not Viewable" by guest and member. When I changed that to custom permissions after your fix to make it Not Viewable, the forum was still Viewable but permissions would not allow entrance. When Guest was changed to Not Viewable for the entire site, nothing was viewable but you could not change Guest back to view anything. Permissions would not change. So yes, thats when I posted the site was still having issues, not a "page".

    The site was working perfectly under 3.3 but now its not, I'm told its my plugins, or my custom roles, or my customization. Funny its not a buggy update at all, its just my fault. Whatever, if it breaks again I'll never use Vanilla again and your problems will be solved. Perfect software solution.

  • R_JR_J Ex-Fanboy Munich Admin

    Okay, if that's your conclusion and your best option, then I will not have to waste my time. Fine for me. 🖖

  • KasparKaspar Moderator

    "Funny its not a buggy update at all"

    it might very well be, you(the generel you) just do not know before either:

    A) every other possible cause is ruled out or found to be the cause.

    B) issue/cause in core package troubleshooted, found, proven to be the cause.

    That is what the free open source is about.

    You get it for free but you are testing it - so issues must be expected.

    Hence the reason to test a new version on a seperate setup before taking it to your live.

  • You know, I really get what you are saying. I've been around long enough to know that if its open source, problems may happen and thats why the community helps to work them out. I understand it could be due to some customization I've done, particularly since only one other user (as far as we know) is experiencing this issue. And I also admit that its my fault for not testing on an alternate database or saving a 3.3 backup before running the update. It was a rookie mistake, I admit it and I get all of that. But what I don't appreciate is being singled out along with another user in a patronizing way. There is no call for that, especially when I was just reporting the issue wasn't fixed after being reported that it was and his only involvement was trying to help me solve the issue.

  • R_JR_J Ex-Fanboy Munich Admin
    edited May 2021

    Okay, let's forget about it. There was something in your last comment that triggered me, maybe my comment could be misunderstood too and that's it.

    When I looked at your forum I noticed things that could be improved and I just want to mention them:

    • I have enabled pretty urls because that is a requirement
    • The forums subfolder should have a longer name since I would assume that this is better for SEO (but I'm no expert on this topic)
    • One of the roles has no default type set
    • There are more plugins enabled than needed

    And I do not think that any of these could be the reason for your problems.

    Coming back to the problem of the lost categories: I approached the problem wrong and spent a lot of time getting the problem fixed and I added a SQL to help other people who face the same problem. I thought it was done then.

    After you have reported that the issue wasn't solved I took another look at the database and indeed: something changed in the default guest permission row. Now that you have reported that you indeed changed something at the categories, I would still be interested in really finding a solution, not only a temporary fix.

    I misunderstood your comment in a way that you have lost patience with Vanilla and then I would need until somebody else reports the same problem. Without access to an installation where that problem comes up, I will not be able to find out the root cause. If you are still interested, then I would ask you if you manage to reproduce the problem, maybe by setting one category to custom permissions. If you can manage to find the steps that break a temporarily fixed database again, I will have something to work on. You would need to describe the steps and grant me access again, though.

    If you cannot reproduce the problem, I'm really lost. But on the other hand: if you cannot reproduce it, there is nothing to fix and we should all be happy ;-)

  • @R_J I appreciate your help and respect your knowledge. I understand this is over my head and my reason for reaching out to both you and the other user. He went out of his way to help me and so have you. Do not misunderstand that I do appreciate that.

    Secondly, let me try and be more descriptive about what has occurred and was occurring yesterday. After I was told the issue was fixed, I noticed that one of the categories that should not be viewable by Guest was viewable by Guest, I unchecked View for Guest in that category. Guest could still View the category title but could not enter without password. So, all View was unchecked for Guest which got "Categories not found" as it should. Then all View was re-selected but the permissions for Guest would not reset.

    After you went in today and reset it, the same thing happened. I went in and did the same thing as above and its back to "Categories not found". Its as if permission changes are not being written and saved.

    Also, I deleted the "Null" (no default type set) user which was a custom role intended to have permissions between Admin and Moderator. So when I created that user, I did associate it with the admin role but it did not appear to save that.

    I have deleted your account and the other users because as you said, I am losing my patience with Vanilla but the truth is no other forum so far has fit the specific needs I have, and Vanilla is beautifully mobile friendly. I would dearly love to have it operating properly again.

    I will look at plugins to see what can be removed.

    Let me know how to get you login credentials and I will do so. Thank you for your time.

  • R_JR_J Ex-Fanboy Munich Admin

    I've used a database backup and a file backup and used both to recreate your forum on my local machine with nginx and mysql. It works as expected for me with this setup. The category that should be hidden is hidden and everything else is visible.

    The next thing to look at is the server. There is only one thing which looks suspicious and that is the mysqli/mysqlnd driver version. To my understanding it should correspond to the php version. This is how it looks like in my phpinfo:

    On your server, the version is "mysqlnd 5.0.12-dev - 20150407" which is ancient! Please ask your hoster about it.

    It's surely possible that this has nothing to do with your issues, but from my testings I'd say that it's not a Vanilla code problem and that's why I cannot support you further, sorry! :-/

  • Thanks VERY much again @R_J ... this was also an issue for me following upgrade from 3.3.

  • I think there is something still wrong... as anytime I try to change role permissions from the dashboard, it stuffs up again, and I need to return to edit the database. For now I'm manually editing permissions from the database (followed by the clear permissions cache step) and that seems to be working.

  • R_JR_J Ex-Fanboy Munich Admin

    Can you check your phpinfo() for anything suspicious? It's not a problem with the code not with the data. As you can read in one of my above comments, I copied files and the database on my machine and didn't have the same problems. Therefore I assume you have some old drivers - hopefully it's that easy...

  • pioc34pioc34 Pézenas ✭✭

    Same problem here. Upgrade from 3.3 and permissions problems.

  • R_JR_J Ex-Fanboy Munich Admin

    Can you send me your phpinfo? I think it is considered best practice not to do publish that info, so it would be better to send it via PM. I'll take a look at it tomorrow

  • R_JR_J Ex-Fanboy Munich Admin

    I'm totally clueless. I suspected LiteSpeed because the @pinchies once mentioned he was using LiteSpeed, too and LiteSpeed comes with its own PHP implementation. I installed LiteSpeed in my virtual machine. But even with LiteSpeed I don't have the same problem like you.

    I really do not know what else to do, sorry. Does anybody of you have a test installation with that problem? It must be a test forum because I would need to mess with source code to dig into that and I would surely render the forum unusable multiple times during testing.

  • pioc34pioc34 Pézenas ✭✭

    Ok, Thank you r-j for your Time.

  • pioc34pioc34 Pézenas ✭✭

    Everything is fine now...What i have done?

    I copy the database and files to another hosting i have.

    Run utility/update utility/structure

    I log with a member account, no permissions and no categories. I log with my administrator account, i go to every profile (members, unconfirmed, invited, administrators) and i save permissions.

    After that, everything seems ok.

    Like @R_J said, it's a hosting related issue.

    On my old hosting, i have a mariadb database (10.3.27-MariaDB - MariaDB Server) and litespeed cache(not enabled on the website) php 7.4

    On my new hosting, it's a mysql 5.7 database and php 7.4

    Hope this helps!

  • I'm using PHP 7.4 and Mysql 5.7 too with this issue (on litespeed). 🤔

  • I think there is something wrong that I have not been able to diagnose -- post counts on the forum have been broken since forever for me, wasn't working on 3.3 and is still broken on 2021.009 -- no idea if its related, but it indicates there are other gremlins with my setup.

  • KasparKaspar Moderator
Sign In or Register to comment.