HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Import problem from kunena to vanilla

I'm trying to convert kunena to vanilla but once exported when I try to import I get the following error:

Row 1 doesn't contain data for all columns

I also fixed the kunena converter by adapting it to kunena version 5.2.

How can I solve the problem?

Tagged:

Comments

  • LincLinc Detroit Admin

    Can you share the fixed version of the code?

    Did any of the tables successfully import? Can you narrow down which table it was trying to import when it hit that error?

    That's a MySQL error; it can indicate that either you have a delimiter problem (like commas being out of place in the porter file) or there was an issue with the export that caused a mismatch in columns.

    specialworld83
  • I uploaded the correct file for kunena. Now when I try to import the file it tells me:

    Out of range value for column 'Banned' at row 2
    
  • LincLinc Detroit Admin

    It looks like there's a bug in Kunena's porter or Kunena just changed how it stores 'banned' values. Vanilla expects 0 or 1; Kunena stores a timestamp, now.

    Try finding this:

    coalesce(ku.banned, 0) as banned,

    And replacing it with this:

    if(isnull(ku.banned), 0, 1) as banned,

    I don't have an easy way of testing that so apologies if it doesn't work and we need to try again. 😅

  • Now I find myself with this error

    Incorrect datetime value: '0000-00-00 00:00:00' for column 'DateLastActive' at row 7
    


  • There was an error while trying to create the Media table (The specified data type (smallint unsigned) is not accepted for the MySQL database.).
    


  • LincLinc Detroit Admin
    edited April 9

    Well at least it's new errors! That means the old one was probably fixed.

    For the Media table error, find wherever it says 'usmallint' and just change it to 'smallint'. (There's probably 4 of them). That may solve that. There's an open bug on core about this, so it may also require modifying the GDN_Media table if that doesn't work.

    The datetime issue is probably to do with the SQL mode of your server and is a bit trickier. You probably have STRICT MODE enabled and need to disable it, at least until the migration is done. Your host may be able to assist with that. You can also try this: https://tableplus.com/blog/2019/10/incorrect-date-value-0000-00-00-date-datetime.html

  • LincLinc Detroit Admin

    @specialworld83 Did you make any progress on this?

Sign In or Register to comment.