HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 2023.001 Open Source Release - PHP 8 Works! (Built From Source)

Hi All,

Woke up to the notification of the new 2023.001 Open Source release this morning.

Built it from source and am happy to report that most of the issues encountered in previous builds now all appear to be fixed from what I can see so far.

PHP 8 now properly works without any of my previous workarounds - Tested on PHP 8.1.12 and the absolute latest PHP 8.2.1! All works as far as I can see! 😁

The Admin Dashboard CSS display error that's plagued pretty much every release since 2021.012 is also sorted out now.

The blank "User Profile" page from the previous 2022.025 release is now working.

Have attached the built release for you all to enjoy!


pioc34LincBleistivtRMonsen
«1

Comments

  • pioc34pioc34 Pézenas ✭✭

    Thank you so much, i will try it.

  • You're welcome - looks promising so far - Maybe I will finally look at migrating my big forum over to Vanilla :D

  • pioc34pioc34 Pézenas ✭✭

    It’s working on my local setup on php 8…i’ll wait a little before push it in production.

  • BleistivtBleistivt Moderator
    edited January 23

    I can vouch for this build. I have also built it from source (attached).

    Comparing with `diff -bur DIR1 DIR2` yields only differences in hashes and composer files since the build system is not deterministic, unfortunately.

    I have turned this discussion into an announcement instead of the older one: https://open.vanillaforums.com/discussion/39032/vanilla-version-2021-009-is-the-latest-stable-release-as-of-now/p1

    PHP8.0 is recommended. While it works on PHP8.1 there are a lot of warnings that could slow things down.


    pioc34
  • For my first 2023.001 custom build trial on blank forum :

    'User Profile' redirection settings is now here BUT like with 2022.025 there's no new UI for Managing Custom Fields (See https://success.vanillaforums.com/kb/articles/599-updated-custom-fields)

    And since the old plugin 'Extended field" is forced to disable...

    When I use /utility/update I have an update failed but no log.... perhaps something around this.

  • pioc34pioc34 Pézenas ✭✭

    i updated in production and i had some issues.

    You have to check logs to find them.

    First : add/update $Configuration['Debug'] = true; in conf/config.php

    I have an error when i tried to make an utility/update with:

    $db->query("DROP INDEX `$indexName` ON " . $px . $tableName . " ALGORITHM = INPLACE LOCK = NONE");

    in library\database\class.databasestructure.php line 744

    i replace it by $db->query("ALTER TABLE " . $px . $tableName . " DROP INDEX ".$indexName.", ALGORITHM=INPLACE, LOCK=NONE;");

    Then i can made utiliy/update but i don't remember if it was before or after update my php version to 8.0!

    After successfully utility/update i test my website and check the php error logs and i had a lot of errors. It was my old bootstrap theme. I change some smarty checks and now it's fine.

  • pioc34pioc34 Pézenas ✭✭

    i disabled profile extender in conf.php because it makes errors too.

  • pioc34pioc34 Pézenas ✭✭

    i disabled Federated search in config-default.php because it's a paid version plugin.

  • There's new code in applications\dashboard\settings\structure.php (not present in 2022.024)

    // Remove legacy Plugins
    Gdn::config()->removeFromConfig($LEGACYADDON);
    
    // Keep this until we have deprecated the ProfileExtender addon.
    if (Gdn::config(ProfileFieldModel::CONFIG_FEATURE_FLAG) && Gdn::config("EnabledPlugins.ProfileExtender")) {
       Gdn::config()->saveToConfig("EnabledPlugins.ProfileExtender", false);
    }
    

    So you can $Configuration['EnabledPlugins']['ProfileExtender'] = true; in config.php to have old plugin forced enable.

    But should be the new system (ProfileFieldModel::CONFIG_FEATURE_FLAG)

    pioc34
  • pioc34pioc34 Pézenas ✭✭

    i had a version.json file in root directory therefore, it makes an error

    i add a .txt extension to it to upload it to the forum

  • AstRucAstRuc New
    edited January 23

    I found in the code 🤩 :

    You must add this in config.php

    $Configuration['Feature']['CustomProfileFields']['Enabled'] = true;
    

    Should be set by default, It's the new big vanilla's feature : there's lot of new possibilites, It's in the vanilla core etc.

    pioc34
  • pioc34pioc34 Pézenas ✭✭

    i add it to my config.php and nothing appears lol

  • Cleaned the cache ?


  • pioc34pioc34 Pézenas ✭✭

    yes but maybe it's my old theme

  • The dashboard doesn't use custom themes. You should delete all files under cache. Perhaps there's error on database schema upgrade.

    Tried new extended/custom fieds on blank forum under php 7.4. So far no problem found.

  • To update database schema of an existing forum (don't forget to make /utility/update), I need to manually edit my some tables (_UserMeta, _UserRole etc).

    Without that /utility/update fails and logging information was unusable (update addon_structure_dashboard_failed).

  • pioc34pioc34 Pézenas ✭✭
    edited January 24

    its a yaga from @Bleistivt problem.

    When i go in user profile, i have a 500 error

    "Error parsing /home/clients/d8ade77d825ada62a38ee7d77a251b43/sites/routeur4g.fr/discussions/plugins/yaga/openapi/yaga-best-users.yml
    

    Even if i disable yaga, i have this error.

    This error appends in appearance branding too

  • pioc34pioc34 Pézenas ✭✭

    i have to delete yaga directory in plugins and everything works... I f i only disable it, i have javascript errors in user profile and appearance branding.

  • I've only ever installed pre build versions of vanilla and tried to update/upgrade but for the life of me I can't get it done... I downloaded this package but still no luck you guys talk about /utility/update but all I get is a blank screen... There seems to be no clear documentation on how to build or install a clean copy (Probably done on purpose) can someone point me in the right direction please... Cheers in advance

  • BleistivtBleistivt Moderator

    @pioc34 Sorry, you probably had a version between releases from GitHub installed where these files have been present for some time. There is also a new minor version available that has been adapted to the new dashboard side menu: https://github.com/bleistivt/yaga

    @Patmac Create a local directory where you collect your downloaded plugins and applications. Then delete everything except for the /conf and /uploads directory. Now you can upload a clean copy of all files and merge the plugins and applications folders back in.

    pioc34
Sign In or Register to comment.