HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

broken install / database(?) bug

edited July 2005 in Vanilla 1.0 Help
hi, i recently tried to install vanilla, but at the second step (database creation) the installer didn't respond anymore. however, i saw in mysqladmin, that the tables were created successfully. i couldn't continue the installation from this point, since the installer complained, that the database structure already exists. so i dropped the tables, deleted the files, and made a manual installation from scratch, everything was fine, the SQL script ran successfully. i could also sign in, however, if i try to post, or change a setting, i get no reaction, and no settings are changed. when i use firefox, i get no reaction (i just see the same page), when i use safari, i get this error: "The error was: “lost network connection� (NSURLErrorDomain:-1005)" any ideas? (i just double-checked the database account settings, they're fine.)
«1

Comments

  • MarkMark Vanilla Staff
    Can you post the url to your installation so we can have a look?
  • sure. http://www.247softworks.com/forum/ this might also help: http://www.247softworks.com/phpinfo.php thanks in advance for your time. basically, i'd like to experiment a bit with vanilla and atom/rss, i'd be happy if i could help you track down some bugs in return.
  • in the meantime, i've set agPUBLIC_BROWSING to 1 in settings.php.
  • hmm. when i try to start a discussion, this happens: Notice: session_start() [function.session-start]: ps_files_cleanup_dir: opendir(/tmp) failed: Permission denied (13) in Vanilla.Session.class.php on line 63
  • MarkMark Vanilla Staff
    Who set up your php? Do you use any other software on your server that would require a login? That error means that php is having trouble doing some basic work - implying that php hasn't been set up properly.
  • isn't that just an oddly worded open_basedir error.
  • i used debug.php to switch into debug mode, then switched back. posting works fine now. still no luck with changing the settings though.
  • MarkMark Vanilla Staff
    edited July 2005
    No. PHP sessions are saved to the filesystem in a /tmp folder. PHP is having trouble cleaning up old sessions because it doesn't have permission to do it.
  • "Who set up your php?" my webspace provider... "Do you use any other software on your server that would require a login?" yep. i have a wordpress test installation, which works fine.
  • MarkMark Vanilla Staff
    debug.php just saves a cookie to your browser. I don't know why that would have any effect on that last error. I bet the problem is still there.
  • the posting error seems to be gone now.
  • btw i have absolutely no idea why i can't save the settings (change application title), the permissions are OK (666).
  • shouldn't i change the permissions on the appg directory from 755 to 666?
  • Um. I *think* all it needs is read/write access. Though i cant fully remember the binary counting on chmod properties. Eitherway 666 is probably a safer bet to try.
  • The Devil!
  • read = 4, write = 2, execute = 1 the sequence is owner, group, other 666 would mean that all three groups get r/w access, but no execute rights.
  • 666 resulted in tons of errors. i switched back to 755.
  • Yeah. For some reason i was bringing 3's into it and getting lost - i need more beer. My motto tends to be 'if somethings bust, you probably cant make it a great deal worse, so try fixing it and see what happens'...you'd be amazed at how often i manage to make stuff worse.
  • in the meantime i also tried 777, no success with changing the settings, so it's not a permission problem.
  • " so try fixing it and see what happens" well, if something goes wrong, i usually start to read the documentation :) but it didn't help in this case :(
This discussion has been closed.