Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Attachments 2.1



  • Quite. It is dependent on the server config, so you kinda have to use whatever works on your setup.
  • I know there's probably an answer lying somewhere beneath my nose, but I guess I've been starring into the screen far too long... so I hope someone could help - is there a way to change the max file size for upload? Using Attachment2 with multifile add and need to put some .pdfs a bit larger than the allowed 500. help... help... help...
  • edited January 2007
    @snowflake: Go to the settings tab, from the panel select "Attachments Settings" and there you can enter the Maximum Filesize. You can only see this option if you have enabled "Manage Attachments" in your role definition.
  • @snowflake: why the name? The only reason I ask is because I used to live in a town called Snowflake.
  • thank you Jazzman! I completely failed to notice the attachment settings thingy... @jeremy2: the answer is more metaphysical than geographical ;)
  • byttebytte
    edited January 2007
    I'm using the attachment add-on with the quotations add-on. It's impossible to quote an inlined image, there's just a bunch of BB code appearing in the quoted text, instead of the image itself. I guess that can't be changed in the settings somewhere?
  • First of all, thanks for this extension! My concern is that I'm using Safari, and Attachments don't work at all when you try to upload a file. I assume it's the way the "functions.js" file is written, can someone help me on this one?
  • edited February 2007
    I'm using 1.0.3 What's weird is that I was using this extension successfully until I installed the Notify extension. I noticed that I was getting an error message related to that extension. I have uninstalled it now, but the Attachement extension is still not working. Even after uninstalling and re-installing. I have tried to edit an old discussion and add an attachement a get the error: "Some problems were encountered The requested discussion could not be found. If I try to add one to a new comment, I get the message: "Some problems were encountered You are not allowed to upload (titleoffile.txt) the requested file type: plain/text" I have uploaded text attachments previously without error. EDITED: It seems that there is just a problem with plain/text attachments now.
  • bunni,

    I just did a new install and had the same error "Some problems were encountered The requested discussion could not be found" and my problem was with Attachments 2.1 and the folder. My attachments settings were pointing to a folder that was not or had not been created yet. I created the "uploads" folder and that solved my problem.....Maybe I should have verified this folder first but I just assumed that the extension would create it automatically and if it was supposed to it did not but I have it working now Yeah.
  • btw, i moved the uploads folder out of the webroot, and changed the path accordingly in the attachments settings. i can attach files, and inline images displays it fine (thickbox too). the only problem i am having is with files that were uploaded before the folder move - they do not display, nor download. to overcome this, i have temporarily copied the uploads folder back to it's original position, but NOT changed the path in the settings, so all new uploads will go into the folder below the web root.

    is there any other way around this? some way to refresh the previous attachments? is there some form of cache?

    thanks in advance!
  • did u edit the LUM_Attachment table in the database so the old files know where their new location is?
  • funny story, i just did that. i hadn't looked beforehand though, because i didn't think that each attachment would record the complete path!

    thanks :D
  • ok, i've moved servers.

    i've updated the server path in the database, and in the settings. all the existing images show up, but i can't attach any new files - "...Failed to upload the file: blah blah". i've tested by setting the uploads folder to 777 but still nada. any ideas? i guess i'm missing something simple again :/ tia!
  • edited May 2007
    any help with the file permissions? are there any other files which may require chmodding for this to work properly?

  • never mind, fixed it up now. reinstalled the extensions, recreated uploads directory... :)
  • edited October 2007
    So, I am trying to install this mod on my Vanilla... I'd really really really like to get it to work. I'm a webdesigner, and I plan on using Vanilla as a client area. I'm using SMF right now, and it's just so bloated... I like how to make a private discussion in Vanilla all you have to do is whisper it... AND MANY OTHER things... but if I can't get attachments to work then I might as well forget it. I'm also trying to integrate it with my Wordpress installation so that may be causing the problem, but I'm not sure. If someone could look into it for me, I would be forever grateful!!!

    I posted everything in a new topic here.
  • it would be neat if you implemented a watermark option to watermark any photos uploaded via it
  • How do I change the 3 files at one time limit? I run an art forum, so we need a bigger limit. Thank you for the help!
  • Do you have MultiFileUpload? It says in the description that the max # of attachments is "configurable." I would assume that means it's somewhere toward the top of default.php (/extensions/multifileupload/default.php).
  • ah, yes I do! Fixed :3, thanks fysicsluvr
Sign In or Register to comment.