Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Adding Yellow Fade

edited January 2008 in Vanilla 1.0 Help
I have just read a post over at YourTotalSite that gives you a quick and dirty way to add the Yellow Fade Technique to any anchor which appears at the end of the URL string. So, Im hoping I can use it to highlight the latest post in a thread (as the link from the discussion list ends #item_x). Its basically just a JS file, but I cant seem to get it to work. The JS file is here: http://www.36-degrees.co.uk/assets/YellowFade.js the example is here: http://www.36-degrees.co.uk/assets/YellowFadeExample.html and the original article is here: http://www.yourtotalsite.com/archives/javascript/yellowfade_technique_for/Default.aspx Cheers Stuart.
«13

Comments

  • Options
    Nice. I like this. The double flash might be a little over the top, but a single fade would do nicely. Shouldn't be too hard to implement either. Good work.
  • Options
    upload the YellowFade.js to your js directory inside your Vanilla install.

    <?php /* Extension Name: YellowFade Effect (For Stuart) Extension Url: http://michaelraichelson.com/hacks/vanilla/ Description: Adds the YellowFade effect on some stuff. Version: 0.1 Author: Michael Raichelson Author Url: http://michaelraichelson.com/ */ if(in_array($Context->SelfUrl, array("index.php", "categories.php", "comments.php", "search.php", "post.php", "account.php", "settings.php"))){ $Head->AddScript("./js/YellowFade.js"); } ?>
  • Options
    Cheers Nifkin, I had made a similar extension, but kept the file outside my vanilla directory, will that make a difference, as it wasnt working at all.
  • Options
    brilliant. thanks for that *runs off to install*
  • Options
    just gave that a try, but to no avail. Im guessing it is a CSS problem?
  • Options
    nathan > if you want to change the double flash to a single, open upthe js file, and change the number in 'startfadeat' to 14, that will give the single fade.
  • Options
    Thanks. I know a fair bit about js, so I have done that already. It does not work fo rme though (the extension that is)
  • Options
    lechlech Chicagoland
    nifkin is on a role today.
  • Options
    yeah, im just looking through it at the minute to see what the problem is, let me know if you fix it before me!
  • Options
    I will do.
  • Options
    it worked for me on my install, try making a new post in a thread.
  • Options
    I did that. *tries again*
  • Options
    dont suppose this will require 0.9.2 will it?
  • Options
    BINGO! some of the changes I made to the js file made it stop working. Works now. Cheers.
  • Options
    hmmm... mine still isnt working... did you do anything special nathan?
  • Options
    edited July 2005
    It shouldn't be a question of version. Or at least that's what I'm assuming. $Head->AddScript() is how all the other JS is referenced when a page is built from what I'm looking at.

    Do you have the .js file in the vanilla js directory or somewhere else?

    Is it named with the Caps in the file name (YellowFade.js)?
  • Options
    edited July 2005
    yes and yes. Im going to try it on the default style, and not my custom one and see what happens. answer - nothing :)
  • Options
    hmm stuart, maybe try it with a fresh install, and then backtrack to see why it's not working?
  • Options
    edited July 2005
    right, im clearly doing something wrong. tried a fresh install, and still no joy. could you chuck me your extension file and YellowFade.js files please nathan. here or email stuart [at] 36-degrees.co.uk
  • Options
    edited July 2005
This discussion has been closed.