Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

weirdness when posting HTML

fuarfuar New
edited July 2005 in Vanilla 1.0 Help
For some reason all the comments i post with HTML in them seem to come out as blocked even though they aren't, if I click block, and then unblock it renders properly, this happens both with text-only on and off.

Any ideas?

Comments

  • edited July 2005
    http://lussumo.com/community/comments.php?DiscussionID=550&page=1#Item_6

    Check my comment there. It's possible that's entirely and totally related to that. can you post some screenshots? or post a step by step instructions on how to create the problem?

    edit: clarified my question
  • I figured it out, my comments were text as default, stupid me.
  • ah, but it does point out an interesting bug whereby text comments are turned into HTML comments and could potentially be used FOR EVIL™
  • but that "format comments as" stuffs below this input doesn't appear in my forum, is it some extension?
  • you need to enable extensions for the HTML and markdown options (and Textile too if you want that one)
  • they are enabled, but still no format options... :(
    and all my users seems to be set for text as default...
  • They're under Settings, Manage Extensions, HTML Formatter and Markdown.
  • I'm out of ideas for you then.

    Are you using 0.9.2.2?*




    * default question for troubleshooting :)
  • i am
  • the format options appears on other people's browsers on my forum, so why can't i see them?

    this just gets weirder and weirder
  • fixed it.
    but is it possible to set HTML as the default value when new users are created?
  • I know there's a per-user preference to set what your choice is. Don't remember seeing a global/default one though.
  • MarkMark Vanilla Staff
    edited July 2005
    Did you have "hide comment formats" enabled on your profile or something?

    The default format is defined in appg/settings.php

    DEFAULTSTRINGFORMAT

    The default is Text because Vanilla comes with Text as the only enabled option. There is currently no way to change this option through Vanilla administration.

    I sense a feature-request coming on :)
  • Old post but Mark can you create a feature to enable and disable HTML or Text?

    SnaveZ :)
  • @SnaveZ: plugins exist for vanilla1 for this (this discussion is about v1)
Sign In or Register to comment.