Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Attachments + Inline Images display only filename

edited February 2009 in Vanilla 1.0 Help
I'm having some problems with these extensions. I'm also using JQThickbox, but even when this extension is disabled the above don't work. The problem is that when I upload an image, only its filename is shown in the comment (as text when Thickbox is disabled, as a link not leading to the image when TB is enabled). Does anyone know how this could be fixed?

image
«1

Comments

  • edited March 2007
    Do you also have the JQuery extension installed? The text in the admin panel on the Inline Images settings page states: Use ThickBox (Requires JQuery and JQThickBox extensions!). You also have to enable these extensions in the proper order - JQuery, then JQThickBox, then Inline Images.

    To have the image show up in the post, you have to use this code: [Image_%AttachmentID%] (AttachmentID being the number assigned to the attached image) in the post where you want the image.
  • I'm aware of all of what you've written ;-)
  • i'm going to assume this is ur local server and hence no way for us to help you
  • I had an issue with this addon when I first installed it, and it was an error of mine that caused it. Make sure in your admin panel, in Attachment Settings, that you list the url correctly for the uploads folder, i.e.:

    /home/username/public_html/domain/support/uploads/Attachments/%year%/%userid%/

    Make sure the trailing slash is at the end of this url; otherwise, the inline images won't display.
  • I'm having the same problem. The url for the upload-folder seems ok (the files get uploaded, and the thumbnails are there etc). When I'm trying to access the image through the inlineImages-phps the files seem corrupted? Can't view them in the browser. Someone got any solutions? Example: http://www.nordicphotogroup.com/admin/forum/extensions/InlineImages/image.php?AttachmentID=36
  • edited April 2007
    I just can't figure it out... the path is OK though. It doesn't interfere with any other plugin. I re-uploaded Attachments, Inline Images, Multi-file Upload, JQuery, JQThickBox, deletet all the info they created in conf/settings.php and reactivated them. Still the same... and the most irritating thing about it is that they worked nicely for some time!
  • And they just randomly stopped working? Strange...

    I'd definitely take JQuery and JQThickBox out of the equation while you get this fixed unless you need them for something else. Disable them, delete them and remove any settings from them in the settings.php file just to be sure. Once you have InlineImages working properly again, then get them back on. I say this as the author of those two plugins...
  • What about that the images seems corrupted when trying to download them through the inlineImages-php? Someone got any clues?
  • At least now I know that the problemy is with the InlineImages. With only Attachments enabled, everything is as it should be. Hope i can figure it out...
  • I give up... I just don't what could be the reason why this doesn't work. When I'm using only the Attachments extension, everything's alright - the image is downloadable. But when I enable Inline Images the only thing that is displayed is the filename (no image, no link). Could someone please help me with this?
  • Lipa -

    Can you give a link to your forum so that we can check out the problem? You'll need to enable Inline Images so that the problem can be observed first-hand. Maybe then one of us can come up with a solution that works for your situation.
  • The exact same thing happens to me. Would realy appreciate some help.
  • edited April 2007
    The problem is that it's a closed (company) forum... and I can't allow anyone from outside the company to enter it. Sorry.
  • Lipa -

    Okay, I can respect that. But there is something else you can do that might give us a clue as to what's happening.

    If you already have a post that has an image in it that will only display the filename as a link, copy the link and post it here (change the domain in the url to read "mydomain.com", but leave what comes after the domain intact so I can see the path to the file. I had a similar problem, and I'd like to see if you're having the same issue.

    Would that be possible?
  • * bump *
  • Lipa -

    The URL is different than what I am getting on my install - mine shows http://www.mydomain.com/support/extensions/InlineImages/image.php?AttachmentID=1. The difference is in the php file called - mine is showing image.php?AttachmentID=1 and yours is showing image.jpg.php?AttachmentID=1.

    In a previous post, you said you were using the Multi-file Upload extension. Is that extension still enabled? If it is, try disabling that, Inline Images, and Attachments, then re-enable Attachments and Inline Images only, and see if the problem persists. If it does, please post the link again to the image like you did before.

    I only have Attachments and Inline Images installed (not Multi-file Upload), so I cannot test if the last one may be causing a conflict.
  • As I stated before: I disabled all those plugins (Attachments, Multifile Upload, JQuery, JQthickbox, Inline Images), deleted them from the server, deleted all the info they created in conf/settings.php, then reuploaded (freshly downloaded form the add-ons site), enabled ONLY Attachments, tested it - worked fine, then I enabled Inline Images... after having no idea of how to fix this problem, I started this discussion. So now we're back where we started :]
  • The only thing I know to tell you to do now is to contact the author of both extensions (Jazzman) and see if he can help figure this out.
  • I still have no luck fixing this problem. I found some discussions describing the same problem (here, here, here and here), but that's what's been fixedf in the newest version of Inline Images and I'm still having the same problem...
Sign In or Register to comment.