HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

installer.php 404'ing - Win2K - IIS 5

edited September 2007 in Vanilla 1.0 Help
I've scoured the community, and found a few issues with "blank screens" following the premissions check, database setup, etc., but have yet to come across my issue, so here goes. I'm installing this fresh on a local web server I setup with Windows Server 2000. I've got PHP 5.2.3 and MySQL 5.0 running fine. I think I've set the permissions on the required folders properly -- I have played with both "Web Sharing" and "Sharing" permissions on multiple folder(s). (I'm no IIS expert, and all the Lussumo documentation seems to be weighted towards *nix, but any-hoo). I can get to the Vanilla-1.1.3/setup/ page fine. When I click the "click here to install a completely brand new version of Vanilla", the URL resolves to "Vanilla-1.1.3/setup/installer.php", but in IE7 I get a 404 (not found), and in FF 2 I get a "No input file specified". I tried to find where my error logs would be, but that involved more command line garbage that I plain just don't understand. The installer.php file is there, so I have not idea why its 404'ing on me. IIS is configured to recognize php files. I've tried adding this to the beginning of my .htaccess file: SecFilterEngine On SecFilterSelective "REQUEST_URI" "/setup/installer.php" "allow,nolog" I've tried moving the .htaccess file to the root (Vanilla-1.1.3) folder. I'm not sure what else to try, which is why I've turned here. If anyone has any type of similar experience, please share as I'd love to get this up & running! Thank you.

Comments

  • I figured this out. It came down to IIS and what I think was probably a port sharing issue with Apache. Also, could have to do with attempting to change permissions from another machine via Dreamweaver, which didn't seem to "take". Not sure if Win 2K just barfed on another box trying to mod file permissions. Either way, I reinstalled IIS and I got past the initial screen to the permissions check screen.
This discussion has been closed.