HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Discussion Tags Plugin Error

edited January 2008 in Vanilla 1.0 Help
DiscussionTags 0.3.1 I use it in local server with no problem (on windows xp with apache friends' xampp ) but on live server I have problem with displaying all tags. I think the problem reasons from friendly urls which I dont use on local server (but I use friendly urls on live apache server). You can the error on live server: http://www.japonya.org/sozluk/extension.php?PostBackAction=DiscussionTags which is : A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message The "DiscussionTags" class referenced by "DiscussionTags" does not appear to exist. Affected Elements ObjectFactory.NewObject(); For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs

Comments

  • Have you tried simply reinstalling the extension?
  • I don't know if this will solve it. You might want to make sure your PHP versions are the same on your test server as your production server. I have not had this problem, but I have had it with other applications when I run in test and then go to run in production and realize that test and production don't have similar PHP functions.
  • Reinstalling the extension did not solve the problem. But I checked php versions. I use php 5.2.3 on local server. And live server was php 4.4.x. So I configured live server to use php 5 and the problem is solved. But this time I got this errors: Warning: session_start() [function.session-start]: open(/tmp/sess_e25dacd42b69289e49c9d24e86d64a09, O_RDWR) failed: Permission denied (13) in /home/xxxxxxx/public_html/japonya/sozluk/library/People/People.Class.Authenticator.php on line 113 Warning: Unknown: open(/tmp/sess_e25dacd42b69289e49c9d24e86d64a09, O_RDWR) failed: Permission denied (13) in Unknown on line 0 Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0 Then I deleted all the things on tmp folder for my account on the server. So it works now. Thanks a lot.
This discussion has been closed.