HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Login timeout causing errors when typing long posts

edited June 2008 in Vanilla 1.0 Help
Something tells me this might be a common problem, but I have not been able to find a solution thus far.

One of my users posted this error:

Notice: Undefined index: CssClass in /home/XXX/public_html/XXX/themes/people_banner.php on line 5

He noted how it came about:

i typed out quite a big post, waited too long, clicked the post button and got logged out. The error message above is what i got when i tried to send while not logged in.

Can anyone help me either (1) resolve the issue, or (2) change the login duration to last >24 hours?

Thank you in advance!

Comments

  • That particular error shouldn't have happened, but the login duration has to do with whether or not the user checked "Remember Me" when they logged in.
  • My users are still having trouble keeping logged in -- particularily, I believe, when using Safari.

    I feel like it's Vanilla that's signing people out, not a time out. It redirects the page to: localhost/vanilla people.php?PageAction=SignOutNow&ReturnUrl=localhost

    Is there a way to manually extend the cookie or allow a permanent login?

    ... Also, not sure if anyone saw this, but this extension has been very useful and came from one of our members.
  • Why are you using localhost?
  • Regular old '/' ...

    Here's the settings in conf/settings.php:

    $Configuration['COOKIE_DOMAIN'] = 'gtdorgtfo.com'; $Configuration['COOKIE_PATH'] = '/';
  • But you say it redirects to localhost?
  • edited June 2008
    Nah, it consistently redirects the user to a logout script. Check out the get variables.

    http://gtdorgtfo.com/people.php?PageAction=SignOutNow&ReturnUrl=http://gtdorgtfo.com/

    P.S. Thanks Minisweeper
  • OK. So when you said "It redirects the page to: localhost/vanilla people.php?PageAction=SignOutNow&ReturnUrl=localhost" that was wrong? Cause that's bound to cause trouble. But your latest URL looks better.
This discussion has been closed.