HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Extensions not added to Administrator Account

edited December 2008 in Vanilla 1.0 Help

I've run into an issue adding extensions to my newly installed forum. I added a number of extensions that need to be set in the Roles & Permissions page, such as the Add Member extension, Remove comments/discussions and the Wall extension. After uploading these to the server, I can turn them on in the Extensions page, and I suppose this will normally add a few lines to the permissions list in the database for Member and Administrator.

I can then easily set the permissions for Members in the Roles & Permissions page and they work just fine. However, whenever I try to set the permissions for the Administrator, I get a "Forbidden
You don't have permission to access to this document on this server." page. After looking through the permission list in the Database, I found that there are some options missing in the admin Role.

Firstly, here are the options I cannot alter:
Can create a new member
Can remove any comment and discussion
Can remove their own comments and discussions (with no replies)
Wall: Can write on public wall
Wall: All private messages visible
Wall: Ability to moderate VISIBLE messages on all walls

In the database, in table LUM_Role, these options are added to the Member Role in the permissions field (but they are missing in the Administrator Role):

Now my guess is that these permissions should somehow be added to the Admin as well, but then with i:1 instead of i:0. The fact that they are missing in the Admin permissions field could be the explanation for why I'm getting the Forbidden error.

I have tried to add the options to the Administrator account manually as well (in de database), but when I do that, I can't even see the Settings tab anymore as Admin! So that doesn't do the trick (but possibly I'm doing something wrong) I don't know how that happens, but apparently it's not possible to add these options in the way I try it.

Any suggestions? I'm in the dark as to what is going on and help would be much appreciated...


This discussion has been closed.