HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

File structure for domain

edited October 2005 in Vanilla 1.0 Help
I successfully installed Vanilla under my domain. That domain also has three WP blogs, the top level one is cranialcavity.net. As installed and when clicking the "discussions" tab it redirects to my top level blog vice Vanila discussion. The URL when redirected is cranialcavity.net/vanilla. When I manually add /index.php in the browser (ie cranialcavity.net/vanilla/index.php) it will correctly call up the discussions page. I checked the settings page and .php file and they both contain the /index.php section. What do I need to edit to correct this problem. On a secondary problem: I also installed Vanilla on my home box. (to play with CSS etc offline) It was manually installed and as a result It never requested the entery of a name and password for me as the administrator. Any ideas on how to correct this? Thanks Marc
«1

Comments

  • I dont quite understand your first problem, but as for the second, i think you just have to create an account as a normal user as you would if you were joining the forum then go into your database and change the role number to 6 (or whatever's admin in your case)
  • edited September 2005
    Lets see if I can clarify the first problem. Under the discussions tab the URL is cranialcavity.net/vanilla, when it should read "cranialcavity.net/vanilla/index.php" As a result when clicked on it opens the index page on my blog vice Vanilla. (The blog index is "cranialcavity.net/wordpress/index.php" and Vanilla is installed under "cranialcavity.net/vanilla") The same occurs when logging in, it directs to my blog index vice Vanilla. I can manually add the suffice (/index.php) and it opens the correct page, but obviously this is a problem for everyone but me. Under applications settings both "Web-path to Vanilla" and "Cookie domain" are set to "cranialcavity.net/vanilla/index.php" Under the other tabs (Categories Search etc) the path seems to be correct and directs to the proper page. Hope this is a little more understandable. Thanks
  • ahh, i get it. unfortunately i dont have time to find a solution. if noone else has then remind me later. I really need that 'mark as unread' feature..
  • Not a problem. There is no hurry, the forum is far, far from the time it will "go active." I'll post an update in a few days or if I discover a solution myself. Thanks
  • Right, try opening appg/init_internal.php and finding the //BUILD THE MAIN MENU Below that is where it adds all the tabs - the first being discussions: $Menu->AddTab($Context->GetDefinition("Discussions"), "discussions", "./", "DiscussionsTab"); Try changing that to: $Menu->AddTab($Context->GetDefinition("Discussions"), "discussions", "index.php", "DiscussionsTab");
  • edited September 2005
    OK, one problem solved. The discussions tab is correct but their is still an issue when going from the sign in page. After signing in it directs me to the following URL: "cranialcavity.net/vanilla" What displays is my blog on that domain. ("cranialcavity.net") When it should be "cranialcavity.net/vanilla/index.php" I guess my biggest question is why both of these seemingly related problems occured? The install was done automaticlly, BTW Does Vanilla create an .htacces file? If so it must be buried somewhere I couldn't find it. Thanks for your prior help
  • lechlech Chicagoland
    In your settings.php, is the path to the forum correct? you may want to check it, it should look something like this:

    line 30:
    define("agDOMAIN", "cranialcavity.net/vanilla/");

    that should fix it from going to the wrong area upon sucessful login.
  • lech would the trailing slash alter how that link was used? It just struck me he's using the cookie domain of cranialcavity.net/vanilla/index.php which is probably better as .cranialcavity.net/vanilla/ but that has nothing to do with the problem we're discussing anyway so i'm not sure why i brought it up. Anyway, would that slash make it consider the folder? It seems at the moment it's avoiding vanilla for some reason to do with his blog in which case he might have to go code hacking again...?
  • lechlech Chicagoland
    edited September 2005
    the trailing slash would throw it into or out of the proper directory depending on how it's being called. for example without the trailing slash it might look something like:

    crainialcavity.net/vanillaindex.php

    instead of the slash being there to form the proper directory structure. else it would throw a 404 or land you outside your intended destination. that is if I'm reading all of this right (sorry tired as hell). typically the trailing slash (depending on the nature) is a good thing.
  • hmm.. indeed. You wanna try adding those trailing slashes and changing your paths like lech has suggested and see if that helps, cranial?
  • lechlech Chicagoland
    back up your current files and only tamper with the /appg/ folder for best results, you really shouldn't have to modify anything outside of the /appg/ unless it's a do or die operation.
  • Here is the entire section from settings.php. You would think because the entire URL is desinated the problem shouldn't exsist, obviously not true.

    // Application Settings
    define("agAPPLICATION_TITLE", "Full Throttle Forum");
    define("agBANNER_TITLE", "Full Throttle Forum");
    define("agDEFAULT_STYLE", "styles/vanilla/");
    define("agDOMAIN", "cranialcavity.net/vanilla/index.php");
    define("agSAFE_REDIRECT", "signin.php?PageAction=SignOut");
    define("agDISCUSSIONS_PER_PAGE", "30");
    define("agDISCUSSIONS_PER_FEED", "20");
    define("agCOMMENTS_PER_PAGE", "50");
    define("agSEARCH_RESULTS_PER_PAGE", "30");
    define("agCOOKIE_DOMAIN", "cranialcavity.net/vanilla/index.php");
    define("agSUPPORT_EMAIL", "[email protected]");
    define("agSUPPORT_NAME", "Marc");
    define("agALLOW_NAME_CHANGE", "1");
    define("agPUBLIC_BROWSING", "1");
    define("agUSE_CATEGORIES", "1");
    define("agLOG_ALL_IPS", "0");
  • I'm surprised that hasnt been causing problems actually. Try changing it to cranialcavity.net/vanilla/ And change your cookie domain to .cranialcavity.net
  • deeldeel New
    edited September 2005
    mine is set to "www.mydomain.com/vanilla/"

    does it need the"www"?
  • I think the WWW depends on the way your server is setup. Some servers/domains dont care about it. Some will automatically forward and add the WWW, others forward and drop the WWW. Some dont work at all unless you add it. Im not a server expert, thats just what Ive noticed. Like my server, sometimes I have issues with things unless I add it.
  • Try changing it to cranialcavity.net/vanilla/
    And change your cookie domain to .cranialcavity.net
    Sorry no luck, the above settings had no effect even after a hard refresh.
  • Well the cookie domain thing wouldnt - its just a semi bugfix for anyone who's having cookie problems (which might not be you but might be one of your users) That really is rather odd if the path doesnt work. You certainly shouldnt need the index.php reference in there. Remind me when i get home and i'll find out what you need to change to force it to use index after signin. deel - depending which definition is set to that, it probably doesnt make a difference. If it aint broke dont fix it.
  • Not a problem, thanks for all your hard work. BTW there are no users at the moment. I just installed the program and will be working out whatever issues there are before "going live." That would include possibly waiting for the next upgrade which apparently includes a type of theming system.
  • Can i take it from that that your sign in still isnt working properly?
  • lechlech Chicagoland
    for define("agDOMAIN", "cranialcavity.net/vanilla/index.php"); take out the index.php

    restore everything else in the /appg folder except your settings.php.
This discussion has been closed.