HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

File structure for domain

2»

Comments

  • lech I have tried both: "agDOMAIN", "cranialcavity.net/vanilla/index.php" and "agDOMAIN", "cranialcavity.net/vanilla/" With no change, signin is still misdirected. By "restore evertthing.... do you mean up load fresh copies of all files in /aapg folder?
  • lechlech Chicagoland
    yes, just save the settings.php and restore everything else as new.
  • lechlech Chicagoland
    do make backups however in case you do need to redo whatever else again.
  • No luck Lech, here is what was done. Deleted the /appg folder and uploaded fresh from the original download of Vanilla. In /appg/settings.php is this line "agDOMAIN", "cranialcavity.net/vanilla/" Under applications settings Web-path to Vanilla is "cranialcavity.net/vanilla/ cookie domin is set to "cranialcvity.net" When signing in it still directs me to "cranialcavity.net/vanilla" (note no ending slash) What is displayed is my blog index page showing the header img and no data. Is it possible because Vanilla is installed directly under cranialcavity.net vice a sub-domain (vanilla.cranialcavity.net) that is causing the problem?
  • It shouln't, as I have it intalled in a sub-domain. Lech said DON'T delete the setting file. I think you did, so I just want to make sure that you restored all the changes Lech and Mini have asked you to make. Just need to be sure.
  • Nathan: No I left the settings.php in the folder and deleted the rest. And backed up the entire folder for that matter.
  • ah. I'm not sure what else to suggest. Sorry. I'm glad you backed it all up though. Good move.
  • lechlech Chicagoland
    yeah, I have no idea what could possibly be misfiring there, if the cookie domain and the path are right and it's still screwing up like that, the only thing I can think of is your php or server are acting against you. so unless I'm missing something in this little scenario, I can't tell what the exact problem is. From the looks of it on your domain, you have some kind of custom 404 running there that redirects all queries to some search results page. Did you install vanilla manually or with the installer? if you wouldn't mind, I would say dump all the mysql tables for vanilla, and try starting from scratch and for the meanwhile disable that funky 404. If that's a wordpress thing enabled to trap queries, you could be missing important error messages. If you're still having trouble, feel free to whisper your aim/icq/msn/whatever address to me and I'll see if I can help you further if you're still having problems, because right now I can't pinpoint what's going on exactly.
  • Hold on, you say you installed it on a subdomain; so have you tried using vanilla.cranialcavity.net/ as the paths?
  • although, the web accessible path COULD still be, cranialcavity.net/vanilla.
  • lechlech Chicagoland
    agdomain should just be domain.com/pathtovanilla/ with the trailing slash as most webservers will interpret anything called after it as a combined directory request ie pathtovanillaindex.php and so on.
  • edited October 2005
    No minesweeper I just questioned whether not having Vanilla on a sub domain may have caused the problem. It is installed directly under the main domain (cranialcavity.net/vanilla).

    Vanilla was installed via the auto installer.

    As far as the funky 404? No clue, if it's there it was done automaticlly somewhere along the line. Possible considering three blogs are installed and all have been consistently upgraded as the WP software has been.

    Add to that the many spam plugins etc, etc.

    I'll have a peak at the .htaccess files and let you guys know

    Thanks.

    Update: Just finished checking my .htaccess file. I see no mention of any 404 redirects. The only thing close was a funky bit of code for trackback spam. I deleted that but it had no effect on the current problem.

    It may take a few hours to get to it, but I think I'll delete all the tables and start with a fresh install.

    Thanks again.
  • lechlech Chicagoland
    Well, you definatly have some type of page that's redirecting all queries to itself and pointing it back to something within wordpress. At least that's what I gather it's that "bad behavior" plugin as well as whatever else might be running as your search engine collecting those queries. I honestly don't know what you're running there but that's what's being hinted from the looks of it.
This discussion has been closed.