Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Foreign characters and Friendly URLs problem

TudorTudor
edited June 2009 in Vanilla 1.0 Help
I am using the Friendly URLs extension and I noticed the following problem.

In Romanian language we use two special characters (among others):
- Ș (s comma below: Ș and ș )
- Èš (t comma below: Ț and ț )

Let's say the name of a forum discussion is "Discuții". The resulting "friendly URL" should be something like: www.your-website/vanilla/discussion/12/discutii (the "ț" must be replaced with "t"). However in Vanilla the URL becomes: www.your-website/vanilla/discussion/12/discuii (notice the missing "t"). Same thing happens with "Ș": instead of being converted to "S", it disappears.

Any idea how to fix this problem?

PS: I set UTF-8 everywhere I could find encoding settings for Vanilla and the database. Other accented characters are converted properly.

Comments

  • TudorTudor
    edited June 2009
    Nevermind, I fixed the issue by adding the missing characters in the CleanupString function (found in FrameworkFunctions.php file).
  • Salut Tudor,

    Is your hack valid for Vanilla 2? I can't seem to find the file/function you've specified.
  • I'm interested in this as well. And no, that function doesn't seem to be present in Vanilla 2.

    /p.s. şi totuşi dacă mai sunt români, a încercat cineva să localizeze versiunea a 2-a? ;)
Sign In or Register to comment.