Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Account Pictures

This discussion is related to the Account Pictures addon.


  • Michael - I had that problem, as did someone else, to quote "so I changed line 148 to include_once rather than include and that seems to have fixed it."
  • ok I'll give it a try tonight and let you know
  • the include_once doesn't fix the avatar showing up lower than the username with the VaneaBlack theme. any ideas?

  • Lament - the include_once wasn't meant to fix that, it fixes uploading both the icon and picture at the same time.

    For your issue, I had the same problem with the standard vanilla theme when going above the default 32x32.

    Your issue will be with the style sheet in some way - either the VaneaBlack theme was designed to take a smaller icon size, or wasn't designed for one at all.

    If you've not done much CSS, install the Web Developer plugin for FireFox and you will pretty quickly be able to diagnose what's going on :)
  • Is there any way to hide the account picture & icon url setting on the personal info page?
  • Yes - read my post above, explaining exactly how.
  • i don't see what you mean??? there's a lot of fixes above, but not for the one I want... what i want to do is hide the url setting for icons & pictures, so the only way to get one is to upload it.

    I think i've figured it out though, im going to look for the lines that add that in /themes/account_preferences_form.php and comment them out.

    Edit ***account_identity_form.php
  • okay so that's not gonna work ... it doesn't add them one at a time, it adds them all aat once, and i don't know php well enough to exclude just those ones.
  • Hello there,

    Thanks for the extension. However, I'm getting the error mentioned previously when attempting to upload an icon or picutre, too:

    phpThumb() v1.7.7-200612252156 in file "phpthumb.class.php" on line 216
  • I lack knowledge on how to add an upload folder?
    Im using Filezilla and Ive got the extension installed. Anyone want to help me take it from there so that I can start uploading. Would be over the moon if you could.
  • I'm getting the same error that's been brought up a few times before here:

    phpThumb() v1.7.7-200612252156 in file "phpthumb.class.php" on line 216 etc. etc. etc.

    Could someone please tell me specifically what was done in order to fix this? It seems like lots of people have solved this problem a few ways. I'd really appreciate it if someone could please spell it out for me a bit more clearly.
  • I'm still needing to sort the phpthumb.class.php error, too.

    phpThumb() v1.7.7-200612252156 in file "phpthumb.class.php" on line 216 setSourceFilename(/hsphere/local/home/erryl/ set $this->sourceFilename to "/hsphere/local/home/erryl/" in file "phpthumb.class.php" on line 234 file_exists() = 0 in file "phpthumb.class.php" on line 1036 is_executable() = 0 in file "phpthumb.class.php" on line 1037 ImageMagickThumbnailToGD() aborting because cannot find convert in $this->config_imagemagick_path (), and `which convert` returned () in file "phpthumb.class.php" on line 1066 $AvailableImageOutputFormats = array(text;ico;bmp;wbmp;gif;png;jpeg) in file "phpthumb.class.php" on line 825 $this->thumbnailFormat set to $this->config_output_format "jpeg" in file "phpthumb.class.php" on line 835 $this->thumbnailQuality set to "75" in file "phpthumb.class.php" on line 852 ResolveFilenameToAbsolute() NOT prepending $this->config_document_root (/hsphere/local/home/erryl/ to $filename (/hsphere/local/home/erryl/ resulting in ($AbsoluteFilename = "/hsphere/local/home/erryl/") in file "phpthumb.class.php" on line 959 $this->sourceFilename set to "/hsphere/local/home/erryl/" in file "phpthumb.class.php" on line 754 phpThumb() v1.7.7-200612252156 "/hsphere/local/home/erryl/" does not exist in file "phpthumb.class.php" on line 3404 setCacheDirectory() starting with config_cache_directory = "" in file "phpthumb.class.php" on line 859 $this->config_cache_directory () is not a directory in file "phpthumb.class.php" on line 895 SetCacheFilename() failed because $this->config_cache_directory is empty in file "phpthumb.class.php" on line 2808 starting ExtractEXIFgetImageSize() in file "phpthumb.class.php" on line 2665 GetImageSize("/hsphere/local/home/erryl/") failed in file "phpthumb.class.php" on line 2688 $this->useRawIMoutput=false because "fltr" is set in file "phpthumb.class.php" on line 1151 ImageMagickThumbnailToGD() aborting because safe_mode is enabled in file "phpthumb.class.php" on line 1201 ImageMagickThumbnailToGD() failed in file "phpthumb.class.php" on line 2695 SetOrientationDependantWidthHeight() starting with ""x"" in file "phpthumb.class.php" on line 2644 SetOrientationDependantWidthHeight() setting w="32", h="32" in file "phpthumb.class.php" on line 2660 EXIF thumbnail extraction: (size=0; type=""; 0x0) in file "phpthumb.class.php" on line 2747 starting SourceImageToGD() in file "phpthumb.class.php" on line 3005 $this->useRawIMoutput=false because "fltr" is set in file "phpthumb.class.php" on line 1151 ImageMagickThumbnailToGD() aborting because safe_mode is enabled in file "phpthumb.class.php" on line 1201 starting ImageCreateFromFilename(/hsphere/local/home/erryl/ in file "phpthumb.class.php" on line 2920 empty $filename or GetImageSize(/hsphere/local/home/erryl/ failed in file "phpthumb.class.php" on line 2969 Populating $rawimagedata in file "phpthumb.class.php" on line 2977 cannot fopen(/hsphere/local/home/erryl/ in file "phpthumb.class.php" on line 2988 Not using EXIF thumbnail data because $this->exif_thumbnail_data is empty in file "phpthumb.class.php" on line 3046 $this->gdimg_source is still empty in file "phpthumb.class.php" on line 3098 ImageMagickThumbnailToGD() failed in file "phpthumb.class.php" on line 3100 phpThumb() v1.7.7-200612252156 Unknown image type identified by "" () in SourceImageToGD()[3210] in file "phpthumb.class.php" on line 3404 SourceImageToGD() failed in file "phpthumb.class.php" on line 312
    I'd really like to use Vanilla, but uploadable avatars is something I want to get working before I do. Thanks.
  • I'm just guessing, but ownership/permissions could well be causing a problem here.
  • For what it's worth, I was having the phpthumb.class.php error above on a test environment.

    The issue went away once I switched from using an IP address to the fully qualified URL. (For testing we hadn't yet changed the nameservers, so the beta was just running off of an IP address.)

    I think this was making it difficult for the extension to find ImageMagick. You might try fiddling with the 'path to ImageMagick' setting in the control panel.

    Hope that helps anyone else having this problem troubleshoot.
  • I'm having the same problems with the phpthumb.class.php

    I'm using a fully qualified address and I've tried it with and without ImageMagick. I'm on debian, and I've got an apt install of ImageMagick so it's in /usr/bin/convert.

    The upload directory is in the root of vanilla and it's chmodded and chown'd correctly so far as I can tell.

    4 drwxrwxrwx 3 www-data marrow 4096 2008-02-12 15:06 uploads

    Any ideas?
  • any chance that the author would re-release the addon with all the fixes that have been mentioned. (hiding the hardcoded account pic/icon fields, include_once rather than include...)
  • If anyone wants the repackaged version with all the fixes so far send me a whisper with your email and I will send it to you... at least until the author has a chance to update his code.
  • @scubaguy: perhaps you should contact the author (jazzman), and ask permission to take over this extension - jazzman developed many fantastic extensions to Vanilla, but hasn't been active for a *very* long time, and many of his extensions are starting to show their age.

    It would be a shame for his work to be abandoned, specially when there are others who are willing to maintain and build on it! :-)
  • can anyone suggest how to include a user's account icon in a wordpress page? this question has been asked a few times but remains unanswered.
  • I'm good at following instructions and doing small code tweaks, but I'm probably not quite up to the task of developing and supporting an extension myself.
  • Warning: move_uploaded_file(/***/community/uploads/AccountPictures/4cd353e1b3bee4df59c3db62a3252b22.png) [function.move-uploaded-file]: failed to open stream: No such file or directory in /***community/library/Framework/Framework.Class.Uploader.php on line 113

    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpOsiWMn' to '/***/community/uploads/AccountPictures/4cd353e1b3bee4df59c3db62a3252b22.png' in /***/community/library/Framework/Framework.Class.Uploader.php on line 113

    i get that error
  • you can download Account Pictures with all the fixes to this point at
  • oh yeah
    thank you a billion thanks
  • new error:

    Warning: getimagesize() [function.getimagesize]: URL file-access is disabled in the server configuration in /***/community/extensions/AccountPictures/default.php on line 62

    Warning: getimagesize(***/hamed/katsushiro_th.jpg?1206134522) [function.getimagesize]: failed to open stream: no suitable wrapper could be found in /***/community/extensions/AccountPictures/default.php on line 62
  • Hamed - your webhost has disabled the file access wrapper. You'll need to mod it to use curl, I think.

    I'm also having problems with the modded version: With it active I can't get to my account.php - so I commented out lines 58-62 which are the ones responsible for that.

    Then it wouldn't upload files, problems with moveing the uploaded file using Framework.Class.Upload.php on line 113. (Which is responsible for moving files from the temporary upload directory to the actual directory the plugin is directing to.

    Where is this tmp directory meant to be anyway? I can't find it. (Perhaps that's the problem).
  • actually right now the account pictures on lussumo works for me, except it may have styling issues .. the images that are not uploaded.. are all messed up
    but the extension from rapidshare does not work at all
  • Hi! it's my first time to post my comments.
    Very exciting though..
    by the way, i have a question:
    does anybody know how to solve this error?

    Warning: move_uploaded_file(/web/home/robeoh/html/vanilla/uploads/AccountPictures/4cd353e1b3bee4df59c3db62a3252b22.jpg) [function.move-uploaded-file]: failed to open stream: Permission denied in /web/home/robeoh/html/vanilla/library/Framework/Framework.Class.Uploader.php on line 113

    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpqzZUWh' to '/web/home/robeoh/html/vanilla/uploads/AccountPictures/4cd353e1b3bee4df59c3db62a3252b22.jpg' in /web/home/robeoh/html/vanilla/library/Framework/Framework.Class.Uploader.php on line 113

    i've tried to solve it at uploader.php but couldn't figure it out..

    any wisdom for this? if you do, please tell me i'd be very appreciated.
  • Looks like a permissions error in the destination directory.
  • Is there a list of the new features somewhere? 1.1.1 is running just fine for me and with these comments about errors I don't know if I want to upgrade unless there is something to make it worthwhile...thanks!
Sign In or Register to comment.