Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Solved] Moved Vanilla but paths to image sprites links to old location

yusfyusf New
edited March 2013 in Vanilla 2.0 - 2.8

Upon moving Vanilla to another place I did the cache wipe according to instructions, so stylesheets and all follows to the new location.

Except the various links in the stylesheets that links to resource images such as sprites.png which continues to link to the old location, leaving the boxes empty of graphics and the site pretty hard to use.

How do I change/update that path?

«1

Comments

  • peregrineperegrine MVP
    edited March 2013

    are you sure it links to the old location, or are the images missing from the new location?

    use firebug to determine which is your problem.

    by default they are located here.

    applications/dashboard/design/images/

    But like anything else you can adjust your .css to point wherever you want.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • hgtonighthgtonight ∞ · New Moderator

    @yusf If your css used absolute references, you will have to update them manually. Are you sure the image files moved with your vanilla install?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • @hgtonight said:
    yusf If your css used absolute references, you will have to update them manually. Are you sure the image files moved with your vanilla install?

    got there a minute before you , lol!

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    hgtonightUnderDog
  • yusfyusf New
    edited March 2013

    @hgtonight @peregrine
    No custom CSS at all. Pretty much a clean install, some plugins, then moved.

    Firebug shows that links do refer to the old path, so it must be set somewhere in code or database I figure…

  • peregrineperegrine MVP
    edited March 2013

    give a screenshot. with page and firebug. or a link to your site.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • hgtonighthgtonight ∞ · New Moderator

    @yusf

    If you changed folders or hosts you will have to update your /conf/config.php manually.

    $Configuration['Garden']['Domain']                              = '';
    $Configuration['Garden']['WebRoot']                             = FALSE; // You can set this value if you are using htaccess to direct into the application, but the correct webroot isn't being recognized.
    

    This should push you towards a solution

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    peregrineUnderDog
  • yusfyusf New
    edited March 2013

    @peregrine

    Certainly!

    Where images fail to show:

    What it says in Firebug:

    The new path is simply "/forum".

  • peregrineperegrine MVP
    edited March 2013

    erase your ini files in your /cache.

    you are using vanilla 2.1 correct.

    then you can see what actual .css you are using and modify ii, if hgtonight's fix doesn't solve it.

    $Configuration['DebugAssets'] = TRUE;

    I still think when people ask a question they should specify vanilla version.

    It's not that hard look in your dashboard at the bottom right - it shows your version.
    or look in index.php - if you want to find the version the hard way.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    yusfUnderDog
  • nah leave the folders intact.

    grep is your friend.

  • @kasperisager @x00

    What entails the entire cache? I've tried erasing ini files and the rest of the files in the cache (empties and folders excluded), to no avail…

  • read my comment.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • what version of vanilla are you using, are you using any cahing plugins like consolidate, minify, pagespeed?

    grep is your friend.

    UnderDog
  • clear the folders but do not delete the folders. that is what I meant by intact.

    grep is your friend.

  • Sorry if I confused anyone. My version version 2.1, correct.

    Clearing caches doesn't update the path.

    Using $Configuration['DebugAssets'] = TRUE; it actually works, but that's really no good long term right?

  • peregrineperegrine MVP
    edited March 2013

    try removing it now.

    $Configuration['DebugAssets'] = TRUE;

    or setting it to FALSE

    should be working fine.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • @peregrine

    Correct! Here's to all you fine people helping me out

    Kasper
  • peregrineperegrine MVP
    edited March 2013

    so click awesome or insightful - your final step.

    And remember when migrating vanilla to another site or when changing .css (for anyone else)

    1) clear the .ini files from cache.
    2) if you are using 2.1 and css updates still don't work, add config statement to config.php
    $Configuration['DebugAssets'] = TRUE;
    3) if it displays correctly now.
    4)if you are using 2.1 modify config statement you added to:
    $Configuration['DebugAssets'] = FALSE;

    also see x00's suggestion if you are using

    are you using any caching plugins like consolidate, minify, pagespeed?clear the folders

    but do not delete the folders. that is what I meant by intact.

    @yusf
    P.S. you could add this to the wiki.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    yusfUnderDog
  • UnderDogUnderDog Moderator

    @yusf said:
    Correct! Here's to all you fine people helping me out

    Can you document it on the wiki please?

Sign In or Register to comment.