Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Fatal Error GDN_ThanksLog?

This discussion is related to the Thankful People addon.
qbauerqbauer
edited April 2013 in Vanilla 2.0 - 2.8

Got this on a shared server (on activation of the plugin):

The addon could not be enabled because it generated a fatal error:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'where name = 'GDN_ThanksLog'' at line 1|Gdn_Database|Query|show table status where name = 'GDN_ThanksLog'

Worked perfectly on a development environment....

Wondering if I need to go into the database?

Comments

  • peregrineperegrine MVP
    edited April 2013

    try enabling and disabling again.

    • not sure if you did the following below:

    • You can't just copy plugins and configs straight across, if the plugin writes to a new table or column it will always result in the error.

    edit: I actually reread your message. it looks like you tried to enable it properly.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • peregrineperegrine MVP
    edited April 2013

    Do you see the table in your phpmyadmin and look at structure

    is it an ISAM table and does your host support ISAM and the primary keys set up correctly.

    just a wild guess.

    also try

    show engines.

    and try utility/update

    and what version of vanilla are you using.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • qbauerqbauer
    edited April 2013

    Vanilla is 2.0.18.8, fresh install.

    I'm going to have to install phpmyadmin and check the tables. I'll follow your suggestions and get back to you. Thank you.

    UnderDog
Sign In or Register to comment.