Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Trying to upgrade vanilla forum because my forum js was infected*

124

Comments

  • I did thanks, that's for another day, I need some sleep.

    Thanks again for all your help

    vrijvlinderperegrinehgtonight
  • avantime4mikeavantime4mike ✭✭
    edited March 2014

    Another issue since upgrading. I previously had my index.html pointing to:-
    http://www.avantime-owners.com/forum/about-us
    This would take visitors to my site straight to one of my "Basic Pages" within Vanilla.
    Since the upgrade the same page url is now:-
    http://www.avantime-owners.com/forum/index.php?p=/about-us
    I've edited my index.html but it won't resolve properly and returns a 404
    Firstly why has it changed and secondly how do I fix it please?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You need to set up ReWrite URL TRUE in the config.php and also the htaccess

    Look at the this for guidance

    http://vanillaforums.org/discussion/25111/about-error-404-not-found#latest

    peregrine
  • avantime4mikeavantime4mike ✭✭
    edited March 2014

    Thanks @vrijvlinder but that looks like a recipe for disaster even if I understood a word of it. I've done the line 55 rewrite urls TRUE in config.php but that made no difference on it's own. The htaccess bit, well, I think I'd better stick to less complicated issues until I understand things a bit better. I'll have to find another way. I still don't know whats changed from before the upgrade.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Just copy paste here your htaccess file and we will get you through, without that change rewrite urls does nothing.

    hgtonight
  • peregrineperegrine MVP
    edited March 2014
    does your .htaccess file in the forum directory   have this
    
        # Modified
        # If you modify this file then change the above line to: # Modified
        <IfModule mod_rewrite.c>
        RewriteEngine On
        # Certain hosts may require the following line.
        # If vanilla is in a subfolder then you need to specify it after the /.
        # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
        RewriteBase /forum
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
        </IfModule>
    
    
    and does your config.php  have this  (check your to see if it has typos.)
    
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • This is mine:-

    Original

    If you modify this file then change the above line to: # Modified


    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    # RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

  • peregrineperegrine MVP
    edited March 2014

    # RewriteBase /

    change it to

    RewriteBase /forum

    I also mentioned it in this link ..... http://vanillaforums.org/discussion/comment/203966/#Comment_203966

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • avantime4mikeavantime4mike ✭✭
    edited March 2014

    Like this:-

    Modified

    If you modify this file then change the above line to: # Modified


    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    # RewriteBase /forum
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

    Still doesn't resolve:- http://www.avantime-owners.com

  • avantime4mikeavantime4mike ✭✭
    edited March 2014

    Here's my index.html (parenthesis removed so it will display)

    (!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd")
    (html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en")
    (head)
    (meta HTTP-EQUIV="REFRESH" content="0; url=http://www.avantime-owners.com/forum")
    (/head)
    (/html)

  • peregrineperegrine MVP
    edited March 2014

    take the # sign off - that means it is a comment with the #

    line below is CORRECT

    RewriteBase /forum


    INCORRECT BELOW

    below is NOT correct (below it is a comment because of the #sign

                 # RewriteBase /forum
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You need to remove the # from in front of the RewriteBase /

    The # is used to disable something

    peregrine
  • <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

    in html5 you don't need that.

    just

    <!DOCTYPE html>

    is sufficient.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • take a moment and read the last 7 comments or so :)

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • avantime4mikeavantime4mike ✭✭
    edited March 2014

    Thanks both, I knew that actually (about the #), just rushing again, sorry. Of course it now works, you guys are great.
    Hugs....

    vrijvlinder
  • avantime4mikeavantime4mike ✭✭
    edited March 2014

    html lessons too :sweat_smile:

    peregrinevrijvlinder
  • avantime4mikeavantime4mike ✭✭
    edited March 2014

    Index.html changed too, thanks again guys.

    Please don't take this as any kind of criticism, you guys are awesome but just have a read of this short paragraph taken from http://vanillaforums.org/discussion/25111/about-error-404-not-found#latest and try to imagine you are a total beginner:-

    The .htaccess (hypertext access) file is a directory-level configuration file supported by several web servers, that allows for decentralized management of web server configuration. They are placed inside the web tree, and are able to override a subset of the server's global configuration for the directory that they are in, and all sub-directories.

    :sweat_smile: :sweat_smile: :sweat_smile:

    vrijvlinderperegrine
  • peregrineperegrine MVP
    edited March 2014

    you've achieved guru status! mike. and a new awesome badge

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
Sign In or Register to comment.