Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 2.1, Wordpress 3.9 and wordpress plugin SS0 sign out problem

Hi,

New dummy in the place but really like vanilla forum so far :-)

I am half done with the wordpress integration using 1.1.14 version plugin from Mr Burry to embed the forum on my website. But still have two things to resolve concerning SSO and would appreciate having some help here.

Here is my last concerns with SSO integration on my website http://www.energympro.com/beta/forum/

1

If a certain user sign out from wordpress, he will still stays logged-in in the forum or vice-versa: sign out from the forum, still logged-in in wordpress.

2

Clicking SIGN-IN with ENERGYMPRO button lead to the parse error page. You have to log in using the wordpress form to have access to your forum account.


To get this working up to where I am now I did the following:

1

Did the 1.1 part only from this page to get the js connect plugin working:
http://vanillaforums.org/discussion/26436/implementing-sso-using-jsconnect-1-4-1-with-vanilla-2-0-18-10-part-i

2

then follow the guide here:
http://blog.vanillaforums.com/help/wordpress-vanilla-forums-single-sign/

A little hint: If I click "make this connection your default sign-in method" in js connect plugin, save my setting and come back to this place, the box will be reset into is uncheck states while the box above "trust connection..." will stays checked.

So yeah, if you think you can be of any help it would be really great. Using basic language for dummy will be even greater.

Cheers,

canadien

Best Answer

Answers

  • hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    Check out this thread: http://vanillaforums.org/discussion/26779/jsconnect-autoconnect-sso-shortcut

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • canadiencanadien New
    edited May 2014

    sorry. realised it was about another plugin. sorry can be deleted

  • hgtonighthgtonight ∞ · New Moderator

    The config file at /conf/config.php will never have all of the available config options in it. If you need/want to add something in there, look for it first. If it isn't there, go ahead and add it yourself.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Nope... just burning time. But maybe if you answers those question it will give me some guide line.

    1

    Does the guide you point me at can be use in pair with the wordpress plugin? (where I think the plugin would replace the step 5:Embeded: Do this complicated stuff)

    2

    If no, is there a reason why this same step 5 point to the second part of the jsConnect Technical Documentation and not the first part?

    I feel I should solve my sign-in parsing error before going trough the autoconnect and autosign-out method...

  • canadiencanadien New
    edited May 2014

    Can't tell if it useful but in safari inspector I have:
    errorPOST http://www.energympro.com/beta/vanilla/entry/jsconnect/error 400 (Bad request)

    And

    input type="hidden" id="JsConnectProviders" value="[{"HashType":"md5","TestMode":false,"Trusted":"1","AuthenticationKey":"---hide---","AuthenticationSchemeAlias":"jsconnect","Name":"ENERGYMPRO","URL":null,"AssociationSecret":"da---hide---","AssociationHashMethod":"md5","AuthenticateUrl":"http:\/\/www.energympro.com\/beta\/?VFRequest=connect ","RegisterUrl":"http:\/\/www.energympro.com\/beta\/wp-login.php?action=register ","SignInUrl":"http:\/\/www.energympro.com\/beta\/wp-login.php?redirect_to=http%3A%2F%2Fwww.energympro.com%2Fbeta%2Fvanilla%2Fentry%2Fjsconnect%3Fclient_id%3D1419234468%26Target%3D%252Fhome%252Ferror ","SignOutUrl":"http:\/\/www.energympro.com\/beta\/wp-login.php?action=logout","PasswordUrl":null,"ProfileUrl":null,"Attributes":"a:3:{s:8:\"HashType\";s:3:\"md5\";s:8:\"TestMode\";b:0;s:7:\"Trusted\";s:1:\"1\";}","Target":"http%3A%2F%2Fwww.energympro.com%2Fbeta%2Fvanilla%2Fentry%2Fjsconnect%3Fclient_id%3D1419234468%26Target%3D%252Fhome%252Ferror"}]" />
    <input type="hidden" id="TransportError" value="A fatal error occurred while processing the request.&lt;br /&gt;The server returned the following response: %s" /
    
  • Thank you so must for pointing me this at hgtonight. You don't know how much grateful I am even if it might look like the silliest thing for most.

    Do probably not have the most stable set-up but here what I've done to get the wordpress plugin working pronely:

    1

    Install wordpress vanilla plugin

    2

    Install jsconnect plugin with the file mod 1.1 (see the OP)

    3

    Did only the last point in your comment link:

    In your logout function, add the code from here: http://pastebin.com/R4wCh9su This is the code from the opening post, but with the spaces in front of Vanilla-ConnectFlood removed (whitespace is not allowed in cookie names). Also, I've changed HOSTNAME to the format that works for me (domain name with a leading dot). I have the following set in my vanilla conf/config.php: $Configuration['Garden']['Cookie']['Domain'] = ''; They don't match, but it works for me.

    It resolve my main problem in my original post.

    Thanks again for your support. Greatly appreciated.

    vrijvlinderhgtonight
  • canadiencanadien New
    edited May 2014

    4

    Ah and I forgot to mention that I still did installed the jsconnect auto signin plugin for its hide sign in and sign out button function. That way the integration is more seamless.

Sign In or Register to comment.