HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Godaddy proxy woos

I have been planning to upgrade vanilla on my godaddy server. the site that it is attached to is a connected to a folder on another site/server, if you know how godaddy does it's routing.

Anyways when I have do a test upgrade everything goes well, but when I click on any link is shows me screen from the main server's home page, yet the path is correct. I have tried this twice with the same effect. what am I missing , did I skip a step or all of the aforementioned?

thanks is advance

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Is GoDaddy acting as your domain registrar, your webhost, or both?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • both so look at my test site: http://puffle.com/forums/

    If you click any link it sends you to a main wordpress page...

  • I followed the read.md update and it said successful.

  • peregrineperegrine MVP
    edited July 2014

    sounds like your .htaccess may be incorrect or the way you added the forum to wordpress is incorrect (if you embedded).

    for better answers you might

    ALWAYS supply the version number of vanilla you are using when asking a question.

    why? because

    http://vanillaforums.org/discussion/26943/tutorial-how-to-determine-the-version-number-of-vanilla-that-you-are-using-for-your-own-forum

    post your config.php minus the password information

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • ok sorry I was not clear... I have 2.0.1.18 and wanted to upgrade to 2.1

  • I did not embed it

  • dimi3dimi3 New
    edited July 2014

    Seems weird that it says 2.0.18.8 after a successful update... could it be because the previous install of vanilla was produced by the godaddy console?

    <?php if (!defined('APPLICATION')) exit();
    
    // Conversations
    $Configuration['Conversations']['Version'] = '2.0.18.8';
    
    // Database
    $Configuration['Database']['Name'] = XXXXXXX;
    $Configuration['Database']['Host'] = XXXXXXX;
    $Configuration['Database']['User'] = XXXXXXX;
    $Configuration['Database']['Password'] ='';
    
    // EnabledApplications
    $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
    
    // EnabledPlugins
    $Configuration['EnabledPlugins']['GettingStarted'] = 'GettingStarted';
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    
    // Garden
    $Configuration['Garden']['Title'] = 'forum';
    $Configuration['Garden']['Cookie']['Salt'] = XXXXXX;
    $Configuration['Garden']['Cookie']['Domain'] = '';
    $Configuration['Garden']['Registration']['ConfirmEmail'] = FALSE;
    $Configuration['Garden']['Registration']['Method'] = 'Approval';
    $Configuration['Garden']['Registration']['CaptchaPrivateKey'] = '';
    $Configuration['Garden']['Registration']['CaptchaPublicKey'] = '';
    $Configuration['Garden']['Registration']['InviteExpiration'] = '-1+week';
    $Configuration['Garden']['Registration']['InviteRoles'] = FALSE;
    $Configuration['Garden']['Email']['SupportName'] = 'forum';
    $Configuration['Garden']['Version'] = '2.1';
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['CanProcessImages'] = TRUE;
    $Configuration['Garden']['Installed'] = TRUE;
    $Configuration['Garden']['InstallationID'] = XXXXXXX;
    $Configuration['Garden']['InstallationSecret'] = XXXXXX;
    $Configuration['Garden']['InputFormatter'] = 'Html';
    
    // Plugins
    $Configuration['Plugins']['GettingStarted']['Dashboard'] = '1';
    $Configuration['Plugins']['GettingStarted']['Registration'] = '1';
    $Configuration['Plugins']['GettingStarted']['Discussion'] = '1';
    $Configuration['Plugins']['GettingStarted']['Categories'] = '1';
    
    // Routes
    $Configuration['Routes']['DefaultController'] = 'discussions';
    
    // Vanilla
    $Configuration['Vanilla']['Version'] = '2.0.18.8';
    

    //

  • peregrineperegrine MVP
    edited July 2014

    Seems weird that it says 2.0.18.8 after a successful update..

    the config.php will not reflect the correct version of your installation if you update it.

    version is as I said found either of two ways.
    http://vanillaforums.org/discussion/26943/tutorial-how-to-determine-the-version-number-of-vanilla-that-you-are-using-for-your-own-forum

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • peregrineperegrine MVP
    edited July 2014

    non-rewritten urls work.

    a non-rewritten url click here it works: discussion3onyourforum

    youforumdomain.xxx/forums/index.php?p=/discussion/3/sdfsdfsdfsd

    you need to fix your .htaccess (to make rewrites work ) meanwhile you can change

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    to
    $Configuration['Garden']['RewriteUrls'] = FALSE;

    you have 2.1 loaded - so you may want to change the references in your config.php for 2.0.18.8
    to 2.1 just for your sanity. - it won;t affect much else :)

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • let us know if that worked, if not

    post your .htaccess file

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • gave it a try and and those flips worked and there was no need so far to update the .htaccess file

  • Thanks @Peregrine! I will update the real server after we test some plugins and the forum is quiet.

    peregrine
  • peregrineperegrine MVP
    edited July 2014

    and there was no need so far to update the .htaccess file

    http://vanillaforums.org/discussion/comment/208595/#Comment_208595

    or else you are not allowed to re-write because a rewrite module may be missing in php.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • Oh OK thanks!

Sign In or Register to comment.