Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Can't enable Twitter Social Connect

Hi,

well, the title says it all. When I go to the 'Social' page in the admin dashboard to enable twitter, I get an inform message that says 'There was an error performing your request. Please try again.' and it does this everytime. I don't know how to get more information about the issue. No apparent problem with Facebook.

Any idea?
Cheers.

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Do you have cUrl enabled and working on your server?

    Any data returned with your enable request? (Check your network tools for more information)

    What plugins do you have enabled?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • ha... I'm afraid I don't know the answers to your first 2 questions... :/ how can I check this? I'm using cPanel, if that helps...

    As for the plugins, here's the list:

    • Discussion Refresh
    • FileUpload
    • Flagging
    • Ignore
    • MediumEditor
    • One Tag (custom plugin by peregrine)
    • Profile Extender
    • Quotes
    • Split / Merge
    • Tagging (modded)
    • Thankful People 2
    • Van2Shout
    • Vanilla Statistics
    • Vanillicon
  • peregrineperegrine MVP
    edited September 2014

    check you phpinfo or user version checker plugin (it has a dashboard phpinfo.)

    http://vanillaforums.org/addon/versioncheck-plugin

    it will say if curl is enabled in the info and might also show you where curl.ini is located as well.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    Accent
  • There was an error performing your request. Please try again

    may be an error coming from global.js

    you could probably debug with statements in SocialController.php and connection_functions.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    Accent
  • Ok I do have cUrl enabled and working.
    I've enabled twitter connectivty in the past and it worked fine...

  • peregrineperegrine MVP
    edited September 2014

    Are you talking about the enable button to the right of twitter row in the dashboard. or do you mean configuring twitter.

    two different things.

    post a screenshot of what you are talking about.

    MEANS ENABLE

    social/enable/Twitter

    does your config.php have this

    $Configuration['EnabledPlugins']['Twitter'] = TRUE;

    if not try adding it.

    are you at this url /dashboard/social/twitter or this url social/manage

    they are two different animals and you need to be explicit.

    this is the twitter settings screen - are you having problems here:

    /dashboard/social/twitter

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Here's what's happening:

    It's in /social/manage. I can't access /social/twitter.

    In config.php I do not have $Configuration['EnabledPlugins']['Twitter'] = TRUE;, however I do have $Configuration['Plugins']['Twitter']['ConsumerKey'], ['Secret'], ['SocialReactions']and ['SocialSharing'] from when I first enabled the plugin.

    When I add $Configuration['EnabledPlugins']['Twitter'] = TRUE; to config.php, then the whole website breaks — nothing is displayed, the source is entirely empty. Same for the dashboard. Nothing at all is displayed.

    peregrine
  • peregrineperegrine MVP
    edited September 2014

    NICE graphic perfecto.

    perhaps the twitter plugin is malformed or incompletely copied.

    I'd consider recopying the the twitter plugin from the vanilla 2.1.1 zip.

    and also consider disabling all other plugins and changing to default theme.

    if that doesn't help ....

    add both of these:

    $Configuration['Debug'] = TRUE;

    $Configuration['EnabledPlugins']['Twitter'] = TRUE;

    and if need be change index.php line 21

    https://github.com/vanilla/vanilla/blob/2.1/index.php#L21

    ini_set('display_errors', 1);

    so you get some real error output.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited September 2014

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • hgtonighthgtonight ∞ · New Moderator

    Assuming you are running Firefox:

    Hit Ctrl + Shift + Q right before you click the button. You should see a single request happen. Copy the response and post it here.\

    Alternatively, enable debugging by adding $Configuration['Debug'] = TRUE; to your /conf/config.php file. Then right click on the enable button and open in a new window/tab.

    This should get you the "actual" error.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    Bleistivt
  • Copying the twitter folder from a new vanilla installation didn't work. @hgtonight‌, initially I was confused because I thought you meant network tools on my host provider, not the browser... (note: don't try firefox shortcuts in chrome, it could close all of your windows.) Anyway there is no response at all. I get a 500 Internal Server Error.

    When opening a new tab by right-clicking on the button with debug tools enabled, here's the message I get:

    Fatal error: Cannot redeclare class OAuthException in .../library/vendors/oauth/OAuth.php on line 8

    I'll investigate more...

  • hgtonighthgtonight ∞ · New Moderator

    What is the full message you get?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • BleistivtBleistivt MVP
    edited September 2014

    I get the same problem on my hoster.
    You probably have the php oAuth extension is installed, which already defines a class "OAuthException".

    I haven't found a better solution other than just commenting out the declaration of the exception in /library/vendors/oauth/OAuth.php, yet.

    That reminds me I wanted to file an issue for this for a long time...

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

    Accent
  • That's it, that's the full message. I just removed the path to my vanilla installation and replaced it with '...'.

  • Just comment out line 3 to 8 in that file or wrap it in

    if(!class_exists('OAuthException')){
        class OAuthException extends Exception {
        ...
    }
    

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

    Accentperegrine
  • @Bleistvist, yes that's it! thanks a ton! it all works properly now I think.

  • Are you filing the issue or do you want me to do it?

  • BleistivtBleistivt MVP
    edited September 2014

    Just a suggestion for twitter:

    I would configure my app on twitter to only have the most basic rights.
    It can be pretty intimidating to new users if your app requires access to write tweets and set new follows.

    When I configured it on twitter, it somehow defaulted to full access.

    edit: I am writing on my phone right now so if you could file it, that'd be cool

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

    Accent
  • Yeah, I am not enabling any sharing features, I just want the easier registration/sign in, so read-only should be fine.

    Filing the issue now. Thanks again :)

Sign In or Register to comment.