HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Posts out of order

Hi folks, I just upgraded to 2.2 from 2.0.18.8. I have a recurring problem with posts appearing out of order. I will see at the end of a thread that there is a new unread post, but when I click on the thread, the new post doesn't appear at the end of the thread, it appears somewhere on the first page (this only seems to affect threads with multiple pages.)

I cleared the *.ini files out of the cache a couple of times, and that seemed to resolve it, but then the problem came back. I also have a user reporting that some threads with new posts are appearing to be read. It can't be a case of accidentally hitting "mark all as read" because it isn't consistent across threads.

There appears to be some timestamp confusion with the posts that show up out of order. Sometimes they have what looks like a correct timestamp, but sometimes they have a timestamp that looks to be several hours off.

Any suggestions or pointers for what could be causing this? This has only been occurring since the upgrade. I have a backup 2.0.18.8 folder pointed at the same database, and the posts appear out of order there too.

Comments

  • We've now isolated that it happens to certain people when posting from the mobile site.

  • hgtonighthgtonight ∞ · New Moderator

    What kind of plugins are you running?

    Some plugins don't run when on mobile, so that might be the cause.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Button Bar
    Comment Body Insert
    Discussion Polls
    Emotify
    Image Upload
    Private Community
    Uploader
    Vanilla Statistics

  • FYI, we had a mirror URL pointed at the same database with 2.0.18.8 installed, it was from last time we upgraded, I did a test first. Some users were still using that URL, that caused posts to be out of order. I deleted that folder.

    Now, we are only seeing an issue with new posts sometimes not showing up as "new". I disabled the "Mark All as Read" plugin.

  • hgtonighthgtonight ∞ · New Moderator

    I would try running the /dba/counts endpoint. Visit http://forum.example.com/dba/counts

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    CateS
  • This seems to have worked! Thanks!

    hgtonight
Sign In or Register to comment.