Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Error 500 on upgrade from 2.1.13p1 to 2.3.1

After copying the new files over the old ones, it completely breaks with Internal server error. This happens with /utility/update as well as the main forum URL.

I can't find a php error log file, only an older one from before the upgrade. Where would the log be?

Things I've done:

  • Checked that it has PHP 5.4
  • Deleted the /cache contents
  • Checked there's no /themes/mobile/views/discussions/helper_functions.php
  • Deleted /applications/dashboard/views/default.master.php

The upgrade instructions say to update .htaccess but which one and make what changes?


  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    You need php 5.6 or higher.

    The error logs from your server , ask your host where it is. There should be a link to them where you host your files.

    Make sure you did not delete the Smarty folder from the cache only the .ini files

    Your htaccess file for vanilla should look like this

    # Modified
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
  • Options

    Thanks vrijvlinder.

    I did delete Smarty. Should I reinstate a few days old backup or is it better to leave the new one that 2.3.1 put there?

  • Options

    Just a note for anyone else, here's how I solved it:

    File permissions were wrong, as shown by this error in the log:

    SoftException in Application.cpp:256: File " [...] /public_html/forum/index.php" is writeable by group

    Previous Vanilla versions up to 2.2 were apparently archived on Windows (FAT) and that seems to cause cPanel File Manager to extract them with correct file permissions (644), so my update process of extracting the new files over the old ones worked OK. But 2.3 and 2.3.1 were apparently archived on Linux and that causes them to be extracted with permission 666 for files which doesn't work.

    I fixed it by extracting and re-zipping on Windows. Then when I uploaded and extracted it on my web host, the files appeared with the correct permissions.

  • Options
    LincLinc Detroit Admin

    For the record, we've always produced the zip files on a Mac. For 2.2, we did remove the "execute" permission from all files. That's the only change I'm aware of.

  • Options

    Rechecking the 2.2.1 file, it turns out it was modified recently so I must have extracted and recompressed it which accidentally kept things working up till now. I see the fresh one from the website is marked "Unix" instead of "FAT".

Sign In or Register to comment.