Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Vanilla Theme Apply Problem PLease Help

This discussion is related to the Bootstrap addon.

Yeterday I Download and setup Vanilla 2.5 on my Ipage server. then i try to add a new theme. I download and Upload Bootstrap 2.5.1 to theme folder and try to apply it. when i click apply it get this error.

"The addon could not be enabled because it generated a fatal error:"
"Plugin not found."

here is the theame Link

https://open.vanillaforums.com/addon/bootstrap-theme

Comments

  • The bootstrap folder should be "/themes/Bootstrap", with a capital B.

    If it isn't, rename it and delete cached theme files from /cache/

    R_J
  • I get this when I try and use any other theme

  • I had this same problem. I was able to solve it by downloading the theme from the Github page instead: https://github.com/kasperisager/vanilla-bootstrap/archive/v2.5.1.zip

    R_J
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    So is the problem only with bootstrap or with any theme? This post is about not being able to enable any theme not just bootstrap. A moderator should make that clear. If you can’t get a theme to work it does not matter where you got it from.

  • Does anyone have the solution to this? @justin_ that didn't work for me.

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    Both the version of the theme listed on this forum and the version from Github work in my local setup.

    What version of Vanilla and what version of PHP are you running?

    @stackmouse is correct in that the theme must be placed as <YOUR_VANILLA_INSTALL_LOCATION>/themes/Bootstrap with a capital B. The file unzipped directly from the download has a lowercase b at the beginning. This may not be an issue on some systems (with case-insensitive filesystems) but is an issue on many systems. It is also gives warning from Vanilla's AddonManager.

  • lorddfglorddfg
    edited May 1

    @charrondev said:
    Both the version of the theme listed on this forum and the version from Github work in my local setup.

    What version of Vanilla and what version of PHP are you running?

    @stackmouse is correct in that the theme must be placed as <YOUR_VANILLA_INSTALL_LOCATION>/themes/Bootstrap with a capital B. The file unzipped directly from the download has a lowercase b at the beginning. This may not be an issue on some systems (with case-insensitive filesystems) but is an issue on many systems. It is also gives warning from Vanilla's AddonManager.

    Doesn't work :(

    2.5.1

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Sorry, @lorddfg but 'Doesn't work' is no use either as feedback or as a request for help.

    What have you tried, and what doesn't work?

  • @whu606 said:
    Sorry, @lorddfg but 'Doesn't work' is no use either as feedback or as a request for help.

    What have you tried, and what doesn't work?

    Sorry, I should have clarified it.

    I downloaded the file and uploaded it. Changed the name from Vanilla-Bootstrap to Bootstrap.

    When I enable it, it gives me the plugin not found error.

    I tried changing the name and the error stayed the same.

    So no dice. I am using the latest Vanila version. I should have been more concise my apologies.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @lorddfg

    No problem.

    I just downloaded the github version, changed the folder, and it works in my local test install (XAMPP), so it must be something to do with your set up.

    What version of php are you running?

  • @whu606 said:
    @lorddfg

    No problem.

    I just downloaded the github version, changed the folder, and it works in my local test install (XAMPP), so it must be something to do with your set up.

    What version of php are you running?

    PHP 7.0, with mariaDB. It's a dedicated server, I just did a clean install, I am already dealing with another issue which I can't make sense off, so it could be related to it.

    https://open.vanillaforums.com/discussion/comment/252549#Comment_252549

    I think it might be related to it.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    I see on another thread you said you didn't want to turn off strict mode, but I would suggest you do so, if just to test if that is what is causing the issue(s).

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    You may try deleting the related files in the cache folder first: /cache/theme/*

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    @lorddfg Did disabling rocket loader on Cloudflare solve this issue as well? The way cloudflare completely rewrites the scripts breaks our older JS which requires being loaded in a particular order.

  • I'm running PHP 7, on apache and linux. Other themes work for me but this one doesn't wanna do it. I keep getting the same error as everyone else "The addon could not be enabled because it generated a fatal error:
    Plugin not found."

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited June 3

    ADanimator

    Your error isn't what 'everyone else' is getting.

    As I said earlier, I downloaded the Github version, changed the folder name as advised, and it worked, so the error isn't simply with the theme.

    Did you delete the cache files?

    Can you try it via an incognito page to rule out cache issues?

  • findanishfindanish New
    edited July 7

    The error says it all. No plugin found. I got it working by uploading the files to both Themes and Plugins folder. Make sure you rename the folder to Bootstrap. I run PHP 7.2, Vanilla 2.5.2 without any issues with this theme.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Great you've solved it, but you wouldn't need it in the /plugins´ folder, only in the /themes` folder

  • @R_J said:
    Great you've solved it, but you wouldn't need it in the /plugins´ folder, only in the /themes` folder

    Wierd because it only worked when i uploaded all files into the plugins folder. I tested it by removing it as well.

Sign In or Register to comment.