Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Strange behaviour with PHP 7.2 and Vanilla 2.6.4 for various plugins

This discussion is related to the Vanilla addon.
edited December 2018 in Vanilla 2.0 - 2.8

I have PHP 7.2.11 installed on my machine and am running Vanilla 2.6.4.

I had a problem with displaying the dashboard (garbage link below showing on the screen) and narrowed that down to it not liking the Vanilla Statistics plugin so disabled that.

I seem to have a similar issue now with Flagging. When I go to the moderation page I get this garbage displayed at the top with flagging.php showing up within that garbage.

**�%�Zflagging.php�VmO�8�ί��@N���Bi���b9(wZ�ɴ��ؑ�,�V���n����HU{<���33��Eb�΄�,ag77W㋳���5k��K�'0�4� �P��%�n!lw�q�6N"���S'�=�txl9�*a%�����9����d+�|�&�u�*ٻ��hc���h�����!��[{ښ�#s�ˢ��߀m�.��?� ����,�i���:�ndIN��ڛ�Zf|�V!���į5���u�I�����Q���ť~Vɻ:����D�CH�n?6���J�R|2�������x����\�48A��6-�%�Y��ua�\��z�� **

I went into plugins to disable the flagging plugin which appeared to work but now when I click on the moderation link the URL points at https://myURL/plugin/flagging and I can't get that screen to appear at all which I assume is because it doesn't like the fact I've switched flagging off.

Any ideas why that PHP routine would appear corrupt at all? I've had a good search around and can't find similar behaviour like it anywhere else so am puzzled at the moment

Comments

  • RiverRiver MVP
    edited December 2018

    @PaulButler said:
    I have PHP 7.2.11 installed on my machine and am running Vanilla 2.6.4.

    I had a problem with displaying the dashboard (garbage link below showing on the screen) and narrowed that down to it not liking the Vanilla Statistics plugin so disabled that.

    I seem to have a similar issue now with Flagging. When I go to the moderation page I get this garbage displayed at the top with flagging.php showing up within that garbage.

    **�%�Zflagging.php�VmO�8�ί��@N���Bi���b9(wZ�ɴ��ؑ�,�V���n����HU{<���33��Eb�΄�,ag77W㋳���5k��K�'0�4� �P��%�n!lw�q�6N"���S'�=�txl9�*a%�����9����d+�|�&�u�*ٻ��hc���h�����!��[{ښ�#s�ˢ��߀m�.��?� ����,�i���:�ndIN��ڛ�Zf|�V!���į5���u�I�����Q���ť~Vɻ:����D�CH�n?6���J�R|2�������x����\�48A��6-�%�Y��ua�\��z�� **

    I went into plugins to disable the flagging plugin which appeared to work but now when I click on the moderation link the URL points at https://myURL/plugin/flagging and I can't get that screen to appear at all which I assume is because it doesn't like the fact I've switched flagging off.

    Any ideas why that PHP routine would appear corrupt at all? I've had a good search around and can't find similar behaviour like it anywhere else so am puzzled at the moment

    perhaps multibyte configuration with php is not set correctly.

    http://php.net/manual/en/mbstring.installation.php

    https://www.interserver.net/tips/kb/what-is-mbstring-and-how-to-enable/

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

Sign In or Register to comment.