HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Memcached and Vanilla 2.8 - causing 504 time out

whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

On Ubuntu 18.04, with nginx and php7.2-fpm

I have installed memcached, checked it is running on the server, and info.php reports that the ini file is parsed, and that memcached is enabled.

Site works fine until I enable memcached in conf .php, at which point it hangs for a while, and eventually returns a 504 error.

If I remove the settings from conf.php, or stop memcached on the server, things go back to normal.

$Configuration['Cache']['Enabled']=true;
$Configuration['Cache']['Method']='memcached';
$Configuration['memcached']['Store']='localhost';

Has anyone come across this? Is there anything I have missed doing?

Thanks

Tagged:

Comments

  • LincLinc Former Staff Detroit Admin
    edited March 2019

    My config says:

    $Configuration['Cache']['Enabled'] = true;
    $Configuration['Cache']['Method'] = 'memcached';
    $Configuration['Cache']['Memcached']['Store'] = array (
      0 => 'localhost:11211',
    );
    

    Perhaps it's not using the correct port. I haven't looked to see why I have it in an array.

    whu606
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    Thanks, @Linc

    Using your config settings and changing 11211 to 127.0.0.1 seems to have fixed the issue.

Sign In or Register to comment.