HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Rich Editor does not work on fresh Vanilla 2.8 install

2»

Comments

  • Thanks @R_J I tried inserting the content of htaccess.dist into the existing .htaccess file - didn't work. I also tried deleting the existing .htaccess file and renaming the htaccess.dist to .htaccess That didn't work either (I cleared my browser history after each change). I will try charrondev's suggestions re Apache set up.

  • I have been unable to get the Advanced Editor to work at all in 2.8. The Rich Editor works for text but I get a 403 error when trying to attach a file or photo.

    Does this suggest server configuration issues as others have mentioned in this thread?

    My site is on Serverpilot in which " Nginx as a reverse proxy in front of Apache" - I was running 2.6 just fine. I'm using the .htaccess file unmodifed but have not changed any nginx config.

    Any hints would be appreciated. Thanks.

  • This is what worked for me with Apache configuration. I added the following to the .htaccess file (replacing what was there):

    1. <IfModule mod_rewrite.c>
    2. RewriteEngine On
    3. # Certain hosts may require the following line.
    4. # If vanilla is in a subfolder then you need to specify it after the /.
    5. # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    6. RewriteBase /forum
    7. RewriteCond %{REQUEST_FILENAME} !-d
    8. RewriteCond %{REQUEST_FILENAME} !-f
    9. RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    10. </IfModule>

    Then I added $Configuration['Garden']['RewriteUrls'] = true; to my /conf/config.php 

  • Thank you for your feedback @tcwebber but it turns out that in my forum's case it was database corruption. Yet another reminder for me to stay away from phpmyadmin and stick with ssh

  • charrondevcharrondev Developer Lead (PHP, JS) Montreal Vanilla Staff

    @plymplan If you're on a Mac, SequelPro is pretty much unrivaled for this type of thing. I use it for connecting to everything.


  • kejonnkejonn New
    edited March 2019

    Scratch my prior post (which is not showing up because it says it needed to be approved but this one is showing up?)! @tcwebber's post was indeed the key, I did not realize I needed to replace everything in .htaccess with that, though it was indeed presented that way. I searched "mod_rewrite" and found a post at https://open.vanillaforums.com/discussion/comment/255735#Comment_255735 by@R_J that confirmed it. Now everything appears to work properly.

  • I'm having similar issues, shared hosting running Apache. Have tried all of the above suggestions but no luck. When I do not include the line $Configuration['Garden']['RewriteUrls'] = true; in config.php, I cannot use the Rich Editor. When I do include it, my site alway directs back to the main page even if it indicates it has gone to another page in the address bar. When I click on "New Disussion" it always just goes to the same main page (http://www.mysite.org/forum/post/discussion and I cannot input anything at all.

    I first tried the site on a sub domain because that is where I wanted it (forum.mysite.org). I then tried a subfolder under the root www but it did the exact thing. Mod_rewrite is enable according to the host documentation.

    When I tried the modifications shared by tcwebber, it was worse in that I got "Page Not Found".

    Any more ideas?

  • R_JR_J Ex-Fanboy Munich Admin
  • Hi, for me the issue got resolved when i switched to php version 7.3 from 7.2.19

    Apache Version 2.4.39

    PHP Version 7.3 

    MySQL Version 5.7.27

    Vanilla forum version 3.1

Sign In or Register to comment.