How do I insert an image into a Discussion

Newbie using v3.3.

I would like to be able to insert a picture into my Discussions. I have given some time to searching this Community Forum but found that everyone is chatting to each other in a restricted code, and I have no idea what they are talking about. So please treat me as the imbecile I am.

I can insert an image in this Discussion because I have these symbols at the bottom of the text box.

However, when composing a Discussion in my own forum I am offered only the first and third of these above symbols. How do I acquire the missing two, please?

«1

Comments

  • Is your upload folder writable?

  • On your server


  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited March 27

    @Hopeless


    I have given some time to searching this Community Forum but found that everyone is chatting to each other in a restricted code, and I have no idea what they are talking about.


    Neither true nor fair.


    For those choosing to self-host Vanilla, there is a reasonable expectation of basic competency in managing a web server. People on here are happy to help, but you are going to have to make an effort as well.

  • My uploads folder permissions look like this? Do I need to modify them?

    Thanks for your help.

  • Yes, tick the write box's

  • Ok. I have done the same with the conf and cache folders too. (Hope that's right)

    I have Rich Editor enabled. I supposed that the two missing symbols were Rich editor related, but they are still absent from my forum Discussions.

  • Do image uploads work when you enable the wysiwyg editor?

  • I appear to have both Rich Editor and Advanced Editor installed. Both claim to be WYSIWYG. the option to upload an image is not offered in the text box when either of them is enabled. Or when neither of them is enabled.

    Thanks for sticking with me on this. I'd really like to be able to offer users the option of uploading images.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Never enable two editors at once. Is your forum public so that you can give a link?


  • The forum has been by invitation, but I have justaltered the Method of registration to basic for you to help, R_J

  • R_J. I have sent you the address of my forum as a message.

  • There is both an .htaccess.dist and an .htaccess file already in my forum root.

  • Go to your /conf/config.php file and look to see if this code is present, if not add it and save,

    $Configuration['Garden']['RewriteUrls'] = true;

  • The code was absent, but when I added it to the list of $Configuration['Garden'] entries and saved it access to the forum was lost. So I removed it and access was restored.

    But thanks for your help.

  • You need that line for pretty URL's to work.

    If you get an error with it in, put this line in at the bottom of conf/config.php to see what the error is

    $Configuration['Debug'] = TRUE;
    


    rbrahmson
  • I have inserted both lines of code as suggested.

    Now I can access my admin dashboard, but not the forum itself. I am sent instead to a page telling me that this domain is already Registered.

  • ianw5555ianw5555 New
    edited March 28

    My suspicion is that your host has not enabled mod_rewrite on your server.

    look in your error_log file (in the root) to see what's in there.

  • ianw5555ianw5555 New
    edited March 28

    Also check that the rewrite rules are inside your .htaccess file


Sign In or Register to comment.