HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

how to restore

I screw up something with my vanilla installation and now it shows me this, see below

It happens for guest users who are not registered yet.

Not sure what I did. Maybe I even changes some files by mistake.

How can I restore it?

Thank you!


  • Options

    You can only restore it if you have a working backup.

    If it's a new installation I would try installing again.

  • Options

    can you post a copy of your themes/{themename}/view/default.master.tpl something in there is not right!

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    I suggest to download the files again from here and simply copy them all to your server. That's completely safe (if you haven't changed any of the core files which you normally should never do)

  • Options

    Thanks R_J! This is a good idea. What files do I need to store before I perform this operation? At least I know /conf/config.php as it has my DB connection setting.

    Is there anything else?

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    The package you download does not include a config.php

    As always I would recommend to make a backup before you do anything at all (backups are never wrong). But since "download zip and upload files" would also be a normal update procedure, there is nothing which can be destroyed that way

  • Options

    I overridden all files with the fresh copy of vanilla on my server and cleaned the cache. But to my surprise, I still see the same problem. I used a browser in a private mode, so it is not cached.

    It looks like I screw up something with users permissions or the DB, maybe sessions? I was trying to create a session programmatically before this.

    Is there any session table that I need to cleanup? or any permissions that I need to check for the guest user?

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Look at the guest role and unchecked permissions for discussions add and maybe also for comments add

  • Options

    The guest role doesn't have add comments/discussion permissions. I tried to uncheck everything but it didn't help either.

    Is there any DB table where it cached by chance?

  • Options

    Well, I did one more experiment. I unchecked those permissions for the "member" role and it solved this issue. So it looks like for some reasons, a guest user is not rendered as a "member".

    Any ideas what to do to restore default behavior?

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Create a fresh install somewhere (e. g. on your local machine) and take the table GDN_Permission from there.

    Another approach which is somewhat risky, but would be faster if it works would be the following:

    1. log in as admin!
    2. back up the tables GDN_Role and GDN_Permission
    3. drop both tables!
    4. run /utility/structure
    5. if it fails restore the GDN_Role and try /utility/structure again

    If it still fails: restore also GDN_Permission and go the long way.

    If it works: dance.

  • Options

    It finally works! Thank you RJ!

    I did a similar trick. I restored everything from the backup which was taken before that change and overrode the data (discussions/comment/users)

Sign In or Register to comment.