HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 2021.003 RC2 is now available

24

Comments

  • which server service? Nginx? Apache?

    If it's Nginx, you can see my reply, that's correct conf.

    meetdilipmarip230p
  • maybe recheck you .htaccess file

    meetdilipmsyafa
  • Thanks. Can you please show me what it should be ? I am not sure what to expect.

  • Could you show your .htaccess file content?

    And you can check https://htaccess.madewithlove.be

    meetdilip
  • If your forum is in a folder, uncomment this line in your .htaccess file.

    #RewriteBase /

    so it is

    RewriteBase /forum

    meetdilip
  • Thanks @ianw5555

    I am trying to install using XAMPP and folder is htdocs/vanilla

    @daocaoit

    I think the installer while I unzipped to htdocs/vanilla didn't have a .htaccess file. I created on in root (vanilla) folder and one in "conf " folder. Yes, I know I messed it up, but I was expecting to unzip - next -next while trying the installer. I haven't dealt with base-level hosting in a while as well.

    Please guide me.

    htaccess file in conf is 1 and one in root (vanilla) folder is 2, attached. Thanks.


  • K17K17 Français / French Paris, France ✭✭✭
    edited February 2021

    @meetdilip you don't need to mess around with htacces, as Vanilla provides a .htaccess.dist in it's package that will be renamed .htaccess during installation. And you will not need to do the "RewriteBase" trick on Xampp.

    But the error you're getting first can be debugged by adding (but don't forget to remove it later):

    $Configuration['Debug'] = true; 
    

    in the conf/config-default.php file (because config.php does not already exists).

    But don't worry, I did it for you, and it's the same error everyone get: tere is a folder missing in that package: the addons folder.

    If you downloaded the Vanilla 4.0 RC1, copy paste that addons folder into your /vanilla folder and empty your forum's cache.

    You may get another error who will mess up the forum layout, I "solved it" by not using Rich Editor and disabling it in the dashboard.

    daocaoitmeetdilip
  • yes, this right to cover your htaccess with the default htaccess and change the base dir.

    I have installed and no need to debug.

    meetdilip
  • meetdilipmeetdilip
    edited February 2021

    Hi @K17

    I added the " addons " folder you suggested. It is working great now. Thanks for the help.

    @daocaoit Thanks :)


    Is it possible to add a user through the admin control panel / Dashboard. ie, Can an admin create a user by himself ?

    update : found how to do it

  • Is it possible to add a user through the admin control panel / Dashboard. ie, Can an admin create a user by himself ?

    Go to moderation tab, click on users to the left, then you will see add user top right.

    meetdilip
  • Thanks. I wonder whether there is any method to get notifications for Reactions or Like or some kind of upvote.

  • Thank you for the releases. Looking forward to the final, stable release.

    I'm curious if the theme editor will also be included in the open source version of Vanilla? Was thinking whether I should start styling our theme for 4.0, but if the theme editor is included I might wait since it looks like some things like colour and font can be done through it instead.

    vaishalij
  • You can add tape view to the new version, as in social networks

  • Why does the Guest user see the content under the spoiler? How to ban this?

  • R_JR_J Ex-Fanboy Munich Admin

    Why do guests can see the spoiler?

    Because a spoiler should only hide content from first sight. It's not kind of pay wall. You use spoilers for other things...


    Why aren’t koalas actual bears?

    They don’t meet the koalafications.

  • Because a spoiler should only hide content from first sight. It's not kind of pay wall. You use spoilers for other things...

    Close the content with a spoiler, selectively and redirect the Guest to check in to view the content under the spoiler. Everything is free, just for the report. It wouldn't be bad 😉

  • I've just noticed that users of my site cannot upload images to embed (they do not see the icon/option in rich editor) but I can as admin.

    I checked the user permissions and that user class definitely has ability to upload.... any ideas? I'm using this latest release.

  • TyrossTyross New
    edited March 2021

    Try It "Advanced Editor" everything works, even in a mobile topic. There is no underline button and no stickers are placed.

    Change the formatting of all publications on "Wysiwyg"

    =================================================================

    Only disable "rich editor" They're in conflict.

Sign In or Register to comment.