Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Vanilla 1.1.5a Released

13

Comments

  • Is there a quick way to do the update from 1.4? I remember it took me a few seconds to do it last time and I've since forgotten how to do it. The instructions only say what files to replace.
  • edited November 2008
    if you do that over ssh, I think you just need to copy the 1.1.5 files over you installation (make a copy first).

    With ftp, you can do the same except for conf/, themes/ and extensions/. Don't copy conf/ or extensions/, and for themes/ and themes/vanilla/style/default/ only copy the files not the folders. However, ftp can corrupt your files, and it might be better to only copy the changed files.

    You can use the following packages to only install the changed files:
    http://vanilla-friends.googlecode.com/files/vanilla-upgrade-1.1.4-to-1.1.5.zip
    http://vanilla-friends.googlecode.com/files/vanilla-upgrade-1.1.5-to-1.1.5a.zip
  • When I set up version 1.1.4 the forum would send me an email each time a new person applied for membership.

    Since the upgrade to 1.1.5a, I am not getting the new member emails.

    What have I done wrong and how can I fix it.

    Many thanks
  • Enable in your Administrator settings?
  • @bigc: It is working for me.

    You should check the options to receive email on registration is turn on (account>forum preference), re-upload library/People/People.Class.UserManager.php and library/Framework/Framework.Class.Email.php and check your email settings. Vanilla can use sendmail or a SMTP server for sending email. SMTP is more reliable; try to use it if you don't already. You can enter your SMTP settings on the "settings>global settings" page.

    Are you using any extensions related to registration or one sending email like notify?
  • edited October 2008
    thanks for the help,

    I have checked the settings, and everything is OK, and I have uploaded the library's again.

    The email is not being sent using the sendmail.

    As for smtp, the server needs SSL

    I get the following message


    Warning: fsockopen(): php_hostconnect: connect failed in /vhost/vhost6/c/o/s/costellokids.com/forum/library/Framework/Framework.Class.Email.php on line 196

    Warning: fsockopen(): unable to connect to smtp.iomartmail.com:25 in /vhost/vhost6/c/o/s/costellokids.com/forum/library/Framework/Framework.Class.Email.php on line 196
    A fatal, non-recoverable error has occurred
    Technical information (for support personel):

    Error Message
    Could not connect to SMTP host smtp.iomartmail.com:25
    Affected Elements
    Email.SMTPSend();

    The error occurred on or near: 110: Connection timed out

    The crazy thing was in 1.1.4 everything worked using sendmail.

    After upgrading to 1.1.5a the email stopped working,

    So I deleted the database, trashed all of the forum, and started again with 1.1.4 and I still can not get the mail to work

    I should note that I have tested sendmail with PHPmyfaq and it works, and I have tested using my email CGI scrips and again sendmail is sending mail.

    Any ideas.?

    Many thanks

    colin
  • I should have said, that when I do thinks like requesting a password chage using the SMTP, the message is that an email has been sent. It just is not being sent out. I have checked all the obvious causes, such as spam etc, and used severl different email addresses as a test. Still no email gets delivered.

    thanks

    colin
  • Hi

    I have an answer on not sending email but have no idea how to fix the problem

    From my ISP

    "It will just require an additional argument to your mail() function. The argument is "-f" followed by the sender e-mail address."

    How can I do this, I have little coding experience

    many thanks
  • edited October 2008
    You can try to replace line 164 of library/Framework/Framework.Class.Email.php with that:
    if ([email protected]($To, $this->Subject, $Message, $Header, '-f' . $this->FromEmail) && $this->FatalError ) { $this->Context->ErrorManager->AddError($this->Context, $this->Name, "Send", "An error occurred while sending the email.", $php_errormsg); }
  • edited October 2008
    Just thought I should flag this to the attention of the 1.1.5a developers --- it appears the upgrade has broken the Private_Messages 1.1 add-on. Look here for some details

    I've also be noticing some other problems on my site which may or may not be related to the cookies vanilla 1.1.5 generate. Are there still links to 1.1.4 around so I can downgrade temporarily while these problems are being worked on / try to confirm my suspicions?
  • Since I down graded some users have been complaing about passwords not working --- did the upgrade change how the passwords are stored?
  • yep, the one that did sign/log-in with 1.1.5 have to request a new password.
  • I just tried to upgrade to 1.1.5a and am now getting this error when logging in:
    UserManager.SaveUserCredentials();

    The error occurred on or near: Data too long for column 'Password' at row 1

    Any suggestions?
  • try to reinstall appg/settings.php.
  • edited October 2008
    If it is not fixed after that:
    Try first to remove from conf/settings.php:$Configuration['DATABASE_VERSION'] = 2;
    Or to update the database structure yourself. Using PhpMysql you would:
    - select the database where vanilla is installed.
    - select the SQL tab and execute the following query:
    ALTER TABLE LUM_User CHANGE Password Password VARBINARY( 34 ) NULL DEFAULT NULL;
    - add $Configuration['DATABASE_VERSION'] = 2; to conf/settings.php
  • Thanks, Dinoboff! I tried replacing the appg/settings.php and that didn't work so I followed the instructions in your next post and now all is well.
  • edited October 2008
    The download button still says "Download Vanilla (386k)" even though the package is more like 514k these days.
  • Iwas about to point that out.
    Also, just a question... Why call it 1.1.5a instead of 1.1.5.1 or 1.1.6 or... I don't know. The 'a' at the end got me confused thinking it was an alpha release, and I waited 2 weeks until I decided to check in the forum. There, I confirmed it wasn't, so I'm downloading it.

    Maybe others felt the same...
    Ignacio
  • Because they have always been ultra-conservative with version numbers and the difference between 1.1.5 and 1.1.5a was so slight. Be thankful this isn't VLC, they are worse! They were stuck on version 0.8.6 for ages, they released 0.8.6a, 0.8.6b, all the way through the alphabet up to 0.8.6i :p But the thing was that there were huge differences between each of those versions and some argued they should have already been at RC1 stage :)
    Anyway, I ramble...
  • oops, I didn't through to that when I tagged it.

    ps: we won't release alpha or beta version for minor revision (any 1.1.x); we will probably for 1.2.
  • I'm a developer myself, that's why I instantly assumed it was an alpha release. Everyone is releasing alphas and betas today, they're to blame probably.

    I know that being a minor fix, maybe it didn't deserve a 1.1.6, but just to let you know that it may confuse some people. I think you should clarify a bit more. Maybe some words like "stable". Like, "Latest _stable_ release" or something.

    Anyways, I'm looking forward to upgrade. Thanks
  • I cant get this installed. Get an error of Access denied for user @'breaklimitgames.com' . No idea where this breaklimitgames is coming from. Definitely not my domain. Any ideas?
  • edited November 2008
    breaklimitgames.com is the domain name of your server and your MySql server doesn't allow to connect from breaklimitgames.com.

    When filing the database form settings, for the database field, did you try "localhost"?
  • I upgraded today from version 1.1.4 to 1.1.5a by following the instructions at - http://lussumo.com/docs/doku.php?id=vanilla:upgrading

    After dowloading version 1.1.5a, I first replaced the files listed in upgrading from 1.1.4 to 1.1.5 and then I replaced the files listed in upgrading from 1.1.5 to 1.1.5a

    Everything appears to have gone smoothly. However, in the upgrade from 1.1.4 to 1.1.5, the file appg/md5.csv is listed. This file doesn't appear in the 1.1.5a installation, nor did it appear in the original 1.1.4 installation. Do I need this file, and if so, where can I obtain it?
  • Hi,

    I am trying to do a fresh install and get these fatal errors:

    PHP Fatal error: Class 'MessageCollector' not found in /forum/setup/installer.php on line 77

    PHP Fatal error: Class 'Context' not found in /forum/appg/settings.php on line 258

    Any thoughts please?

    ty
  • You should download vanilla again and reinstall it. If you are transferring the files with ftp to your server, make sure it doesn't miss any file and doesn't corrupt any of them.
  • I'm confused.

    I had 1.1.4 installed.

    I downloaded 1.1.5a and unzipped the file.

    I next looked at the list of all the 1.1.5 files you're supposed to change.

    So, I went through my current 1.1.4 file list and wrote over all the files in that version using the upgraded files from 1.1.5a

    The forum is working, but it is really slow and my header image isn't right (it's text now instead of an image).

    Was I supposed to transfer files from my current 1.1.4 installation to the 1.1.5a or visa versa?

    It might be nice to have some automatic upgrading script or something. I'm pretty clueless when it comes to this stuff.

    Fortunately, I backed up most of my 1.1.4 installation prior to trying this upgrade. (I made it through about half the files before I started getting worried that I was doing it wrong.)

    So, if I have screwed it all up, what would you suggest is the best way for me to fix it?

    thanks
Sign In or Register to comment.