Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Inline Images

This discussion is related to the Inline Images addon.
124

Comments

  • I also have the problem that when I klick on a attachment it wan't to save the picture as a file instead of viewing it. When I enable inline image the link gets broke, but if I copy it and paste it into the url-box I get the "download file" window. Anyone know why?
  • i'm also getting this, but only recently. i have moved servers and also installed the multi-file upload extension. tried disabling that but no change. paths and permissions seem to be OK.
  • I know this is sorta an off-topic question, but how hard would it be to modify the code of this add-on to make an uploaded MP3 playable via something such as DPlayer? I mean, is that something that could be done with a modified version of this code, or would it be easier to just start over from scratch?

    See, I have the DPlayer add-on installed, and it works great, but my forum posters are having to upload a file, then view that file's direct link in the Files tab of the Dojo Files add-on, and then paste that link to get a Play button. I'm trying to make it to where my forum posters don't ever see that Files tab.
  • Surely JQMedia covers this functionality?

    /me goes away and tests uploading an MP3 file...
  • Is JQMedia working now?

    I had it before and it didn't like me at all so I uninstalled it.
  • Got some problems as well. I installed Attachement 2 and Inline Images correctly. Permissions for the upload folder is set. When I upload a image, I just see a missing image within my post. The Image is linked to http://www.cielab.org/vanilla/extensions/InlineImages/image.php?AttachmentID=3 which brings up weird code mess. Any suggestion how to get the inline image fixed? Cheers dex
  • There seem to be some kind of issue when useing other languagefiles then English. The addon is working when I'm running English but when I change to Swedish it no longer does. When I change to Swedish all I get is broken textlinks to the pictures. Has anyone experienced the same error and happen to have a solution or a suggestion to what's causing it?
  • Same problem.
    This Extension DOESN'T WORK WITH UTF encoding, even English in my vanilla.
    Couple of hours and i know it for shure.

    Does anyone know what to do with this issue?
    Or how to change default charset of vanilla to non utf?
  • It seems to work pretty well with tons of other english forums?
  • Works fine with my utf test forum...
  • When i resave definitions.php as utf (using Ultraedit32.exe) it does'nt works. (With English utf it's only for exemple, originally i want to use Russian utf) May be i do something wrong. Still looking for desision.
  • Have you checked the character encoding documentation on the wiki to make sure all your character encoding matches up with the database and front end etc?
  • it doesn't matches, DB is cp_1251 encoding. Now i am Trying to change to utf and check. Someone resave your english defifnition.php in utf encoding, refresh page with inline images and tell me that everiyhing all right. If you'll do so, also tell what your DB encoding.
  • Appologising for my stupidness. Resaved lang file with another editor called "Bred", now it works. Something bad with this resaving as utf. Now feel ecstatic feelings, Russian peaple will see inline images.
  • This extension still doesn't work when using Swedish language-file. Anyone know why?
  • Just swedish or any language file?
  • Don't know if its related to the language-pack, but I use the norwegian language pack and still haven't got any solution to the problem discussed here.
  • zowie I have exactly the same problem.
  • @HannesB
    Sorry mate... Seems like author has'nt been active here for a while. -april on that thread... But as the fisherman sais: There's hope in a hanging line! ;-)
    Have you isolated the problem to only appear together with your swedish language pack?
    @Minisweeper
    I've tested norwegian, english and "none" language with the same result of only showing text. I ca'nt see no difference with the JQThickBox enabled either?..
    Only with "Inline images" disabled I get a download-link in the attachement-window.
    Also added the $Configuration['DATABASE_CHARACTER_ENCODING'] = 'utf8'; -line to my /settings.php file. Even if I don't understand what i've done... ;-p

    With the "none" language enabled, the attachement box is so thin, the link is nearly not visible though.
    Could point towards a connection with this problem and language-pack addons?

    Anyway. *** HAPPY NEW YEAR!! ***
  • Hi, I'm using inline images without ThickBox. I've done a tiny modification so that you can click the resized image, and the full sized image will opened in a new window. Just under "//Init variables", you'll find the code for the $ImageBody string. I changed it to the following: $ImageBody = '<a target="_blank" href="'.$WebRoot.'extensions/InlineImages/image.jpg.php?AttachmentID='.$Attachment->AttachmentID.'">'; $ImageBody .= '<img border="0" src="'.$WebRoot.'extensions/InlineImages/image.php?AttachmentID='.$Attachment->AttachmentID.'" alt="'.$Attachment->Name.'" />'; $ImageBody .= '</a>';
Sign In or Register to comment.