Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.


This discussion is related to the FCKeditor addon.


  • Did u enable Visual editing
  • Thanks for flagging me on that. No I had not enabled that setting.

    Just to clarify skube's post above...

    1) Click the Account tab.
    2) Click "Forum Preferences" in the left sidebar.
    3) Spot the "Visual Editing Preference" toward the bottom of the page that appears and tick the checkbox.

    After doing that, FCKeditor starts to load in Firefox (Mac), but I then get the following error dialog:

    Error loading

    Clicking OK to that dialog then yields this dialog:

    Error loading

    Clicking OK to that then yields yet another dialog:

    Unknown toolbar item "Video"

    After that the toolbar loads and I can edit text to my heart's content with FCKeditor.


    I know that Safari was blocked by your extension in the past, but now that Safari 3 is out, would you might re-enabling it so we can test? I am reading that the nightly builds of FCKeditor are working in Safari for some people, so it would seem worthwhile to re-enable it once again, or maybe add an option so the user can enable or disable it? Thanks.
  • It sounds like you didn't copy the Video directory from the extension over into the FCKEditor you installed in the js/ directory
  • gpreston, you are correct in that I turned a blind eye to the following line in the FCKeditor extension readme:

    4) Copy the included Video folder to /js/FCKeditor/editor/plugins/ that will enable the embedding of youtube and google video

    After copying that into /js, the problem goes away. Ooops!

    Well, I still would appreciate knowing how to reneable Safari so we can test it in the new Beta. Thanks!
  • Since my Whisper to MySchizoBuddy (author of the FCKeditor extenion) has gone unanswered for the past 4 days, I've decided to post the content in the open forum.

    Can we please have a beta version with Safari functionality re-enabled? Please?

    As you all know, Safari 3 is out. Not just for the Mac, but for Windows too. MySchizoBuddy disabled Safari from showing the FCKeditor tools because past versions were incompatible. But from what I've seen, the latest editions of FCKeditor are compatible with Safari 3, hence the code in the FCKeditor extension that now blocks Safari should be disabled so we can test it with Safari 3.

    Thank you!
  • Could you take a look in the code and disable the bit that discriminates against Safari?

    I might take a look at it to see if I can hack it.

    Posted: Tuesday, 10 July 2007 at 10:55AM

  • Sorry I couldn't test this, there's too many hoops to jump through to install this gadget and I can't be bothered.
    Open default.php in a text editor and add the xxx in these three places, that should stop it balking in Safari...

    // only detect safari if ((stristr($navigator_user_agent, "xxxkonqueror")) || (stristr($navigator_user_agent, "xxxsafari"))) { $browser = 'xxxsafari'; $dom_browser = true; } return $browser; }

    Posted: Tuesday, 10 July 2007 at 11:21AM

  • Excellent post, Wanderer!

    It is quite unfortunate to see that MySchizoBuddy is no longer supporting his extension (as evidenced by his continued refusal to post), but perhaps another savvy member of our Vanilla community would be willing to adopt the code? This is really a terrific extension, and the only major flaw that I found previously was Safari 2 incompatibility.

    So I will try the hack and test with Safari 3 sometime tomorrow.

  • there's too many hoops to jump through to install this gadget
    I agree Wanderer. Would it be possible to get this extension updated so it included a copy of FCK and was all contained in the one extension directory?
  • JDW, I'm not sure MySchizoBuddy is refusing to support this extension, I think he is away or otherwise indisposed. He's always been very keen to fix problems in any of his extensions very quickly. Besides FCKeditor is not his extension, he simply adapted it to work with Vanilla.

    And [-Stash-], I think there may be licensing issues involved in distributing FCKeditor but I may be wrong, I've been wrong before but I can't remember when exactly!

    Posted: Wednesday, 11 July 2007 at 8:49AM

  • I hate licensing...

    Reading through the FCK license page, I don't see there would be any problem packaging it up as a single download. But *please* someone else who knows about these things double check for me :)

    Just in case I'm right, I've packaged FCK 2.4.3 up into a single package with the current extension (no Safari changes, sorry). I've uploaded it to my own webspace as I cannot email MSB (no email on his user page) - please feel free to yell at me to take it down MSB if you don't want it up there, it's very much only for testing purposes for those brave few. I've only tested it on Vanilla 1.1.2, but I've done it on both a root installation and a one level down installation both with and without the js/css packer installed/enabled and everything works for me.

    It ends up being a chunky extension (868KB ZIP file or 440KB RAR), but I think it's worth it just to make installation as simple as download, extract, upload, enable :)
  • I have asked MArk to increase the Extension size limit so far, it hasn't happened. FCKeditor cannot fit in 100kb. Can u guys send mark an Whisper or email and ask him to up the extension limit.
  • I'll send him an email t add to yours. I understand keeping a limit on extensions, but it would be good if he made exceptions to specific ones he knows are worth it, like yours Schiz :).
  • Mine isn't working. I've read this whole thread. I've installed, uninstalled, and reinstalled everything including the video folder. I've set it in the forum preferences. the box is checked but I get nothing.

    What's going on?
  • Get any errors? Enable it on your forum, give us a link to it and a login we can use so we can see what's going on.
  • I don't get any errors. It simply doesn't show up. The TinyMCE to work, but not this one. I will turn off the TinyMCE and turn on the FCK right now.

    here's the testing forum

    It's set to let anyone view it.

    EDIT: Sorry. Forgot to include the login

    NAME: Test User
    PASS: temp1234
  • You shouldn't have TinyMCE and FCKeditor enabled at the same time...
  • I don't. FCK is ON and Tiny MCE is OFF

    I didn't even have TinyMCE on the server when I first tried it.
  • hmmmm it was there. And NOW it's working. I guess the folder had to be "FCKeditor" instead of "fckeditor". I never changed that though. I figured it would be right by default. I also changed some permissions in hopes that it would work.

    I'll let everyone know if I come across anything else while using it.
  • Yeah, the "FCKeditor/fckeditr" thing has caught a lot of people out before...
  • Well, thanks again. You definitely put me in the right area to spot the problem.
  • Schiz, Mark's given permission for Lussumo Admins to upload large addons - fancy making those changes so it's just one download now? ;)

    And yes,I have asked if he can make it so that in the future it can be made so the extension authors can be given permission on a per extension basis to upload large addons ;)
  • No matter what I do, I can't get this toolbar to work.
    In fact, I can't seem to get any of my extensions to work, except for the sidebar. It's driving me NUTS!
  • Cool editor. Replaced tinyMCE in our forum for several reasons, not least of which is the ability to use a quote post function. Plus FCK seems to run much faster. Thanks for the good work!

    I used the Global Preference extension to set all current users VisualEditing to 1, but is there a way to set the FCKeditor default to on for new users as they join? Or do I have to go through the exercise of setting the global option every time a batch of new folks sign up?
  • Actually, here's a feature request. Please can we have an option in FCK that the admin can set to force the editor to be the only formatter (no choice of anything else) and so that users don't have an option to use it or not? I assume that if they don't have JS enabled they'll just get a plain text field where they can enter unformatted text? If so, this would be a nice mode for FCK from an admin's POV and a lot simpler for most users not to be given a choice (plus it'll solve dyohn's issue above).
  • Stash, MySchizoBuddy hasn't posted in this thread since July 17th (nearly a month ago)! I take that to mean his answers to your two questions will be long in coming! Makes one wonder if FCKeditor has fallen into the realm of abandonware!
  • Or he could just have been on a long holiday ;) I'm sure he'll be back, but as with all free ventures, they usually take a back seat to RL and work ;)
  • Thought folks following this thread would be interested to see that Yahoo just released their own WYSIWYG editor:

    Even more interesting, unlike FCKEditor it's Safari compatible:
  • unlike FCKEditor it's Safari compatible

    Do you mean "compatible with all versions of Safari"? Because AFAIK, current versions of FCKeditor are fully compatible with Safari 3. The problem is in getting the author of this Vanilla extension to update his silly action to remove the block on Safari 3 so we can fully test that point! The block was put in place because past versions of FCKeditor were not compatible with Safari 1.x or 2.x. But Safari 3 is a different story, hence my pleading for the removal of the Safari block. That's all I've been asking these past couple months since Safari 3 has been released. But alas, as Stash indicates, the author is on quite a lengthy vacation. How nice it would be if I could get a 2-3 month "vacation"!!!
Sign In or Register to comment.