Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

FCKeditor

This discussion is related to the FCKeditor addon.
1234568

Comments

  • having an issue w/ embedding url's... all ampersands in a link get changed to the html equivalent (i.e. & becomes & amp ;) and breaks the link. is there a fix?
  • I would like to make FCKeditor the default for all new users. Has anyone managed to do this?

    Thanks very much.
  • Teecee - the solution is:
    http://lussumo.com/community/discussion/5575/2/fckeditor/#Comment_67869
    That took me a long time to figure out too
  • It appears that FCKEditor in its default configuration can't change the colour of text (the preview works fine, but the post doesn't show the color).
    I understand that this is because it writes some
  • Hi guys, I got FCKEditor up and it works well for most part. There is an error when someone clicks on the Templates icon. An error dialogue pops up:

    ==
    Error loading "../../../../extensions/FCKeditor/fcktemplates.xml" (HTTP Status: 404).

    Do you want to see the server response dump?
    ==
    This is the server response dump:

    ==
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

    The page cannot be found





    BODY { font: 8pt/12pt verdana }

    H1 { font: 13pt/15pt verdana }

    H2 { font: 8pt/12pt verdana }

    A:link { color: red }

    A:visited { color: maroon }







    The page cannot be found

    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.



    Please try the following:



    Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.

    If you reached this page by clicking a link, contact

    the Web site administrator to alert them that the link is incorrectly formatted.



    Click the Back button to try another link.



    HTTP Error 404 - File or directory not found.
    Internet Information Services (IIS)



    Technical Information (for support personnel)



    Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.

    Open IIS Help, which is accessible in IIS Manager (inetmgr),

    and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.






    ==


    Appreciate any feedback on this, thanks!
  • S.O.S!
    I have done all the Readme.txt said to do, but I still can't see it work in FireFox.
    I can only see it in IE.
    Can anybody help?
  • I have an odd FCKeditor problem. It's fine in Firefox, but not in IE6.
    The toolbar shows correctly but you can't post anything that doesn't finish with a carriage return in IE6, e.g.

    "test" will give you an error message
    "test " is fine

    Posts that don't end with a carriage return return this error from Vanilla:

    "Some problems were encountered
    You must enter a value for the comments input."

    Any ideas please guys? Thanks very much.
  • I have two questions:

    1) Is there a way to giving smileys shortcuts like in vBulletin for instance? So typing an :) will return the smiley image and not a colon and a closing bracket?

    2) Is it possible for the extension to be ON by default?

    Great extension, btw!
  • Thanks a lot for that mpowrie! Absolutely brilliant.

    I fixed my problem of the 26th BTW. I have also found a way to disable TinyMCE, switch to FCKeditor, and get all of your old TinyMCE posts to format correctly with FCKeditor instead if anyone's interested...

    You just use SQL to change the value in the Vanilla Comments table from "tinymce" to "fckeditor".
  • no matter what, fck editor is not working in my forum

    www.socaltelugu.com/messageboard/
  • symbols are saved as html-entities if the user inputs in cyrrillic through fckeditor.. any way to preserve the original symbols? thanks
  • I've managed to add a Spell Check button to FCKEditor today. I used "SpellerPages" rather than "IE Spell" and it seems to work correctly in both IE and FireFox.

    These are the steps I followed:

    1. Edit js/fckeditor/fckconfig.js and change:

    FCKConfig.SpellChecker = 'ieSpell' ;

    to

    FCKConfig.SpellChecker = 'SpellerPages' ;

    2. For Linux you must also edit js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php and:

    comment out
    $aspell_prog = '"C:\Program Files\Aspell\bin\aspell.exe"';

    and uncomment
    //$aspell_prog = 'aspell';

    For a Windows server, you wouldn't do this. Note - I have only tested these steps on Linux, not Windows.

    3. Edit extensions/FCKeditor/config.js and:

    Add a "," to the end of this line:

    ['Link','Unlink','-','Smiley','SpecialChar','Image','-','Video','-','FitWindow' ]

    Then add a new line after it:

    ['SpellCheck']

    You may need to clear your browser cache and close/reopen your browser before this will work.
  • I'm not sure why I'm having trouble installing FCK.
    As stated in the Readme.txt, I downloaded the FCKeditor_2.6.3 package, as well as the latest extension package. Unzipped all, the copied all the files from the extension to "www/forum/extensions", which makes the path to the extension's default.php file this: "www/forum/extensions/FCKeditor/default.php".
    Then I copied the unzipped FCKeditor 2.6.3 package to "www/forum/js", which makes the path to the package's fckconfig.js file this: "www/forum/js/FCKeditor/fckeditor.js". (NOTE: I did have to rename the /js/FCKeditor folder from /js/fckeditor (previously in lowercase, now in upper) - not sure if this will make a difference).
    I've managed to enable the extension after changing the permissions on my extensions.php file to 7777 - otherwise didn't work. Once activated, I reverted the permissions.
    I log in as admin in Vanilla, and create a new post - but I cannot see the bars or anything, except for a radio button at the bottom of my text field that says "text". I cannot switch it as this is the ONLY radio button - there isn't a second choice.

    I'm trying to config this so it'll work, but I have a feeling something is missing somewhere. I'm not familiar enough with it, even after going through the config files, default files, js files, etc. I can't find the bug. Care to help out?
  • teecee,

    Thanks for spellcheck post. i have followed your instructions and I have the button showing and the spellchecker runs when I use it but keeps throwing an error! It says it cannot find 'C:\Program Files\Aspell\bin\aspell.exe'
    I assume this is becuase the spellchecker is looking for that file on my PC and its not there.

    My forum is held on a remote server.

    Any suggestions please?

    Cheers
  • Hello there, I just noticed there is now a 2.6.4 edition of this extension released out of Beta 31.1.09, I'm very new to Vanilla as in a couple of days, and would love to install it. Feeling a little lost at present.

    Will you be updating your installation? I'm not sure if there would be different download and installation Read.Me.

    Thanks in advance...
  • I'm keen on the latest version as well please, as it seems to be compatible with Safari.
  • It seems not an uncommon issue to have problems in getting this editor to work judging by many of the previous posts. I'm in the same situation, having downloaded the extension (version 2.5.4) and downloaded the editor itself and installed both into (AFAIK) the correct folders, made sure the permissions on the default.php were set to 750 (although nothing mentioned if that was necessary) I just cannot get the toolbar to display.

    I had the HTML Formatter installed before I attempted to install the FCKEditor and enabling FCKEditor removes the "Text/HTML" choices from below the Comment field - so something must be happening. I found the documentation a little unclear as to where the skin folders need to be loaded as they seem to appearin a few places but despite my effots nothing seems to change. In passing, the same unclear advice relates to the location of the Video folder - where should THAT go??

    I was also confused by the mention of a choice reportedly offered when the extension is installed to enable the editor for all users - and I never got offered any such choice - although I have enabled the graphical editor in the individual Member Account settings.

    From looking at the demo it seems this editor gives me exactly what I'm after so I'm reluctant to give up on it - particularly as it obviously DOES work (for some people). Any suggestions would be gratefully received.

    Dave

    Edited to add: The comment above about changing the name of the subfolder in the js folder to "FCKeditor" appears to be the key!! Having made that change the menu immediately works!!!
  • I upgraded FCKEditor to the latest version today and my forum now works properly with Safari:

    1. Download the latest FCKEditor from fckeditor.net and install this as per the intructions in the Extension's readme.txt
    2. Edit extensions\FCKeditor\default.php and change this:

    // only detect safari
    if ((stristr($navigator_user_agent, "konqueror")) || (stristr($navigator_user_agent, "safari")))
    {
    $browser = 'safari';
    $dom_browser = true;
    }
    return $browser;

    Just replace:
    $browser = 'safari';

    With something like:
    $browser = 'xxx';

    I also changed:
    $Context->Dictionary['VisualEditingPreference'] = 'Enable Visual editing toolbar (not compatible with Safari Browser)';
    to:
    $Context->Dictionary['VisualEditingPreference'] = 'Enable Visual editing toolbar (now compatible with Safari Browser)';
  • ^billdoody
    Sorry, I probably can't help you much. Are you on a Windows or Linux server? Check that and then review my notes.
    :o)
  • ah. I'm about on my tenth installation of this extention. I'm very confused about the directions, and have tried installing it with a web builder with no luck. would someone mind emailing me with some help? please???
  • ok I keep getting this in the text box where the editor should be, when I turn on the extention:


    Page Not Found

    The page you tried to access does not exist on this server. This page may not exist due to the following reasons:

    1. You are the owner of this web site and you have not uploaded (or incorrectly uploaded) your web site. For information on uploading your web site using FTP client software or web design software, click here for FTP Upload Information.

    2. The URL that you have entered in your browser is incorrect. Please re-enter the URL and try again.

    3. The Link that you clicked on incorrectly points to this page. Please contact the owner of this web site to inform them of this situation.

    Um, I've uploaded the thing a dozen times I thought I followed directions pretty well...
  • got it mostly working now.... some problems include the posts not saving the font size, video embedding window does not close, and the templates do not work....
  • Having a strange issue with adding video. When I add a youtube video and click "OK", I see the flash logo show up in the body but the video popup window doesn't auto close.... I either have to click cancel or click the "x" on the video pop up window for it to close. The video still shows correctly in the post. Why wouldn't the pop up auto close when clicking OK?
  • Just a thought here. The FCKeditor allows you to adjust the size of fonts (amongst other things). The problem is that this uses and by default FCKeditor doesn't allow style settings withing a . Took me a bit to figure that out, I enabled it and it all started working again. Not sure if there is a particular reason this is not allowed by default.
  • All installed OK. Had to capitalise the folder as mentioned here.
    The tweak for Safari (above from Teecee) also worked to fix it for Google Chrome. Very nice.
    Next, I'll try the "Global Preference" extension to see if I can force it on by default. (Set Extension,Go to its settings Enter VisualEditing and then 1 and click send).
  • For some reason the colour button does nothing - I get a colour change in the actual input field, but if I submit or preview it it doesn't change colour. Also if I hit edit, it will have colour in the edit field.

    Do I need some other extension to get this to work?
  • Also how do I get firefox spell checker to work so it doesn't just underline the word but also if you right click gives suggestions.
  • Im having the same problem as Leo.
    I've followed the instructions given, here and in the help me file. The tool bars still do not show up.

    Im now running 1.1.8 vanilla and the 2.5.4 Fckeditor.
    Can I get an install package that has everything enabled and I'll turn off what I do not want?

    Side note: In the config.js and setting.php, thoose line items are already in there. Do I need to add these lines again or in a different area in the file?
  • It's not working for me. My forum simply ignores the extension.

    Am I doing something wrong?

    Vanilla 1.1.2
    FCKeditor 2.4.1
    *************************************
    its not working for me either, tried it on every browser, i'm seeing nothing!!! note i'm also using notifi plugin, could there be a conflict?
  • this is long outdated.. can anyone post an update how this extension works with new FCKeditor ?
Sign In or Register to comment.