Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.




  • Options
    @ trolls and spode:
    Then they can go make their own extensions and call them Exclude and Excludes.
    The description of the extensions could be something like "Enables users to forgo their imaginations by only accepting the most commonly used synonyms. For every user who installs this extension we will tear up one (1) thesaurus and cause language graduates and enthusiasts to weep for the all-but-lost art of writing.".
    I see your point spode and thanks for mediating but for one thing I'm just having some fun (:-D), and for another thing it's obviously not causing them to understand the sentence incorrectly; they aren't suggesting the word be replaced by "includes" or "coffee mug".

    Is the force notification feature enabled or disabled? I think I will just remove that feature in the next version, it really doesn't serve any good purpose.
  • Options
    $mName = ''; if ($val[2] != '') { $mName = ' '.$val[2]; }

    There's no need to add an extra space there, as you do |Hello '.$mName.',| later on in the code. You can just do |$mName = $val[2];|. The extra space looks weird currently.
  • Options
    Would it be possible to add Jabber notification to this add-on? I was pointed out that would be helpful. Thanks for the plugin though, I'll be using it soon :)
  • Options
    I have 2 problems with Notifi & I'm hoping you can help. Thanks so much for all that you've done so far. 1. I'm subscribed to the entire forum but rarely get any emails telling me about an update. There seems to be no rhyme or reason as to what gets sent to me. I'd have like 8 new postings to the forum but get 1 email which only has 1 message in it. Any idea what's going on? 2. When I tried to upgrade to Notifi 2.0, it causes an error. Some directory error. I'll have to reinstall to get the error again.
  • Options

    @ in it so I reverted back to older version.

  • Options
    First of all, Thank You for this Add-On, SubJunk! But as all readers might have guessed already, I have a problem: I downloaded and unpacked version 2.0 as of 2008-12-29 yesterday. After copying the Notifi directory into the extensions directory of my vanilla development installation, which has got an URL of 4 directory levels deep under the web server's root URL, I could not see it in vanilla's extensions pane. I added two extensions afterwards (InlineImages and LightBox) which show up as expected. Remembering from earlier discussions that there once had been an issue of a missing brace I checked for a regression of that kind, but couldn't find one. Because I'm more the sushi kind of coder (smalltalk, ruby, python in order of personal preference) It may be of course that I'm missing something potentially obvious. Can anybody help me out? Lots of thanks in advance from a newbie to this community (although a frequent reader since about two years).
  • Options
    Here are some more details about my installation as an addendum to my posting of yesterday about Notifi not to be seen on the extensions adminstration page: Mac OS X 10.5.6 Apache 2.2.9 (as pre-installed by the OS with virtual host declarations for development, added by me) PHP 5.2.6 MySQL 5.0.51b (via socket) Vanilla version 1.1.5a List of Add-Ons before adding Notifi: AddMember 1.0, Attachments 2.1, BlogThis 1.14, PageManager 2.5.3, TagThis 1.07, Textile 2.0. As already mentioned I installed after Notifi: InlineImages 1.3, LightBox 2.03.3 - c. For the sake of completeness, the additional installed language is "Deutsch-formal" and some themes. Both (languages and themes) do not seem to have any influence on the behaviour described in my previous comment, as is the case with the browser used (Firefox 3.0.5 vs. Safari 3.2.1). Any clues will be highly appreciated. Thank you for your time!
  • Options
    Ok, I figured it out, and it was quite too obvious: After unpacking the zip file on Mac OSX the directory's right mask is 700 (drwx------), hence it could not be read by the web server process. Good ole command line... Sorry for polluting the thread.
  • Options
    You're right, I have changed it for the next version. Thunderbird (the email client I use) ignores double spaces so I never noticed it.

    I've never used Jabber, I don't even know what that is, but if you want to write some code that gives Notifi that functionality feel free to do it and we can work out some kind of release.

    @Left Brain:
    1) By default, Notifi will email you only once until you visit the forum. You can set it to email you every time a comment is made in your account settings, though.
    2) It would be good if you can paste that error into here so I can see it. Thanks

    I can't reproduce the bug, I have tried new installations and old ones and played with settings but can't make it produce those unwanted characters. Maybe it is a conflict with another extension, can you please tell me which other extensions you have enabled?

    I'm glad you found the solution, sorry I wasn't here sooner to try to help.
  • Options
    Jabber is an IM protocol. Google uses it for GTalk.

    I'll see if I can get something going later on.
  • Options
    Hi there,
    i was having a problem sending a non English texts over a notification email. Namely when the comment that is emailed to the subscribers contains such text. I pinpoint the problem to the
    htmlentities php function. Here is my resolution of the problem:

    $mComment = htmlentities($mComment, ENT_NOQUOTES, $DiscussionForm->Context->Configuration['CHARSET']);
    As one can see the default behavior of that function doesn't respect the character set of the application set in the configuration files. That's why i provide them manually and it works.

    Some aditional info:
    1. yeah ima using UTF-8 (default)
    2. I'm not using additional language that may override the default character set
  • Options
    SJ, first of all thanks for writing this extension! You have some great turnover and quick responses - that's awesome. Second, apologies if this has already been addressed, I did my best searching these forums but didn't find anything. Problem: None of the check boxes in my "Account Options"->Notifications stick. Whether I check or uncheck them, when I refresh the page it goes back to whatever it was. I have verified that the database values are not updated either (in the User table). I can change the behavior of the page if I manually manipulate the data in the database. Another small detail - I notice checking/unchecking the boxes is an Ajax call. I don't notice any kind of spinner or icon indicating an action is taking place when I check/uncheck these boxes. I am running a fresh 1.1.5a Vanilla install, and Notifi-2.0 is my only extension. Thanks for your attention.
  • Options
    Ok, figured out my problem. I dug through the source code and found that it's expecting Notifi to be installed in a folder called "Notifi" under extensions. I had installed it in "Notifi-2.0". I'm not sure if there's a way to detect the install path, but may I suggest removing the hard-coded path and replacing with a function call to get the actual install path. Alternatively (but not as good) you could release the source code packaged in a folder called "Notifi" that way we don't have to create our own under the extensions directory (and possibly do something silly like me). Thanks again for this useful add-on!
  • Options
    Ah yes that is something someone else suggested as well, I will try to remember it. If you look in readme.txt it does give instructions though, but you are right I shouldn't rely on people reading that.
  • Options
    Looks like Notifi might be interfering with JQMedia. Just having it activated breaks it. Has anyone else run across this?
  • Options
    That's not very surprising, because JQMedia is dependant upon the jQuery extension, which (like MooTools) changes the way JavaScript works and would therefore break Notifi which uses Vanilla's built-in JavaScript handler (Prototype).
  • Options
    Makes sense. I have a tad of JS training. How big of a hack would it be on Notifi?
  • Options
    If you know jQuery it wouldn't take long to hack Notifi to work with it if that's what you mean. There isn't a lot of code to change.
  • Options
    Not sure if this has been metioned - but the URLS in the e-mail sent out, aren't the friendly URLs.
  • Options
    @verbigena go to and filter by noConflict. It all comes to wrap your JQuery code in a special block.
Sign In or Register to comment.