Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla ProxyConnect

This discussion is related to the Vanilla Proxyconnect addon.
TimTim Operations Vanilla Staff
edited July 2010 in Vanilla 2.0 - 2.8
Vanilla ProxyConnect

Vanilla Forums COO [GitHub, Twitter,]



  • Awesome!
    I have to check this out!
  • Did anyone got this working? I tried on my local xampp with both fresh installations of wp2.9 and the latest vanilla2 without success. As soon as I enable Single Sign-on in vanilla, my vanilla forum seems to be inaccessible (white page, loading forever) and I can't log in to wordpress anymore (always get redirected to login-form after entering user & password).
  • MarkMark Vanilla Staff
    @flobster - try deleting your existing cookies for WordPress & Vanilla. Are your WordPress & Vanilla installations on the same domain?
  • Where can I download wordpress 2.9? The current stable version is 2.8.4 for me.
  • Also, I installed it using wordpress 2.8.3, and I get the following when I try to change the plugin settings in vanilla:
    It's a static page.
  • @nauthez - you can get the latest development version here:
    @Mark - that's what I did: clear cookies and close the browser. Does it matter where vanilla is installed? Currently I have a folder 'wpdev' (so on my machine, wordpress is at 'http://localhost/wpdev'), and within a sub folder, vanilla2 is installed ('http://localhost/wpdev/vanilla').
  • MarkMark Vanilla Staff
    @flobster - Hmmm. Strange. I thought it might be cookie related, but it might also be related to the fsock call that Vanilla makes to your WordPress AuthenticateUrl.

    Oh, and it should really work with WP 2.8.x also...
  • MarkMark Vanilla Staff
    It shouldn't matter where Vanilla is installed in relation to WP - it only matters that they're on the same domain (or related subdomains) like and or
  • MarkMark Vanilla Staff
    The fsock calls can be a pain. It's really what took the longest for me to get sorted out (about 4 hours). I'm concerned that different web servers respond differently to the request depending on the headers defined. If you want to see what I'm talking about, check out the fsock call here:

    You can see I've got some debugging code there to spit out the headers being sent and the response received...
  • Thanks @Mark, guess I'll have to give it a try 'in the wild'. When using the addon on localhost, there seems to be no proper defined domain. I realised the value 'Cookie Domain' in my vanilla config being blank, however inserting various values didn't make a difference.
  • Any chance of a port to Vanilla 1?
  • MarkMark Vanilla Staff
    Vanilla 1 was built with a different sso scheme in mind. I don't have time to try this kind of a port for Vanilla 1, but anyone is welcome to give it a shot...
  • ToddTodd Chief Product Officer Vanilla Staff
    I got this to work fine on localhost with leaving the domain blank. I am pretty sure that if Vanilla is in a subfolder of Wordpress then they can share cookies just fine.
  • It works for me too on localhost.
    Very nice module. I didn't know what CMS to choose for my new site but know vanilla/wordpress is a lot more appealing.

    Keep up the good work !
  • Still no luck on that add-on. Maybe this special issue is Vista-related. I remember having heard of certain difficulties concerning fsock calls.
  • is there an example of this online somewhere?
  • You can check mine out. Still working on the site so don't hate <3 <- blog <- forum

    This addon integrates the forum's login into the blog's login... so the blog's login is the only interface.
  • halp :)
    from conf/config.php
    $Configuration['Garden']['Authenticator']['AuthenticateUrl'] = '';
    $Configuration['Garden']['Authenticator']['SignInUrl'] = '';
    $Configuration['Garden']['Authenticator']['SignOutUrl'] = '';
    $Configuration['Garden']['Authenticator']['RegisterUrl'] = '';

    using WP 2.8.4 .... doesn't seem to work :(
  • I've disabled single sign on in the mean time.
    I've tried different combinations of URLs etc.

    IS it that I am not using WP 2.9 perhaps?
  • ok here's an update:

    2 questions:


    I have it working :) yay! (the step about uploading stuff to wordpress isn't very clear)

    once logged in the "edit my account" and "change my password" links are incorrect.

    I've found this in the source:

    applications/garden/controllers/profile.php: $SideMenu->AddLink('Options', 'Edit My Account', '/profile/edit', FALSE, array('class' => 'Popup'));

    Is there a way to over write these without tampering with the source files?


    How do I "administer" the forum? I'm logged in as an admin in wordpress, but don't have access to the admin of vanilla.

    and slightly relate, has anyone messed about with theme integration?
Sign In or Register to comment.