Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

ProxyConnect 1.8 Released

This discussion is related to the Vanilla Proxyconnect addon.
TimTim Operations Vanilla Staff
edited September 2010 in Vanilla 2.0 - 2.3
ProxyConnect 1.8 has been released.

This release changes the way we hook into signin and signout urls, with the intended side-effect of improving support for reliably logging users out of their local and remote sessions when they click "Sign Out".

Also included is a new way to integrate with Wordpress using our new Remote Integration Managers. Integrating with Wordpress is now a simple 2 step process.

Enjoy this release and be sure to report any bugs you find!

Vanilla Forums COO [GitHub, Twitter, About.me]

«1

Comments

  • Thankyou i have just installed wordpress now going to install vanilla soon when i get a host with PDO.
  • On a brand new, clean installation of 2.0.7 and ProxyConnect 1.8, I get the following error message when I choose 'WordPress Integration' in the Authenticator panel:



    Unable to create wordpress proxyconnect provider entry in GDN_UserAuthenticationProvider.

    Possible reasons:

    * Database was not created. Did you enable ProxyConnect properly, through the Plugins screen?
    * Does your database user have write permissions to the GDN_UserAuthentication* tables?

    ProxyConnect is definetely 'properly enabled' and as I'm on localhost, I guess permissions shouldn't be problematic (user role: admin).
  • Unfortunately things seem to get even worse:
    After disabling an re-enabling the plugin, the error described before disappeared and the add-on would save authentication settings, however, the signin / signout URLs seem to be totally messed up.
    My vanilla installation is at 'http://my-machine/dbtest/community/', when I try to sign in, vanilla keeps sending me to 'http://my-machine/dbtest/community/dbtest/community/entry/signin?Target=discussions' which of course brings up a 'Page not found' error. The only possibility to sign in again is via 'entry/password'.
  • Alright, decided to give manual integration a try, but it seems as if the settings are not saved. Whenever the page reloads or I click on activate, all the fields are blanked out.
  • TimTim Operations Vanilla Staff
    Please could you give me a screengrab of the contents of your Gdn_UserAuthenticationProvider table? Either from PHPMyAdmin or console

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • The plugin doesn't want to save any of my authentication settings. I can set the cookie domain but none of the sign-in, signout urls etc. Any help would be appreciated.
  • How can I send you the screengrab Tim?
  • TimTim Operations Vanilla Staff
    Send it in a private message in the forums here. Host it on imgur.com or something.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • edited September 2010
    Here's a screenshot from phpmyadmin:

    -- deleted --
  • Now that's what I call large...;)
  • TimTim Operations Vanilla Staff
    Alright I see the problem. I'll fix that shortly. My mistake.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • TimTim Operations Vanilla Staff
    Alright. Grab 2.0.8 and install it and you should get the 3 missing columns.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • TimTim Operations Vanilla Staff
    Hmm, this step might need a little work. I'll do some more testing quickly and see whats really causing the issue.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • What about that repeated URL?
  • TimTim Operations Vanilla Staff
    One step at a time :p This is still broken. if you check your mysql table definition for UserAuthenticationProvider, you'll see that URL is not allowed to be NULL. It SHOULD be allowed to be null.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • As far as I am concerned, there's no hurry...
  • I too had this problem - posted it in a different thread though.
  • really want to see integration with Data Life Engine(DLE)
  • So, er, what's happening here?
  • Any news on this?
    Eagerly waiting for a working version of this add-on, just like v1.6 was pretty fine (to a certain extent)...
  • Alright, have to admit this is working now.
  • edited October 2010
    Can someone please confirm if the integration of the registration process is working?
    While the sign-in / out process appears to be working as intended, the registration from within Vanilla is not affected at all. Regardless of settings (manual / auto), with proper values filled in, the 'Apply for Membership' link doesn't redirect to the WP registration URL as specified.
  • Someone managed to integrate it with Textpattern?
  • The plugin definitely has no effect on the registration process, however I found out that manually setting a registration URL in config.php has the desired effect:
    $Configuration['Garden']['Authenticator']['RegisterUrl'] = 'REGISTERURL';
  • I install and running Vanilla 2.0.10 and use ProxyConnect 1.8
    I have these conditions:
    WordPress script on http://mysite.com/wp/ but got live in http://mysite.com/
    and I install Vanilla on http://mysite.com/forum/

    When I login to WordPress and view the forum and login with the same credentials, it cannot login as admin, so I can not access the Vanilla Dashboard. But still be able to login as member.

    When I logout, I get redirected to WordPress login form, not to the forum page. Now, everytime I login to forum via forum 'Sign in' link, I get login automatically without providing password.

    I've curious and tell my friend in another place to click the 'Sign in' link forum, and he got logged in automatically with my last member account without providing password too, even he can change the profile picture. Weird.

    I think this is a big security issue and you should fix it as soon as posibble.
  • @rio That really sounds weird, however I don't think that it relates to a major security issue in either Vanilla or ProxyConnect. If you can access your Admin-Dashboard, try disabling ProxyConnect, properly clear your cookies and then maybe start anew. If you cannot acces your dashboard, maybe manually editing your config.php and removing everything related to ProxyConnect could help (without any warranty;).
  • edited October 2010
    @rio
    you are being logged in automatically because cookies have not expired or have been not been cleared.

    It is NOT a security problem except at public terminals in say Libraries, Universities and Schools when you should exit the browser rather than just log out, even rebooting the machine if necessary.

    You can always login to the admin interface (avoiding proxy authentication) via
    http://example.com/yourforum/entry/password
    but only to accounts e.g. the original admin account i.e. id/1 that have been setup explicitly with accounts in Vanilla rather than WordPress.
  • edited October 2010
    I'm stuck.. and my problem sounds a bit like Rio's issue.

    I have a WordPress 3.0.1 installation and I've created a brand new install of Vanilla 2.0.10 and installed ProxyConnect 1.8 with Manual configuration (since the WordPress auto config still gives me errors). At the very least, can someone tell me why my WordPress 3.0.1 won't allow ProxyConnectAutoconfigure? The only HTTP header that I'm seeing from the ProxyConnect WordPress plugin is:

    X-ProxyConnect-Enabled: yes
    No other ProxyConnect HTTP headers are displayed. This implies to me that WordPress isn't set up for autoconfigure.

    Moving on...

    Besides that issue, how is it possible that I can set up the brand new Vanilla install and log in as the admin on WordPress, then use the SyncScreen to link my WordPress admin account to my Vanilla admin account (upon the first Vanilla login)......and then create a brand new user in WordPress using a different email address, clear my cookies, clear my cache, restart my browser and log in to WordPress as that new user and go to Vanilla only to see I'm logged in as the Vanilla admin?? (i.e. the last user that was logged in)

    I've reinstalled Vanilla twice now, from scratch, and I get the same result every time. I don't understand how Vanilla can keep logging me in as the admin (or last logged-in user) when I'm doing everything in my power to clear my cookies/cache/history and log in as a new WordPress user. Even if I create additional WordPress users, they all log into Vanilla as the last Vanilla user to log in (the admin account in this case). I just can't get ProxyConnect to create a new Vanilla user no matter what I do.

    Please help.
  • edited October 2010
    Regarding ProxyConnectAutoconfigure, I've done fresh installs of WordPress 3.0.1 and WordPress 3.0 with Vanilla 2.0.10 and ProxyConnect 1.8 on a completely different domain (same server) and I still can't get WordPress to Autoconfigure with ProxyConnect and its WP3 plugin.

    Is everyone else here able to Autoconfigure Vanilla with WordPress 3.0+?

    (I'm also still experiencing the same-user bug described above by me and Rio)
  • @dan39 I guess sharing cookies across different domains is always problematic. Furthermore, AutoConfigure doesn't seem to work in a localhost environment, whereas it works fine when both WP and Vanilla are on the same domain (Vanilla in a subfolder).
«1
Sign In or Register to comment.