Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Sign In With Google Plugin Not Working

2

Comments

  • same prob. It doesn't work out of the box with a new install.
  • I fresh installed 2.0.17.2 but google&facebook sign in boxes does not work yet :(
  • edited January 2011
    @Todd @Tim @Mark

    With many of us having this problem, we're looking for some type of feedback. Is there something we can try or information that you need from us that may help you guys track down the cause of this bug?
  • Having the same issue as others on a fresh install of Vanilla.
  • Has anyone had the chance to test the latest version to see if this issue has been fixed?
  • I'm using the latest version of Vanilla and I'm having these issues. So yes it's been tested and no it's not fixed. :/
  • It's listed as fixed:
    http://vanillaforums.org/discussion/14397/vanilla-2.0.17-released

    Item # 11
    Fixed bugs in OpenID and GoogleSignIn where redirect targets were not getting sent to the signin.

    @ArrantSquid @ntuyelik @vincentw @djalecc @HerkesUzman @dnigrin

    I just updated to 2.0.17.8 and google login is still the same problem. What about you?
  • @chuckD I'll do an upgrade tonight and post back later to let you know.
  • Instead of an upgrade and to see what happens if I do a clean install, I downloaded 2.0.17.8 and I am still getting the same error message. This has become a frustrating experience with the google plugin.

    @ArrantSquid Did you have a chance to test? I'm hoping you got further than I did.
  • I found that you must enable openid before you enable googleid. that fixed the problem for me. my install was right out of the box
  • Nice catch, jjj! Hopefully it's also the solution for the others that had this problem.
  • Dear friends,

    I had issues with Google Sign In. First of all, you have to switch on OpenID plugin. If it doesn't work, you have to replace the file "class.lightopenid.php" in directory plugins/OpenID with it's newer version (you can find it here http://tinyurl.com/4gqvyce -- click "Raw blob data" and make sure you're saving this file with the name "class.lightopenid.php" replacing the old one).

    In newer version developers don't use deprecated PHP functions and use cURL instead. It works for me. Hope you'll enjoy the solution.
  • @jjj0923 as mentioned, openid is enabled.

    @Alibaba31337 I'll give this a try so hopefully it'll work.

    If not, I can tell them not to convert to vanilla and stick with vbulletin or xenforo. At least I tried.
  • CsabbencsCsabbencs
    edited March 2011
    I get the following error when try to sign in:
    Fatal Error in LightOpenID.discover(); No servers found! The error occurred on or near: ...\plugins\OpenID\class.lightopenid.php 372: throw new ErrorException('No servers found!');
    Vanilla Version: 2.0.17.8
    PHP Version: 5.3.0
    Browser independent.
    Can anybody help, please?
  • So, after some debugging...
    In class.lightopenid.php line 178, the function get_headers($url) returns nothing for the url https://www.google.com/accounts/o8/id.
    Any idea?
  • edited April 2011
    new to vanilla, very interested in using it - especially with Google Login since all my clientele have Google accounts. Doesn't work yet though on fresh install (in subdirectory www.domain.com/forums)
    You don't have permission to access /forums/entry/openid on this server.
    Possible solutions in this thread didn't work for me. Any solution available soon?

    --edit--

    Got it fixed, it appeared to be a server issue: the '403 Forbidden' error page that Google Login gave, was caused by mod_sec security setting blocking certain GET parameters. Got my site whitelisted for mod_sec (at hostgator), now works flawlessly.
  • @hanez Can you give a few more details please, how does someone get their site whitelisted for mod_sec? Does this have to do with .htaccess?

    I too keep getting a 404 error page at my own site in the pop-up whenever I try logging in with Google ID.
  • edited April 2011
    I got my site whitelisted at the support desk of my hosting provider (HostGator).

    Google signin did work straight away at another hosting provider I have, that's why I figured it had to be a server issue. I found the following topic at my hosting provider which shows similar problems:
    http://forums.hostgator.com/google-openid-response-triggering-403-t47709.html
    That's how I came up with this mod_sec thing, I don't really understand what it is/does either.

    To be sure, remember I got a 403 Forbidden error page (in page title pop-up), along with the message: "You don't have permission to access /forums/entry/openid on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."
  • @hanez Ah, okay. I'll contact my host, which is different.
  • Confirmed. It is server related, I had the same problem and contacted my host. They disabled the mod_security for my vanilla installation subdomain. Problem solved, but it leads me to another question regarding security. Is there any drawbacks with the mod_sec disabled?
Sign In or Register to comment.