Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Sign In With Google Plugin Not Working



  • Options
    Is there any drawbacks with the mod_sec disabled?
    I'd like to know that, too.

  • Options

    I have it working - brand new install.

    1. As mentioned above, get the new openid.php from:

    and name it class.lightopenid.php.

    1. Then modify line 7 from: $this->trustRoot = (!empty($_SERVER['HTTPS']) ? 'https' : 'http') . '://' . $_SERVER['HTTP_HOST'];
      $this->trustRoot = 'http://' . $_SERVER['HTTP_HOST'];

    to solve the Google error for Page requested is invalid.

  • Options

    I just upgraded from to to fix another issue and now the google sign-in is no longer working. Its giving the same error mentioned by others. All other sign-in methods do work still. I tried disabling it and openId, and re-enabling them in order but no luck... any help? thx in advance!

  • Options

    I have tried getting the latest versions of the google sign-in plugin and the open id plugin, as well as the latest lightopenid file. I made the modification mentioned by @AnalyticsEdge but still no luck. Finally, I found this page which suggests the google URL must have a slash at the end. This change my error from the 501 error to a "No servers found" message.

    Note google sign-in was working a coule days ago before upgrade. Now it is not. Even if I revert changes to previous version it no longer working. Perhaps a file permissions issue?

    Any suggestions?

Sign In or Register to comment.