Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Vanilla Extensions not Found

edited May 2006 in Vanilla 1.0 Help
Hi--I'm new to Vanilla and have it installed at http://www.collegechat.info/forum/ The version is 9.2.6 (which I assume is best to install as it was the default download from the getvanilla site). Whenever I copy ANY extension's .php file to the extension folder (I've tried several, including Signature, GoogleAds, PreviewPost, etc.) it does not show up in the extension manager. If I manually try to enable it by modifying the extension.php file, I get a bunch of errors (except in the case of PreviewPost--the preview button appeared but was not functional, and in the case of Signature, where all the options appeared but signatures weren't working). Maybe I'm using the wrong version extensions, but I never see anywhere which version is which. Thanks for the help. (P.S. Which default extension is used to allow HTML and how much HTML (which html tags) does it allow? Thanks.)
«13

Comments

  • Options
    Extension versions (and the v of vanilla they're designed for) should be shown on the publishers site and if not they should be written in the extension file itself.
    As for them not working, do you get a load of the whisper extension or just nothing atall? If you completely clear the extensions.php file what happens then? Are all the persmissions set correctly?

    As for the html question, sorry i'm not the man for that. I believe the one in use here is marks version (as on the wiki) and the raw html formatter allows anything whatsoever. If there are more than that or for some reason one or both of those have disappeared then i apologise.
  • Options
    Thanks for your reply. I might have phrased it wrong. All the default extensions (included with Vanilla) show up and work fine if I active/deactive them. The problem comes when I try to add custom extensions. I add them into the extensions folder via FTP but they do not subsequently appear in the extensions manager. Any suggestions? Thanks again, James
  • Options
    hm. And if you delete one of the default extensions what happens?
  • Options
    What are you suggesting I do? Remove one of the .php files for one of the default extensions via FTP from the extensions folder?
  • Options
    Any other ideas?
  • Options
    yeah. do that.
  • Options
    edited March 2006
    I tried removing one of the default extensions and as it should, it is removed from the extensions manager list. When I add it back, it is added back to the list. However, when I try to add ANY custom extension it does not appear on that list. Perhaps this has something to do with the version of my vanilla? However, I've tried several and none work or list the version of vanilla they should go with. edit: For example: http://michaelraichelson.com/hacks/vanilla/ Which version of vanilla are these for? They don't appear in the list when I add them.
  • Options
    edited March 2006
    Erk. Thats really rather odd and unfortunately i dont have a 0.9.2.6 installation to fiddle with nor can i recall ever coming across this error before. Can you double check that all the custom extensions youre uploading have all the same permissions as the default ones you've already uploaded? Beyond that i'm gonna have to get some sleep; with any luck someone can take care of you in the meantime. I'm pretty sure theyre all for 0.9.2.x. If you're doing the copy and pasting thing, try saving the files and just renaming them from phps to php. Worth a go incase your editor is doing anything funky.
  • Options
    edited March 2006
    Thanks for the help. I'll try that (although I think I did). I got the YellowFade extension to work by uploading it and then manually adding it to the extensions.php file. It still doesn't appear in the extension manager list, however. edit: but my yellow fade acts weird, it only "blinks" the text of the message, not the entire message block (including user name, etc.) as it does on here. not sure why. Edit: One more question. Assuming I can't get these extensions to work, I really do need to get Google Ads on here in the near future. Is there a simple way for me to input the ad code into one of these .php files without messing everything up? I don't care if it appears in the sidebar, or above/below posts, etc. I simply want one thing of ads on each page. Thanks for the help.
  • Options
    MarkMark Vanilla Staff
    edited March 2006
    Do all of your "new extensions" have the proper file extension? I notice that he's labelled them ".phps", but they should be ".php". The extension manager won't recognize them (and the php parser won't know what to do with them) otherwise.
  • Options
    edited March 2006
    Yes, I've done .php for all of them. edit: Any other suggestions?
  • Options
    And if not, any tips on which file I should paste the adsense code into manually?
  • Options
    MarkMark Vanilla Staff
    What are the errors you get if you manually try to add an extension to the extensions file?
  • Options
    I can manually add extensions to the extension file without errors in some instances (for example, the Yellow Fade). However, other ones give a bunch of errors. For example, when I try to manually install the Google Ads plugin, all my pages on the forum return this error: Parse error: parse error, unexpected $ in /homepages/1/d154684333/htdocs/collegechat/forum/extensions/GoogleAds.php on line 83 Thanks for all your help--hopefully I can get this sorted out.
  • Options
    More errors (when trying to install WhosOnline.php manually): Warning: main(/homepages/1/d154684333/htdocs/collegechat/forum/extensions/WhosOnline.php): failed to open stream: No such file or directory in /homepages/1/d154684333/htdocs/collegechat/forum/appg/extensions.php on line 11 Warning: main(): Failed opening '/homepages/1/d154684333/htdocs/collegechat/forum/extensions/WhosOnline.php' for inclusion (include_path='.:/usr/local/lib/php') in /homepages/1/d154684333/htdocs/collegechat/forum/appg/extensions.php on line 11
  • Options
    The only thing I can come up with is that the files are getting messed up during the FTP upload. You could try uploading in binary mode.
  • Options
    I don't think that's it because every other file I've uploaded has worked out fine. I'm using Fugu/Cyberduck on OS X any ideas how to do that?
  • Options
    edited March 2006
    Hmm... I just did a test on my server, and it seems that vanilla doesn't like Mac-style linebreaks very much. This may be the source of your problem. Unfortunately, I've never used OS X, so someone else will have to help with that.
  • Options
    shoot... i wonder if downloading a different text editor aside from TextEdit will help? actually, while i'm at it, maybe using dreamweaver to do the php files? or is just the fact that i'm on os x going to mess it up?
  • Options
    OK--got some of them working now by saving in Dreamweaver instead of TextEdit. Can't believe that may have fixed it. I'll let you guys know if there's still any problems. Thanks a lot for all the help!
This discussion has been closed.