Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

How can I localise/translate Vanilla easily?*

magrufmagruf New
edited April 2013 in Localization

Hi everyone, fisrt of I want to mention that I searched the forum about my question before ask this. I try to translate the Vanilla into Turkish. I have found some guide/tips on your website but I do not understand exacly how I will do. Becouse some of them saying that the language plugin neet to be under /locales folder some of them saying into /applications folder as file...

I also tried t odo this but not (http://vanillaforums.org/docs/converting-locales)

Could you please someone explain how I can do it easily, step by step.
Becouse it seems translation file are ready to use but no explanation how?

Turkish translations: https://www.transifex.com/projects/p/vanilla/language/tr_TR/

Thanks in advance

«134

Comments

  • First you might want to contribute to that project

    http://vanillaforums.org/discussion/20639/attention-translators-you-can-now-help-translate-vanilla-online/p1

    Second add it to /locales folder, then go

    /settings/locales

    then enable it.

    then set "Default Locale" then save.

    grep is your friend.

  • magrufmagruf New
    edited April 2013

    Thanks for reply.
    But the main problem that even if if I can do , it doesn't work.

    There are 3 different resource

    Archive- no need
    Core
    Dashboard

    Here is announcement about it.

    • site_core contains the text for the site. If you just want to translate the public portion of the site then translate this resource.
    • dash_core contains the text for the dashboard. Translate this file if you need everything translated.

    It is very clean explanation but how it will be added?
    For example, in order to translate just frontend should we added it like this?

    /locales/turkish/definitions.php

    and afterthat enable it ?

    I did it but now I got some errors :)

    Now website is not work :)

    I really need a clear explanation...

  • you have a wider issue than just locale.

    IsWritable should be in library/core/functions.general.php

    what version of vanilla do you have?

    grep is your friend.

    twhook
  • I have just installed 2.0.18 for test.

  • well that function exist in 2.0.18

    are you sure you copied all the files across, and set up permissions correctly?

    grep is your friend.

  • I presume you mean 2.0.18.8?

    grep is your friend.

  • magrufmagruf New
    edited April 2013

    Sorry, yes it is 2.0.18.8 and now installed new again. http://zahek.net/v3/
    Let me try again the same I explained above?

    Edit: What permission you mean?

  • magrufmagruf New
    edited April 2013

    No problem on permissions, they are 0755

  • you have a file

    library/core/functions.general.php

    grep is your friend.

    twhook
  • Yes, but its perm. was 0644, I changed it 0755. Now it is ok?

  • does it contain IsWritable?

    grep is your friend.

  • magrufmagruf New
    edited April 2013

    Yes it has.

    Here: http://codepaste.net/56o15s

  • Ok can you try it then?

    grep is your friend.

  • magrufmagruf New
    edited April 2013

    Done and result :)

    Fatal error: Call to undefined function Iswritable() in /home/zaheknet/public_html/v3/library/core/class.filesystem.php on line 271

    Edit: Sorry it can be my foult. Let me try again.
    Edit1: No same :(

  • hmm I can't try it right now but will get back to it. If anyone would like to check 2.0.18.8 , give it a shot.

    grep is your friend.

  • @magruf,

    Perhaps you are going about it wrong.

    1) download the transiflex here.

    http://vanillaforums.org/get/vf_tr_tr-locale-2012.10.23p1110

    2) extract the zip file.

    3) copy the folder to locales

    e.g.

    locales/vf_tr_TR

    NOT locale/turkish

    4) enable the plugin

    5) click visit site

    6) go back to dashboard and choose default locale tr-TR

    worked perfectly for me and got it going in 2 minutes on vanilla 2.0.18.8

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I really do not understand what is wrong.
    I installed new Vanilla and done as you said above step by step but result is this.

    http://www.zahek.net/vtest/

    Fatal error: Call to undefined function Iswritable() in /home/zaheknet/public_html/vtest/library/core/class.filesystem.php on line 271

  • hgtonighthgtonight ∞ · New Moderator

    @magruf, what browser are you using? Do you know how to inspect network requests?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • @hgtonight, I am using Opera. I know dev. tool and use but not more.
    @peregrine, BTW, I tried it again in local machine and worked. It is very strange.

  • His problem is the core is not loading properly.

    What version of php do you have?

    grep is your friend.

  • magrufmagruf New
    edited April 2013

    Apache : 2.2.22

    MySQL : 5.1.68-cll

    PHP : 5.2.17

  • x00x00 MVP
    edited April 2013

    try

    $ php -a
    php > error_reporting(-1);
    php > define('APPLICATION',TRUE);
    php > define('PATH_LIBRARY',"/path/to/forum/library");
    php > require PATH_LIBRARY."/core/functions.general.php";
    php > exit;
    

    substituting /path/to/forum/library

    grep is your friend.

  • Sorry I am not a developer. You mean to save it and put the folder /library or run these commands?

  • hgtonighthgtonight ∞ · New Moderator

    @magruf Run those commands in a terminal (command, console, term, etc.)

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • you could also create a file test.php and point to it.

    <?php
    error_reporting(-1);
    define('APPLICATION',TRUE);
    define('PATH_LIBRARY',"/path/to/forum/library");
    require PATH_LIBRARY."/core/functions.general.php";
    exit;
    

    grep is your friend.

  • magrufmagruf New
    edited April 2013

    It gaves an error when to run these file. It seems the error regard with PHPMyadmin?

    Warning: require(/path/to/forum/library/core/functions.general.php) [function.require]: failed to open stream: No such file or directory in /home/zaheknet/public_html/vtest/library/test.php on line 5

    Fatal error: require() [function.require]: Failed opening required '/path/to/forum/library/core/functions.general.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/zaheknet/public_html/vtest/library/test.php on line 5

  • did your non-local forum run ok before trying to translate? Or did it just stop working when you tried to translate.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Yes peregrine, zahek.net is a live server and I can run Vanilla without problem. Both last stable version and beta version.
    But when I try to translate it downs. Actually It happens once to choose tr-TR option after enable the plugin.

  • peregrineperegrine MVP
    edited April 2013

    do you have any duplicate translations directories lying around? if so delete all of them.

    1 - especially the one in the locale directory.
    can you post a directory listing of your locale directory.

    2 - can you post of what is inside conf/constants.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

«134
Sign In or Register to comment.